Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Booting today stalls system and I con only boot from previous kernel using advanced options

  1. #11
    Join Date
    Nov 2008
    Posts
    2,479
    Blog Entries
    1

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Not sure how to do this now as there is no longer any line for parameter entry in the boot screen. I used E and then added what you suggested but as the machine cannot complete I cannot examine the log or anything else.

  2. #12
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,402

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Quote Originally Posted by Budgie2 View Post
    ... I used E and then added what you suggested but as the machine cannot complete I cannot examine the log or anything else.
    No useful text displayed on the terminal before the kernel panic as it attempted to boot?

    You could boot from the working kernel and then look at the log for boot that failed. But if the kernel panic is very early there may not be anything written to the log...
    Regards, Paul

  3. #13

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Hi:
    I also have a bad experience regarding yesterday's upgrade of kernel form 5.14.21-150400.24.18-default (64-bit) to 5.14.21-150400.24.21-default (64-bit). After reboot the system did not run any more and ended with a screen of "kernel panic". I had to use previous kernel at the boot screen.
    he output of the inxi -SGaz --vs command is as follows:
    Code:
    inxi 3.3.21-00 (2022-08-22)
    System:
      Kernel: 5.14.21-150400.24.18-default arch: x86_64 bits: 64 compiler: gcc
        v: 7.5.0 parameters: BOOT_IMAGE=/vmlinuz-5.14.21-150400.24.18-default
        root=UUID=85cb5677-e732-4bcf-b769-b98aee0a5c3c splash=silent
        mitigations=auto quiet
      Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 7
        dm: SDDM Distro: openSUSE Leap 15.4
    Graphics:
      Device-1: NVIDIA TU106GLM [Quadro RTX 3000 Mobile / Max-Q]
        vendor: Hewlett-Packard driver: nvidia v: 470.141.03
        alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
        2022-08) arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie:
        gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
        active: none off: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0
        chip-ID: 10de:1f36 class-ID: 0300
      Device-2: Quanta HP HD Camera type: USB driver: uvcvideo bus-ID: 1-7:3
        chip-ID: 0408:5347 class-ID: 0e02 serial: <filter>
      Display: x11 server: X.Org v: 1.20.3 with: Xwayland v: 21.1.4
        compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
        unloaded: fbdev,nouveau,vesa alternate: nv gpu: nvidia,nvidia-nvswitch
        display-ID: :0 screens: 1
      Screen-1: 0 s-res: 1920x1080 s-dpi: 128 s-size: 381x211mm (15.00x8.31")
        s-diag: 436mm (17.15")
      Monitor-1: DP-6 pos: primary res: 1920x1080 hz: 60 dpi: 128
        size: 382x215mm (15.04x8.46") diag: 438mm (17.26") modes: N/A
      Monitor-2: eDP-1-1 size-res: N/A modes: N/A
      OpenGL: renderer: Quadro RTX 3000/PCIe/SSE2 v: 4.6.0 NVIDIA 470.141.03
        direct render: Yes
    I sought help at Linuxquestions forum and got an opinion that I am using NVidia's proprietary drivers, and something went wrong in the new kernel's initrd trying to include them. Also I was told that inxi output shows all good running kernel 5.14.21-150400.24.18, with proprietary NVidia drivers installed for graphics. So, I have been suggested to ask an NVidia forum, so as to attract expert attention.

    So, please advice.
    Regards,
    Bojan

  4. #14
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,402

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Quote Originally Posted by Bojan View Post
    ... Also I was told that inxi output shows all good running kernel 5.14.21-150400.24.18, with proprietary NVidia drivers installed for graphics. So, I have been suggested to ask an NVidia forum, so as to attract expert attention.

    So, please advice.
    Perhaps do as suggested and ask on nvidia's forum: https://forums.developer.nvidia.com/...hics/linux/148

    As an aside, you've tagged your Leap 15.4 problem onto one concerning 15.3
    Regards, Paul

  5. #15
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,402

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    @Budgie2

    You'd be venturing into rather deep waters with this, but, you could use kexec/kdump to save the dump of the crashed kernel.

    "Kexec preserves the contents of the physical memory. After the production kernel fails, the capture kernel (an additional kernel running in a reserved memory range) saves the state of the failed kernel. The saved image can help you with the subsequent analysis."

    Details of it's use here: https://doc.opensuse.org/documentati...ing-kexec.html
    Regards, Paul

  6. #16
    Join Date
    Nov 2008
    Posts
    2,479
    Blog Entries
    1

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Hi Paul,
    Sorry for the delayed reply. Not been a good week. In spite of having had all the four previous jabs I have succumbed to the dread Covid virus. No idea where it came from but apparently the present version is much more infectious than earlier ones. The effect has been much worse than I anticipated. At sometime during the past week my media NAS died so I am slowly surfacing to a whole bunch of problems. Still too befuddled to get my head around Kexec but it looks like just the tool I need so many thanks. Will report progress in due course.
    Thanks again.
    Alastair.

  7. #17
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,402

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Quote Originally Posted by Budgie2 View Post
    ... Still too befuddled to get my head around Kexec but it looks like just the tool I need so many thanks. ...
    Yes, I think you need to be bright eyed and bushy tailed there. Wishing you a full and hopefully fairly swift recovery.

    I had my fourth vaccination earlier this week, I've managed to avoid covid-19 so far, (hope that's not talking it up).
    Regards, Paul

  8. #18
    Join Date
    Nov 2008
    Posts
    2,479
    Blog Entries
    1

    Default Re: Booting today stalls system and I con only boot from previous kernel using advanced options

    Hi Paul,
    Covid was not much fun and has left me knackered but my positive test was only last Tuesday and my family say I should give it 10 days.

    Meanwhile having noted some troublesome inconsistent behaviour on rebooting I thought my problem might point to an hardware issue.
    I gave my HP Z640 a good clean with a compressed air jet, reseated all the memory and the second processor board and now ... no more kernel panic or problems with NIC.
    No idea why this had been lurking undetected for so long but seems all is now OK.
    Will close this now.
    Thanks for the help along the way.
    Regards,

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •