Results 1 to 8 of 8

Thread: Brak możliwości połączenia ze zdalnymi katalogami SMB

  1. #1

    Default Brak możliwości połączenia ze zdalnymi katalogami SMB

    Witam!
    Zainstalowałem Open SUSE Leap 15.2
    Nie mogę się połączyć z udziałami SMB w mojej sieci lokalnej. Mam dwa dyski NAS, mam udostępnione katalogi na innych komputerach z windą. Inne komputery z Windą wszystko widzą i bez problemu się łączą. Widzę i bez problemu obsługuję te udziały też z urządzeń z Androidem. Mam dwa komputery z linem, jeden ze wspomnianym SUSE u drugi z Kubuntu, Żaden nie odczytuje zasobów SMB. Chyba nie umiem tego skonfigurować.
    Dolphin nie wyszukuje w ogóle udostępnionych zasobów, ale gdy wpiszę mu np w ścieżkę adres jednego z moich NAS, czyli SMB://192.168.7.190/Public to otrzymuję komunikat: Połączenie z gospodarzem 192.168.7.190 zostało przerwane.
    Gdy próbuję zamontować ten wspomniany udział gdzieś w drzewie katalogów, to mount wypisuje mi o niezgodności wersji smb, jako możliwa przyczyna problemów. Ale nie jest ważne, czy wpiszę vers=1.0, zawsze efekt jest taki sam.
    Dodatkowo z urządzeń z Androidem w aplikacji do obsługi zdalnych katalogów mogę sobie wybierać wersje smb, po których mogę się łączyć, 1.0 2.1 czy 3.0 i niezależnie kórą wersję wybiorę połączenie jest prawidłowe i szybkie.
    Tylko SUSE i Kubu mają u mnie problem.
    Czy ktoś może spotkał się z podobnym problemem i jakoś sobie poradził? Jak są potrzebne jakieś zrzuty ekranów, to powiedzcie jakie. Służę.

    Z góry dziękuję za pomoc.

    A! Jeszcze próbowałem wpisać w konsoli

    smbclient -L 192.168.7.190

    otrzymałem komunikat:

    protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

    Jeszcze raz pozdrawiam!

  2. #2
    Join Date
    Aug 2021
    Location
    Wolne Miasto
    Posts
    73

    Default

    Szczerze mówiąc nie posiadam żądnego NAS, kiedyś tam dawno temu próbowałem połączyć w celu wymiany plików Win10 z Linuksem. Ale do rzeczy. Nie napisałeś ile wiosen mają twoje NAS, choć po tym jak wspomniałeś o ver=1.0 domyślam się że mogą mieć sporo. Być może odpowiedz znajdziesz tu ---> https://www.theregister.com/2022/03/...16_toctou_smb/
    tak wiem to z tego roku, a Ty wspominasz o Leap 15.2 - co w sumie jest dziwne.
    Pewnie nie pomogłem....

    Przeczytałem jeszcze raz twój post, i wyczytałem że jesteś w stanie z Androida połączyć się z dyskami na różnych wersjach protokołu, a kiedyś w ogóle działały ?
    Last edited by pbojczuk; 21-Aug-2022 at 06:19.
    Moja strona domowa: https://pietraszczyk.vxm.pl

  3. #3

    Default

    Racja. Oczywiście to literówka w tym 15.2.
    Nie wiem, czy dobrze zrozumiałem ten artykuł, ale nie znalazłem w nim rozwiązania mojego problemu. Może przeczytam go jescze kikla razy
    Tak, moje NAS maja już swoje lata i jest prawdopodobne, że pracują na starych protokołach, jednak tak, jak wspomiałem, w aplikacji na Andrida obsługującej SMB i zdalne katalogi bez problemu, mogę zaznaczyć z którego protokołu chcę korzystać. 1.0, 2.1 itd. I przy każdym wszystkie katalogi są dostępne bez problemów. Komputery z Windą 10 też je widzą. Tylko Suse i Buntu nie. Nie tylko udziałów z urządzeń NAS, ale też udostępnionych z komputerów z Windą. No nic szukam dalej... Ale dziękuję za zainteresowanie.
    Pozdrawiam.

    Quote Originally Posted by przem View Post
    Przeczytałem jeszcze raz twój post, i wyczytałem że jesteś w stanie z Androida połączyć się z dyskami na różnych wersjach protokołu, a kiedyś w ogóle działały ?
    Jeżeli chodzi o lina, to działało kiedyś na Ubu 18.... coś tam LTS. Nie pamiętam który dokładnie to był. Potem długi czas nie włączałem komputeraz ubu. No... klika lat. Teraz mam dwie distro opisane w pierwszym poście i nie mogę sobie poradzić z połączeniem.

    Utworzyłem udział sieciowy na SUSE. Jest widoczny przez urządzenie z Androidem. Jest widoczny przez komputery z windą. Nie jest widoczny przez komputer z Ubu. SUSE nadal nie widzi żadnego z sieciowych udziałów. To znaczy, Dophin ich nie wyszukuje, a gdy się je adresuje bezpośrednio, to komunikat

    Połączenie z gospodarzem hostIP/nazwa_hosta zostało przerwane

    NIc. Walczę dalej. W końcu musi się coś udać. Coś przecież musi być gdzieś w ustawieniach, plikach konfiguracyjnych, tylko nie mogę znaleźć co to...

    P.S.
    Przecież, chyba Winda 10 nie posługuje się starym SMB...?

    Last edited by pbojczuk; 21-Aug-2022 at 06:20.

  4. #4
    Join Date
    Dec 2017
    Posts
    151
    Blog Entries
    15

    Default Re: Brak możliwości połączenia ze zdalnymi katalogami SMB

    Quote Originally Posted by Dyrszlak View Post
    A! Jeszcze próbowałem wpisać w konsoli

    smbclient -L 192.168.7.190

    otrzymałem komunikat:

    protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

    Jeszcze raz pozdrawiam!
    https://www.suse.com/support/kb/doc/?id=000020299

    Działa?

  5. #5

    Default Re: Brak możliwości połączenia ze zdalnymi katalogami SMB

    Przeczytałem. Wpisałem wg instrukcji:

    mbclient -L WAP-0008 -U mk -m SMB2

    Wyskoczyło:

    lpcfg_do_global_parameter: WARNING: The "domain logons" option is deprecated
    do_connect: Connection to WAP-0008 failed (Error NT_STATUS_NOT_FOUND)

    Skoro nie skumał nazwy hosta (a inne urządzenia w sieci ją rozpoznają!!!) to spróbowałem z IP hosta:

    mk@zlewozmywak:~> smbclient 192.168.7.190 -U mk -m SMB2
    lpcfg_do_global_parameter: WARNING: The "domain logons" option is deprecated
    Password for [WORKGROUP\mk]:


    192.168.7.190: Not enough '\' characters in service


    Za mało \ (backslashy) !!??. Przepraszam, co to znaczy? w Windowsie to używałem tych znaków...

    Ale jeżeli chodzi ciągle o ten protokół SMB2, to jak zmusić zmianę tego protokołu, żeby stare NAS można było obsłużyć z poziomu SUSE?

    Choć mi się wydaje, że to coś nie tędy droga, choć komunikaty się zmieniły. Nie wierzę, żeby winda 10 pracowała na pierwszej wersji SMB. Poza tym, dlaczego aplikacja Androida działa niezależnie, który protokół w niej wybiorę? Mimo tego, że oba NAS mają ponad 10 lat.

    Ale i tak Dziękuję za odpowiedź.

  6. #6
    Join Date
    Dec 2017
    Posts
    151
    Blog Entries
    15

    Default Re: Brak możliwości połączenia ze zdalnymi katalogami SMB

    Nie, wiem, nie używam SMB, ale zobacz, jak tego używają inni - spróbuj tych kroków:
    https://forums.opensuse.org/showthre...18#post2979418

  7. #7

    Default Re: Brak możliwości połączenia ze zdalnymi katalogami SMB

    Bardzo jestem wdzięczny za zainteresowanie i Twój czas.

    Poczytam ten wątek i poinformuję, co mi z tego wyszło.

    Pozdrawiam.

  8. #8

    Default Re: Brak możliwości połączenia ze zdalnymi katalogami SMB

    Quote Originally Posted by pbojczuk View Post
    Nie, wiem, nie używam SMB, ale zobacz, jak tego używają inni - spróbuj tych kroków:
    https://forums.opensuse.org/showthre...18#post2979418
    Super!

    Naprawdę dziękuję!

    Poczytałem, powalczyłem i udało mi się podłączyć do starych NAS moje SUSE. Ubu nadal jest oporne, ale mniej mi zależy. Już tylko dla satysfakcji będę rozgryzał. Najważniejsze, to dla mnie podłączenie SUSE do dysków NAS.

    Ciągle jeszcze mój SUSE nie widzi udziałów z komputerów z windą, ale to już też jakby mniejszy problem, bo tak naprawdę udziały NAS są dla mnie najważniejsze.
    No i jednak wygląda mi na to, że chodziło o te nieszczęsne protokoły.

    Przede wszystkim w pliku /etc/samba/smb.conf w sekcji [global] muszą się znaleźć wpisy:

    client min protocol = NT1client max protocol = SMB3

    Bo inaczej domyślnie protokół NT1 jest obcinany i nieużywany.

    Z windami jest jakiś problem z logowaniem. Ale to już spokojniej powalczę i popróbuję. Jak mi się uda, to skrobnę coś, może się komuś kiedyś przyda, jak sobie wyszuka ten wątek.

    Pozdrawiam!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •