Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

  1. #1
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Just upgraded a system 15.3 > 15.4 with the on-line method. All went fine and the main functionality (inclusing Apache, MySQL) runs fine.

    Having problems with my user. Apart from annoyances as apparently lost configurations on several desktop aspects, main concern is now that Kontact (where I have Kmail, Kaddressbook, Akregator, etc. running) segfaults after a few seconds.

    I tried the several components separately.
    KAddressBook seems to run OK (but looks very different from what it was Sigh!

    Akkregator started from the konsole. It shows a window with Akregator did not close correctly do you want t restore the previous session? If I click Restore Session, or Do Not Restore sesssion, in both cases after a few secs segfault:
    Code:
    henk@boven:~> akregator
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    Connection to speech-dispatcher failed
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=664,665,666"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=668,673,674"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=669"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=676"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=670"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=672"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=675"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=934"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=679"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=680,783,805"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=678,807,692"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=683,685,686,687"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=689,690"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=861,862,864,865,866,868,869,871,872,873,874"
    KCrash: Application 'akregator' crashing...
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi
    
    [1]+  Gepauzeerd              akregator
    henk@boven:~>
    kmail. It floods the konsole and blocks the system for at least 15-15 secs, It ends with
    Code:
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor
    [warn] epoll_wait: Bad file descriptor*** KMail got signal 11 (Exiting)
    *** Dead letters dumped.
    Timersignaal
    I can also add as background that SDDM segfaults (I used update-alternatives to switch to LighDM, else Graphical login impossible).

    Vague isn't it? I will investigate further, but may be someone has a suggestion.
    Henk van Velden

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,321

    Default AW: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Post:
    Code:
    zypper lr -d
    Do you get anything by:
    Code:
    zypper dup --allow-vendor-change
    and
    Code:
    zypper se -si | grep -Ei 'systemp|sytem_p|system-p|system p'
    What about creating a new User and logging in there?

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default Re: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Code:
    boven:~ # zypper lr -d
    #  | Alias                       | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                               | Service
    ---+-----------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
     1 | backports-debug-update      | Updates for debuginfo from openSUSE Backports                                               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.4/backports_debug/                    | 
     2 | backports-update            | Updates from openSUSE Backports                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/backports/                          | 
     3 | libdvdcss                   | Libdvdcss                                                                                   | No      | ----      | ----    |   99     | NONE   | http://opensuse-guide.org/repo/openSUSE_Leap_15.4/                                | 
     4 | main                        | Main (OSS)                                                                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.4/repo/oss/                     | 
     5 | main-debug                  | Debug (OSS)                                                                                 | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.4/repo/oss/               | 
     6 | main-debug-update           | Update-Debug (OSS)                                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/oss/                          | 
     7 | main-source                 | Source (OSS)                                                                                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.4/repo/oss/              | 
     8 | main-update                 | Update (OSS)                                                                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/oss                                 | 
     9 | network_utilities           | network:utilities                                                                           | No      | ----      | ----    |   99     | rpm-md | https://download.opensuse.org/repositories/network:/utilities/openSUSE_Leap_15.3/ | 
    10 | non-oss-debug               | Debug (Non-OSS)                                                                             | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.4/repo/non-oss/           | 
    11 | non-oss-debug-update        | Update-Debug (Non-OSS)                                                                      | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/non-oss/                      | 
    12 | non-oss-main                | Main (Non-OSS)                                                                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.4/repo/non-oss/                 | 
    13 | non-oss-source              | Source (Non-OSS)                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.4/repo/non-oss/          | 
    14 | non-oss-update              | Update (Non-OSS)                                                                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/non-oss/                            | 
    15 | packman                     | Packman                                                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/               | 
    16 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.4/backports_debug/                    | 
    17 | repo-backports-update       | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/backports/                          | 
    18 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/sle/                          | 
    19 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/sle/                                | 
    20 | sle-debug-update            | Updates for debuginfo from SUSE Linux Enterprise 15                                         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/sle/                          | 
    21 | sle-update                  | Updates from SUSE Linux Enterprise 15                                                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/sle/                                | 
    22 | teams                       | teams                                                                                       | No      | ----      | ----    |   99     | rpm-md | https://packages.microsoft.com/yumrepos/ms-teams                                  | 
    boven:~ #
    Code:
    boven:~ # zypper dup --allow-vendor-change
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    The following 33 items are locked and will not be changed by any action:
     Available:
      PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE PackageKit-gtk3-module
      libpackagekit-glib2-18 libply-boot-client5 libply-splash-core5 libply-splash-graphics5 libply5 plymouth
      plymouth-branding-openSUSE plymouth-branding-upstream plymouth-devel plymouth-dracut plymouth-lang
      plymouth-plugin-fade-throbber plymouth-plugin-label plymouth-plugin-label-ft plymouth-plugin-script
      plymouth-plugin-space-flares plymouth-plugin-tribar plymouth-plugin-two-step plymouth-scripts
      plymouth-theme-bgrt plymouth-theme-breeze plymouth-theme-breeze-plugin-breeze plymouth-theme-fade-in
      plymouth-theme-script plymouth-theme-solar plymouth-theme-spinfinity plymouth-theme-spinner
      plymouth-theme-tribar samba
    
    The following 15 packages are going to be upgraded:
      ffmpeg-4 libavcodec58_134 libavdevice58_13 libavfilter7_110 libavformat58_76 libavresample4_0 libavutil56_70
      libheif1 libjavascriptcoregtk-4_0-18 libpostproc55_9 libswresample3_9 libswscale5_9 libwebkit2gtk-4_0-37
      rsync webkit2gtk-4_0-injected-bundles
    
    The following 11 packages are going to change vendor:
      ffmpeg-4          http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libavcodec58_134  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libavdevice58_13  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libavfilter7_110  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libavformat58_76  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libavresample4_0  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libavutil56_70    http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libheif1          http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libpostproc55_9   http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libswresample3_9  http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
      libswscale5_9     http://packman.links2linux.de -> SUSE LLC <https://www.suse.com/>
    
    The following NEW package is going to be installed:
      libwebkit2gtk3-lang
    
    15 packages to upgrade, 1 new, 11  to change vendor.
    Overall download size: 30.0 MiB. Already cached: 0 B. After the operation, 4.7 MiB will be freed.
    Continue? [y/n/v/...? shows all options] (y):
    Which, as I see it, will revert the vendor switch to Packman I did right after the upgrade.

    For zypper se -si | grep -Ei 'systemp|sytem_p|system-p|system p': https://paste.opensuse.org/82205586

    I do not know if it has any connection with these segfaults, but many of my configurations (e.g. also of konsole) are lost/changed.

    I will try a new user.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default Re: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Created a fresh user.

    Kmail first starts, but then asks if I want tocnfigure, which I do not want. Clicking that it breaks.

    Akregator also breaks. First time just bang, second time first asks if it should retsore the broken session, then bangs.
    Henk van Velden

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,044

    Question Re: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    @hcvv:

    Broken package dependencies? «zypper verify»
    Orphaned packages?
    Missing files? «rpm --verify --all»
    System configuration check? «rpmconfigcheck»

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default Re: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Code:
    boven:~ # zypper verify
    Retrieving repository 'Packman' metadata ...............................................................[done]
    Building repository 'Packman' cache ....................................................................[done]
    Retrieving repository 'Update repository with updates from SUSE Linux Enterprise 15' metadata ..........[done]
    Building repository 'Update repository with updates from SUSE Linux Enterprise 15' cache ...............[done]
    Retrieving repository 'Updates from SUSE Linux Enterprise 15' metadata .................................[done]
    Building repository 'Updates from SUSE Linux Enterprise 15' cache ......................................[done]
    Loading repository data...
    Reading installed packages...
    Dependencies of all installed packages are satisfied.
    boven:~ #

    Code:
    boven:~ # rpm --verify --all
    SM5..UGT.  c /srv/www/htdocs/favicon.ico
    SM5..UGT.  c /srv/www/htdocs/index.html
    S.5....T.  c /etc/ntp.conf
    .M.......    /usr/share/teams/chrome-sandbox
    .....UG..  g /run/lightdm
    S.5....T.  c /etc/speech-dispatcher/speechd.conf
    missing     /etc/uefi/certs/40905999.crt
    ........P    /usr/lib64/libexec/ksysguard/ksgrd_network_helper
    S.5....T.  c /etc/sane.d/dll.conf
    S.5....T.  c /etc/zypp/zypp.conf
    S.5....T.  c /etc/default/grub
    .M.......    /var/lib/nfs/rpc_pipefs
    .M.......  g /var/lib/nfs/state
    .M.......  g /usr/share/fonts/Type1/encodings.dir
    .M.......  g /usr/share/fonts/cyrillic/encodings.dir
    .M.......  g /usr/share/fonts/cyrillic/fonts.scale
    .M.......  g /usr/share/fonts/truetype/encodings.dir
    ....L....    /etc/cifs-utils/idmap-plugin
    /usr/bin/clockdiff: cannot verify root:root 0755 - not listed in /etc/permissions
    .M.......  g /etc/xml/catalog-d.xml
    .M.......  g /usr/share/fonts/misc/encodings.dir
    .M.......  g /usr/share/fonts/misc/fonts.scale
    ....L....    /etc/ImageMagick-7
    S.5....T.  c /etc/unixODBC/odbcinst.ini
    .M....G..  c /var/log/audit/audit.log
    .......T.  c /etc/login.defs
    .M.......  g /var/lib/kerberos/krb5
    .M.......  g /var/lib/kerberos/krb5/user
    .M.......  g /run/avahi-daemon
    .M.......  g /var/lib/ca-certificates/ca-bundle.pem
    .M.......  g /var/lib/ca-certificates/java-cacerts
    .M.......  g /var/lib/GeoIP/GeoIP.dat
    S.5....T.  c /etc/cups/cups-browsed.conf
    S.5....T.  c /etc/rsyncd.conf
    S.5....T.  c /var/lib/nfs/etab
    S.5....T.  c /var/lib/nfs/rmtab
    S.5..UGT.  c /etc/apache2/default-server.conf
    S.5....T.  c /etc/apache2/listen.conf
    ....L....  c /etc/pam.d/common-account
    ....L....  c /etc/pam.d/common-auth
    ....L....  c /etc/pam.d/common-password
    ....L....  c /etc/pam.d/common-session
    .M.....T.  c /etc/default/useradd
    .M.......  g /usr/share/fonts/100dpi/encodings.dir
    .M.......  g /usr/share/fonts/100dpi/fonts.scale
    .M.......  g /usr/share/fonts/75dpi/encodings.dir
    .M.......  g /usr/share/fonts/75dpi/fonts.scale
    .M.......  g /var/lib/power-profiles-daemon
    S.5....T.  c /etc/sddm.conf
    .....UG..  g /run/sddm
    S.5....T.  c /etc/zypp/repos.d/repo-backports-debug-update.repo
    S.5....T.  c /etc/zypp/repos.d/repo-backports-update.repo
    S.5....T.  c /etc/zypp/repos.d/repo-sle-debug-update.repo
    S.5....T.  c /etc/zypp/repos.d/repo-sle-update.repo
    .M.......    /var/lib/AccountsService/icons
    .M.......  g /run/cryptsetup
    S.5....T.  c /etc/fonts/conf.d/10-rendering-options.conf
    S.5....T.  c /etc/fonts/conf.d/58-family-prefer-local.conf
    S.5....T.  c /etc/chrony.conf
    .M.......  g /var/lib/chrony/drift
    .M....G..  g /var/log/lastlog
    .M.......  g /etc/aliases.lmdb
    S.5....T.  c /etc/postfix/main.cf
    S.5....T.  c /etc/postfix/master.cf
    .M....G..    /usr/sbin/postlog
    .M.......  g /etc/resolv.conf
    .M.......  g /run/netconfig
    .M.......  g /run/netconfig/resolv.conf
    .M.......  g /run/netconfig/yp.conf
    ....L....  d /usr/share/man/man1/ftp.1.gz
    /etc/cron.d/: cannot verify root:root 0755 - not listed in /etc/permissions
    /etc/cron.daily/: cannot verify root:root 0755 - not listed in /etc/permissions
    /etc/cron.hourly/: cannot verify root:root 0755 - not listed in /etc/permissions
    /etc/cron.monthly/: cannot verify root:root 0755 - not listed in /etc/permissions
    /etc/cron.weekly/: cannot verify root:root 0755 - not listed in /etc/permissions
    S.5....T.  c /etc/my.cnf
    .M.......  g /var/adm/update-messages/mariadb-10.6.8-150400.3.7.1-something
    .M.......  g /var/log/alternatives.log
    .M.......  g /var/lib/pulseaudio
    SM5....T.  c /etc/fonts/conf.d/30-metric-aliases.conf
    .M.......  g /etc/iscsi/initiatorname.iscsi
    .M.......  c /var/log/NetworkManager
    .M.......  g /run/mcelog
    S.5....T.  c /etc/cups/cupsd.conf
    ......G..    /etc/cups/ssl
    boven:~ #
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default Re: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Code:
    boven:~ # zypper pa --orphaned
    Loading repository data...
    Reading installed packages...
    S  | Repository | Name                  | Version                              | Arch
    ---+------------+-----------------------+--------------------------------------+-------
    i  | @System    | libbind9-160          | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libbind9-1600         | 9.16.6-150300.22.16.1                | x86_64
    i  | @System    | libdns169             | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libdns1605            | 9.16.6-150300.22.16.1                | x86_64
    i+ | @System    | libdvdcss2            | 1.4.2-1.3                            | x86_64
    i  | @System    | libgit2-28            | 0.28.4-1.28                          | x86_64
    i  | @System    | libGLEW2_1            | 2.1.0-1.28                           | x86_64
    i  | @System    | libhavege1            | 1.9.2-6.1                            | x86_64
    i  | @System    | libhogweed4           | 3.4.1-4.18.1                         | x86_64
    i  | @System    | libhogweed4-32bit     | 3.4.1-4.18.1                         | x86_64
    i  | @System    | libimobiledevice6     | 1.2.0+git20180427.26373b3-1.40       | x86_64
    i  | @System    | libirs160             | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libirs1601            | 9.16.6-150300.22.16.1                | x86_64
    i  | @System    | libisc166             | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libisc1606            | 9.16.6-150300.22.16.1                | x86_64
    i  | @System    | libisccc160           | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libisccc1600          | 9.16.6-150300.22.16.1                | x86_64
    i  | @System    | libisccfg160          | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libisccfg1600         | 9.16.6-150300.22.16.1                | x86_64
    i  | @System    | liblwres160           | 9.11.2-lp152.13.6                    | x86_64
    i  | @System    | libmediacheck5        | 5.4-1.13                             | x86_64
    i  | @System    | libnettle6            | 3.4.1-4.18.1                         | x86_64
    i  | @System    | libnettle6-32bit      | 3.4.1-4.18.1                         | x86_64
    i  | @System    | libns1604             | 9.16.6-150300.22.16.1                | x86_64
    i  | @System    | libopencv3_3          | 3.3.1-6.6.1                          | x86_64
    i  | @System    | libplist3             | 2.0.0-1.31                           | x86_64
    i  | @System    | libpoppler89          | 0.79.0-3.5.1                         | x86_64
    i  | @System    | libraw16              | 0.18.9-3.14.1                        | x86_64
    i  | @System    | libsgutils2-1_43-2    | 1.44~763+19.1ed0757-9.3.1            | x86_64
    i  | @System    | libusbmuxd4           | 1.0.10-3.23                          | x86_64
    i  | @System    | libvncclient0         | 0.9.10-4.25.1                        | x86_64
    i+ | @System    | libx264-160           | 0.160+git20200702.cde9a933-pm152.1.2 | x86_64
    i+ | @System    | libx265-192           | 3.4-pm152.1.2                        | x86_64
    i  | @System    | libyui-ncurses11      | 2.54.5-lp152.1.3                     | x86_64
    i  | @System    | libyui-ncurses15      | 4.1.5-150300.3.8.7                   | x86_64
    i  | @System    | libyui-qt-graph11     | 2.46.3-lp152.1.1                     | x86_64
    i  | @System    | libyui-qt-graph15     | 4.1.5-150300.3.8.6                   | x86_64
    i  | @System    | libyui-qt11           | 2.52.4-lp152.1.1                     | x86_64
    i  | @System    | libyui-qt15           | 4.1.5-150300.3.8.6                   | x86_64
    i  | @System    | libyui11              | 3.9.3-lp152.1.3                      | x86_64
    i  | @System    | libyui15              | 4.1.5-150300.3.8.7                   | x86_64
    i  | @System    | python-enum34         | 1.1.6-1.24                           | noarch
    i  | @System    | python-gobject2       | 2.28.7-1.27                          | x86_64
    i  | @System    | python-ipaddress      | 1.0.18-3.3.1                         | noarch
    i  | @System    | python-sip-common     | 4.19.19-1.52                         | x86_64
    i  | @System    | python-solv           | 0.7.22-150200.12.1                   | x86_64
    i  | @System    | python2-appdirs       | 1.4.3-1.21                           | noarch
    i  | @System    | python2-asn1crypto    | 0.24.0-3.2.1                         | noarch
    i  | @System    | python2-brotlipy      | 0.7.0-1.24                           | x86_64
    i  | @System    | python2-cairo         | 1.15.1-3.3.1                         | x86_64
    i  | @System    | python2-certifi       | 2018.1.18-1.18                       | noarch
    i  | @System    | python2-cffi          | 1.13.2-3.2.5                         | x86_64
    i  | @System    | python2-chardet       | 3.0.4-3.23                           | noarch
    i  | @System    | python2-configobj     | 5.0.6-1.24                           | noarch
    i  | @System    | python2-cryptography  | 2.8-10.1                             | x86_64
    i  | @System    | python2-dbus-python   | 1.2.16-6.3.1                         | x86_64
    i  | @System    | python2-decorator     | 4.4.2-7.3.13                         | noarch
    i  | @System    | python2-gobject       | 3.34.0-2.27                          | x86_64
    i  | @System    | python2-gobject-cairo | 3.34.0-bp153.1.33                    | x86_64
    i  | @System    | python2-gobject-Gdk   | 3.34.0-bp153.1.33                    | x86_64
    i  | @System    | python2-idna          | 2.6-1.20                             | noarch
    i  | @System    | python2-numpy         | 1.16.5-150200.3.5.1                  | x86_64
    i  | @System    | python2-packaging     | 20.3-1.9                             | noarch
    i  | @System    | python2-py            | 1.8.1-5.6.1                          | noarch
    i  | @System    | python2-pyasn1        | 0.4.2-3.2.1                          | noarch
    i  | @System    | python2-pycparser     | 2.17-3.2.1                           | noarch
    i  | @System    | python2-pyOpenSSL     | 19.0.0-1.31                          | noarch
    i  | @System    | python2-pyparsing     | 2.4.7-1.24                           | noarch
    i  | @System    | python2-PySocks       | 1.6.8-1.19                           | noarch
    i  | @System    | python2-pyudev        | 0.21.0-3.22                          | noarch
    i  | @System    | python2-requests      | 2.24.0-1.24                          | noarch
    i  | @System    | python2-rpm           | 4.14.3-150300.46.1                   | x86_64
    i  | @System    | python2-setuptools    | 40.5.0-6.3.1                         | noarch
    i  | @System    | python2-six           | 1.14.0-12.1                          | noarch
    i  | @System    | python2-urllib3       | 1.25.10-9.14.1                       | noarch
    i  | @System    | python2-urwid         | 2.0.1-1.15                           | x86_64
    i  | @System    | python2-zypp-plugin   | 0.6.3-150000.4.2.1                   | noarch
    i+ | @System    | teams                 | 1.4.00.26453-1                       | x86_64
    boven:~ #
    I can report that Konqueror also bytes the dust.

    Code:
    boven:~ # rpmconfigcheck
    Searching for unresolved configuration files
    Please check the following files (see /var/adm/rpmconfigcheck):
        /etc/chrony.conf.rpmnew
        /etc/cups/cups-browsed.conf.rpmnew
        /etc/default/grub.rpmnew
        /etc/fonts/conf.d/10-rendering-options.conf.rpmsave
        /etc/fonts/conf.d/58-family-prefer-local.conf.rpmsave
        /etc/ntp.conf.rpmnew
        /etc/pam.d/common-account.rpmnew
        /etc/pam.d/common-auth.rpmnew
        /etc/pam.d/common-password.rpmnew
        /etc/pam.d/common-session.rpmnew
        /etc/postfix/main.cf.rpmnew
        /etc/postfix/master.cf.rpmnew
        /etc/pulse/client.conf.d/50-system.conf.rpmsave
        /etc/sane.d/dll.conf.rpmnew
        /etc/zypp/zypp.conf.rpmnew
        /usr/share/info/dir.rpmnew
    boven:~ #
    There are a few, but I doubt one of them has much to do with what we are after. Of course feel free to poit to one that is suspect.

    I have another system (laptop) that I upgraded 15.3 > 15.4 the same way a few weeks ago.
    I do not use KDE PIM there, but now tried the same as with the fresh user here. Akregator and Kmail have NO problems on that system.
    Henk van Velden

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,321

    Default AW: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Have you tried another kernel?

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default Re: AW: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    Quote Originally Posted by Sauerland View Post
    Have you tried another kernel?
    No, this is just what I got with upgrading. Should be the present kernel for 15.4
    Code:
    henk@boven:~> uname -r
    5.14.21-150400.24.18-default
    henk@boven:~>
    Henk van Velden

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,302

    Default Re: upgraded to 15.4: Kontact, Kmail, Akregator, all segfault

    To recap what is breaking (or not).

    • SDDM breaks, a segfault message is shown in dmesg.
    • Kmail breaks. When in a fresh user, it firsts starts with a confuring helper, when that is dismissed it breaks. Other wise it breaks (after some seconds)
    • Akregator breaks. When restarted it show a window telling that it stopped abnormal and asks if you want to restore the session or not. Whatever answer, it breaks after a few secs.
    • Komqueror breaks.
    • Kontact breaks, but that is not illogical as at least two of it's components break by themselves.

    Often the window borders and titlebar are showing for 5-10 secs with a transparent inner before it breaks completely.During that time the session is blocked. Not able to click somewhere, etc.

    Kaddressbook does not break (strange because it is also a KDE PIM application).
    Konsole, Firefox, the three standard games (Kpatience, Kmines and Kmahjongg), Gimp, LibreOffice Writer all start and run OK as far as I tried them.
    Last edited by hcvv; 17-Aug-2022 at 00:45.
    Henk van Velden

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •