Results 1 to 5 of 5

Thread: mount error(40): Too many levels of symbolic links

  1. #1
    Join Date
    Jun 2008
    Location
    Melbourne, AU
    Posts
    26

    Default mount error(40): Too many levels of symbolic links

    On updating kernel versions (as below) and trying to mount CIFS shares from Synology (where Aggregation Portal is enabled) results in "mount error(40): Too many levels of symbolic links".

    • 5.3.18-150300.59.76 => 5.3.18-150300.59.87 (+)
    • 5.14.21-150400.22 => 5.14.21-150400.24.11 (+)

    Disabling Aggregation Portal allows the mount to succeed.

    I raised a case with Synology and they have said this is a SUSE Kernel issue.

    When your client device sends a create request with DFS operation enabled, file path will ends up with \0, which will cause a mismatch with the Blob Length after the \0 has been ignored, and leads to a OBJECT_NAME_INVALID / Too many levels of symbolic links error.

    We have also reproduce the issue with original samba 4.15.9 package as a SMB server. And the mount.cifs version will have different behaviors between under DFS and non-DFS operation (no extra \0 under non-DFS operation), and that is why the issue disappears after MSDFS option is disabled.

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,402

    Default Re: mount error(40): Too many levels of symbolic links

    Create a bug report at https://bugzilla.opensuse.org (same log in credentials as the openSUSE forum).
    Regards, Paul

  3. #3
    Join Date
    Jun 2008
    Location
    Melbourne, AU
    Posts
    26

    Default Re: mount error(40): Too many levels of symbolic links

    Quote Originally Posted by tannington View Post
    Create a bug report at https://bugzilla.opensuse.org (same log in credentials as the openSUSE forum).

    Bug #1202463

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,402

    Default Re: mount error(40): Too many levels of symbolic links

    OK - Thanks for providing the link for any users who may wish to follow the progress.

    Kernel bugs are normally responded to fairly quickly, so hopefully you won't have too long to wait.
    Regards, Paul

  5. #5
    Join Date
    Jun 2008
    Location
    Melbourne, AU
    Posts
    26

    Default Re: mount error(40): Too many levels of symbolic links

    Quote Originally Posted by tannington View Post
    OK - Thanks for providing the link for any users who may wish to follow the progress.

    Kernel bugs are normally responded to fairly quickly, so hopefully you won't have too long to wait.
    Sure is. Already marked as duplicate of Bug #1198753

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •