Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Yast / Zypper / Network issues

  1. #11
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,310

    Default Re: AW: Yast / Zypper / Network issues

    Quote Originally Posted by Sauerland View Post
    Please use
    Code:
    zypper lr -d
    or something similar to show your Repo list with the URL.
    He did in post #3 (although he forgot to include the command within the copy/paste). Zypper does not work at all for him.
    Henk van Velden

  2. #12
    Join Date
    Aug 2022
    Posts
    11

    Default Re: Yast / Zypper / Network issues

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Sounds like this old bug... https://bugzilla.opensuse.org/show_bug.cgi?id=1178332

    As root user, no sudo please, so;

    Code:
    su -
    zypper lr -d
    rpm -V -a --nofiles
    Here is the return from above:

    Code:
    localhost:~ # su - 
    localhost:~ # zypper lr -d 
    zypper: symbol lookup error: /usr/lib64/libzypp.so.1722: undefined symbol: _ZN4YAML6detail9node_data12empty_scalarB5c
    xx11E 
    localhost:~ # rpm -V -a --nofiles 
    /etc/cron.d/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.daily/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.hourly/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.monthly/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.weekly/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /usr/bin/clockdiff: cannot verify root:root 0755 - not listed in /etc/permissions 
    localhost:~ #
    
    Jim

  3. #13
    Join Date
    Aug 2022
    Posts
    11

    Default Re: Yast / Zypper / Network issues

    kvcc

    I'm still learning...
    So I can just remove
    Code:
    /etc/zypp/repos.d/http-download.opensuse.org-629a0695.repo:baseurl=http://download.opensuse.org/distribution/leap/15.4/repo/oss/
    reboot and see if I get some function back with Yast or zypper?

    Jim

  4. #14
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,112
    Blog Entries
    1

    Default Re: Yast / Zypper / Network issues

    Cleaning up repo files will not fix a broken zypper command or zypp library. This is a pretty serious failure that will probably be easier to fix by reverting to a snapshot, and if that's not possible, doing an offline upgrade using installation media. A hand-ons expert could probably fix it using rpm, but I don't want to try to explain that to anyone, and there's no guarantee of success anyway.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.4, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.4 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  5. #15
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,323

    Default AW: Yast / Zypper / Network issues

    Post:
    Code:
    rpm -q libyaml-cpp0_7

  6. #16
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,310

    Default Re: Yast / Zypper / Network issues

    Quote Originally Posted by jr95 View Post
    kvcc

    I'm still learning...
    So I can just remove
    Code:
    /etc/zypp/repos.d/http-download.opensuse.org-629a0695.repo:baseurl=http://download.opensuse.org/distribution/leap/15.4/repo/oss/
    reboot and see if I get some function back with Yast or zypper?

    Jim
    As others explain, this is really a side step, that better is corrected after your main problem is solved.
    Henk van Velden

  7. #17
    Join Date
    Aug 2022
    Posts
    11

    Default Re: Yast / Zypper / Network issues

    The results:
    Code:
    jim@localhost:~> sudo rpm -q libyaml-cpp0_7 
    [sudo] password for root:  
    package libyaml-cpp0_7 is not installed 
    jim@localhost:~> 
    
    
    It's beginning to look like my knowledge and experience here isn't enough to save my current installation, even with help from the folks here.
    It will probably be quicker and less prone to to errors on my part to do a clean install.
    I'll be doing another backup of my home directory and reinstall 15.4 Sunday morning.

    I appreciate the time taken by those to look into these issues for me.

    Jim

  8. #18
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,323

    Default AW: Yast / Zypper / Network issues

    Oops should be 6:
    Post:
    Code:
    rpm -q libyaml-cpp0_6

  9. #19
    Join Date
    Aug 2022
    Posts
    11

    Default Re: Yast / Zypper / Network issues

    Re-posting with 6:
    Code:
    jim@localhost:~> sudo rpm -q libyaml-cpp0_6 
    [sudo] password for root:  
    libyaml-cpp0_6-0.6.3-150400.2.5.x86_64 
    jim@localhost:~> 
    
    
    

  10. #20
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,112
    Blog Entries
    1

    Default Re: Yast / Zypper / Network issues

    A newer version is on the mirrors:
    http://ftp5.gwdg.de/pub/opensuse/upd...3.1.x86_64.rpm

    You could download it manually to the current directory and try to install it thus:
    Code:
    sudo rpm -Uvh libyaml-cpp0_6-0.6.3-150400.4.3.1.x86_64.rpm
    First, check in /var/cache/zypp/packages/* to see if it was already downloaded but not installed, if you do find it there, look around for *zyp* packages that also may have not yet been installed.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.4, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.4 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •