Results 1 to 10 of 10

Thread: yt-dlp no longer working

  1. #1
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    61

    Default yt-dlp no longer working

    yt-dlp (youtube download application) has stopped working.

    Code:
    nick@shuttle:~> yt-dlp -o "%(title)s-%(id)s.%(ext)s" pOcfW0zv7cY
    DeprecationWarning: Python version 3.6 is no longer supported! Please update to Python 3.7 or above
    [youtube] pOcfW0zv7cY: Downloading webpage
    ERROR: module 're' has no attribute 'Pattern'
    nick@shuttle:~>
    As far as I can see, Python 3.7 or above is not available for openSUSE Leap 15.4.

    How do I overcome this problem?

  2. #2

    Default Re: yt-dlp no longer working


  3. #3
    Join Date
    Sep 2012
    Posts
    8,042

    Default Re: yt-dlp no longer working

    Quote Originally Posted by nwlord View Post
    yt-dlp (youtube download application) has stopped working.
    You did not explain where this program comes from, how you installed it, whether it worked before and when it stopped working so any answer will be just a wild guess. Anyway, quick test using version included in openSUSE works here:
    Code:
    bor@localhost:~> yt-dlp -o "%(title)s-%(id)s.%(ext)s" pOcfW0zv7cY
    [youtube] pOcfW0zv7cY: Downloading webpage
    [youtube] pOcfW0zv7cY: Downloading android player API JSON
    [info] pOcfW0zv7cY: Downloading 1 format(s): 313+251
    [download] Destination: Marcus Mumford - Cannibal-pOcfW0zv7cY.f313.webm
    [download]   8.2% of 504.92MiB at  1.83MiB/s ETA 04:12^C
    ERROR: Interrupted by user
    bor@localhost:~>

  4. #4
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    61

    Default Re: yt-dlp no longer working

    Quote Originally Posted by AdmFubar View Post
    I removed yt-dlp, then installed opt-python37 from the repository you linked to. It installed packages opt-python-libpython3, opt-python311 and opt-python37. I then reinstalled yt-dlp, but I get the same ouput.

    Do I need to do something to connect yt-dlp to python37?

  5. #5
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    61

    Default Re: yt-dlp no longer working

    Quote Originally Posted by arvidjaar View Post
    You did not explain where this program comes from, how you installed it, whether it worked before and when it stopped working so any answer will be just a wild guess. Anyway, quick test using version included in openSUSE works here:"
    I had updated to the latest version from the Packman repo. I've now gone back to the openSUSE version, which works.

    Thanks for your help.

  6. #6
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,386
    Blog Entries
    15

    Default Re: yt-dlp no longer working

    Quote Originally Posted by nwlord View Post
    I removed yt-dlp, then installed opt-python37 from the repository you linked to. It installed packages opt-python-libpython3, opt-python311 and opt-python37. I then reinstalled yt-dlp, but I get the same ouput.

    Do I need to do something to connect yt-dlp to python37?
    Hi
    Assuming it's from the Packman third party repo, there is a fix on the way, see their mailing list for details: https://lists.links2linux.de/piperma...st/017171.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    61

    Default Re: yt-dlp no longer working

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Assuming it's from the Packman third party repo, there is a fix on the way, see their mailing list for details: https://lists.links2linux.de/piperma...st/017171.html
    Thanks, Malcolm. I've solved the problem temporarily by reverting to the non-Packman version

  8. #8
    Join Date
    Sep 2012
    Posts
    8,042

    Default Re: yt-dlp no longer working

    Quote Originally Posted by malcolmlewis View Post
    there is a fix on the way, see their mailing list for details: https://lists.links2linux.de/piperma...st/017171.html
    Which is rather different from what was shown in original post.

  9. #9
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    214

    Default Re: yt-dlp no longer working

    Kudos to all involved - I see that the latest yt-dlp update for openSUSE 15.3 in Packman repo is notated:
    - Force python 3.9 on anything older than Tumbleweed

    It works here.


  10. #10
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    61

    Default Re: yt-dlp no longer working

    Quote Originally Posted by Tallowwood View Post
    Kudos to all involved - I see that the latest yt-dlp update for openSUSE 15.3 in Packman repo is notated:
    - Force python 3.9 on anything older than Tumbleweed
    Thanks for the info, Tallowwood. Have reinstalled from Packman, which installed python 3.9. Now working fine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •