Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Multimedia guide?

  1. #1

    Default Multimedia guide?

    Just curious, what happened to the multimedia guides here in the forum?
    There has no longer been one since... 15.1?

    Specially with the recent Packman changes at least on Tumbleweed, shouldn't there be one?

    Also, brief offtopic, what happened to Caf4926?

    Thanks for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,265
    Blog Entries
    1

    Default Re: Multimedia guide?

    Quote Originally Posted by F_style View Post
    Just curious, what happened to the multimedia guides here in the forum?
    There has no longer been one since... 15.1?
    They got out of date....unmaintained. Feel free to step up and participate...

    Two of many such unofficial guides...

    https://www.linuxhowto.net/how-to-in...s-in-opensuse/

    https://cubiclenate.com/linux/applic...decs-terminal/

    Specially with the recent Packman changes at least on Tumbleweed, shouldn't there be one?
    What changes are you referring to specifically? This one?

    https://forums.opensuse.org/showthre...s-from-Packman

    Also, brief offtopic, what happened to Caf4926?
    Still around AFAIK, probably busy with other life priorities.
    openSUSE Leap 15.4; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,879
    Blog Entries
    20

    Default Re: Multimedia guide?

    I'm still here
    I moved house last Autumn and have a massive project on my hands

    Anyway. With regards to multimedia I find there is really no longer a need as it just works now.

    I have been running Tumbleweed a long time and don't do regular trials as I used to

    But this would be my process:

    After install on any release of openSUSE

    Code:
    su -
    Code:
    zypper dup
    Reboot


    Add the main Packman repo from the add repo section in Yast - Repositories > Community section
    If you need libdvdcss, add that too

    Once done, exit.

    Code:
    su -
    Code:
    zypper in ffmpeg gstreamer-plugins-{good,bad,ugly,libav} libavcodec-full vlc-codecs
    You have to work through a load of switching options in that last one
    It's whatever option is saying
    openSUSE > Packman
    Read each one carefully
    If you make a mistake, exit and start again

    Once done, go back to Yast Software Management
    View by repositories - you may have to enable this from the View Tab dropdown
    Select Packman on the list on the left
    Click the Switch system Packages option
    https://paste.opensuse.org/56146323

    As you add more stuff during normal use - If you have any issues, you can always re-apply the switch
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,204
    Blog Entries
    5

    Default Re: Multimedia guide?

    Quote Originally Posted by caf4926 View Post
    Anyway. With regards to multimedia I find there is really no longer a need as it just works now. I have been running Tumbleweed a long time and don't do regular trials as I used to. But this would be my process ...
    https://forums.opensuse.org/showthre...Packman-Codecs
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022) openSUSE Tumbleweed, KDE Plasma
    See also Blogs > KeepItSimple

  5. #5

    Default Re: Multimedia guide?

    Quote Originally Posted by caf4926 View Post
    Code:
    zypper in ffmpeg gstreamer-plugins-{good,bad,ugly,libav} libavcodec-full vlc-codecs
    I found 2 problems with this:

    1) Package libavcodec-full does not exist.

    2) The ffmpeg package seems to pull packages libavdevice57 libavdevice58, but "nothing provides these packages" and thus package conflicts. First suggested solution is downgrading from Packman to SUSE repo, and other possible broken packages. IIRC similar error with vlc-codecs.
    Two possible solutions:
    ---Install package ffmpeg-3, which seemingly still has no problems; I strongly wonder what the difference between ffmpeg, ffmpeg-3, and ffmpeg-4 is...
    ---Add the Mozilla repo beforehand, because for some reason it seems to have the missing packages...

    By the way, are packages x264 and x265 still used?

    Thanks again.

  6. #6
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,879
    Blog Entries
    20

    Default Re: Multimedia guide?

    Quote Originally Posted by F_style View Post
    I found 2 problems with this:

    1) Package libavcodec-full does not exist.

    2) The ffmpeg package seems to pull packages libavdevice57 libavdevice58, but "nothing provides these packages" and thus package conflicts. First suggested solution is downgrading from Packman to SUSE repo, and other possible broken packages. IIRC similar error with vlc-codecs.
    Two possible solutions:
    ---Install package ffmpeg-3, which seemingly still has no problems; I strongly wonder what the difference between ffmpeg, ffmpeg-3, and ffmpeg-4 is...
    ---Add the Mozilla repo beforehand, because for some reason it seems to have the missing packages...

    By the way, are packages x264 and x265 still used?

    Thanks again.
    I can only assume you have run this zypper in a working install? Rather than a new install.
    But I never add the Mozilla repo
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,204
    Blog Entries
    5

    Default Re: Multimedia guide?

    Quote Originally Posted by F_style View Post
    I found 2 problems with this:

    1) Package libavcodec-full does not exist.

    2) The ffmpeg package seems to pull packages libavdevice57 libavdevice58, but "nothing provides these packages" and thus package conflicts. First suggested solution is downgrading from Packman to SUSE repo, and other possible broken packages. IIRC similar error with vlc-codecs.
    Two possible solutions:
    ---Install package ffmpeg-3, which seemingly still has no problems; I strongly wonder what the difference between ffmpeg, ffmpeg-3, and ffmpeg-4 is...
    ---Add the Mozilla repo beforehand, because for some reason it seems to have the missing packages...

    By the way, are packages x264 and x265 still used?

    Thanks again.
    No issue with ffmpeg-4:
    Code:
    Leap-15-4:~ # zypper if ffmpeg-4 
    Loading repository data... 
    Reading installed packages... 
    
    
    Information for package ffmpeg-4: 
    --------------------------------- 
    Repository     : packman 
    Name           : ffmpeg-4 
    Version        : 4.4-pm154.2.6 
    Arch           : x86_64 
    Vendor         : http://packman.links2linux.de 
    Installed Size : 2.2 MiB 
    Installed      : Yes (automatically) 
    Status         : up-to-date 
    Source package : ffmpeg-4-4.4-pm154.2.6.src 
    Upstream URL   : https://ffmpeg.org/ 
    Summary        : Set of libraries for working with various multimedia formats 
    Description    :  
        FFmpeg is a multimedia framework, able to decode, encode, 
        transcode, mux, demux, stream, filter and play several formats 
        that humans and machines have created. 
    
    Leap-15-4:~ #
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022) openSUSE Tumbleweed, KDE Plasma
    See also Blogs > KeepItSimple

  8. #8

    Default Re: Multimedia guide?

    This is a new install from scratch.

    I did have the aforementioned problem with package ffmpeg when trying to "zypper in" it. But I ended up installing ffmpeg-3 and thus did not actually try the "second solution". I only guessed it would work because "zypper in -D libavdevice57" no longer gave errors after adding Mozilla repo.

    These are my current repos:
    Code:
    test1@localhost:~> zypper lr -d
    #  | Alias                       | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
    ---+-----------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
     1 | mozilla                     | mozilla                                                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.4/  | 
     2 | openSUSE-Leap-15.4-1        | openSUSE-Leap-15.4-1                                                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.4/repo/oss/           | 
     3 | packman                     | packman                                                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/     | 
     4 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.4/backports_debug/          | 
     5 | repo-backports-update       | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/backports/                | 
     6 | repo-debug                  | Debug Repository                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.4/repo/oss/     | 
     7 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.4/repo/non-oss/ | 
     8 | repo-debug-update           | Update Repository (Debug)                                                                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/oss/                | 
     9 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/non-oss/            | 
    10 | repo-non-oss                | Repositorio Non-OSS                                                                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.4/repo/non-oss/       | 
    11 | repo-oss                    | Repositorio principal                                                                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.4/repo/oss/           | 
    12 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.4/sle/                | 
    13 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/sle/                      | 
    14 | repo-source                 | Source Repository                                                                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.4/repo/oss/    | 
    15 | repo-update                 | Repositorio principal de actualizaciones                                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/oss                       | 
    16 | repo-update-non-oss         | Repositorio de actualizaciones (No OpenSource)                                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.4/non-oss/                  | 
    17 | wine                        | wine                                                                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/Emulators:/Wine/15.4/        | 
    test1@localhost:~>

  9. #9
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,879
    Blog Entries
    20

    Default Re: Multimedia guide?

    Very odd arrangement of repos
    It's difficult to asses your results when you use extraordinary ingredients
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Multimedia guide?

    Quote Originally Posted by caf4926 View Post
    Very odd arrangement of repos
    It's difficult to asses your results when you use extraordinary ingredients
    What are you talking about?
    All these are the *defaults* when running the Yast installer from openSUSE iso!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •