Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: function keys doesn't works

  1. #11
    Join Date
    May 2019
    Location
    Padova - Italy
    Posts
    133

    Default Re: function keys doesn't works

    Quote Originally Posted by karlmistelberger View Post
    It seems I have no shortcuts set. I press "reset to default" button but nothing change. Not sure but I think functions keys software is part of kernel.

  2. #12
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,184
    Blog Entries
    5

    Default Re: function keys doesn't works

    Quote Originally Posted by Giorgio_os View Post
    It seems I have no shortcuts set. I press "reset to default" button but nothing change. Not sure but I think functions keys software is part of kernel.
    Alt+F2 started krunner in previous versions of KDE. Nothing happens with the current version.
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022) openSUSE Tumbleweed, KDE Plasma
    See also Blogs > KeepItSimple

  3. #13
    Join Date
    May 2019
    Location
    Padova - Italy
    Posts
    133

    Default Re: function keys doesn't works

    Quote Originally Posted by susejunky View Post
    Under what circumstances (older OS-version, different OS, ...) did the function keys work as expected?
    I use frequently functions keys, mainly for volume and they worked till one or two days ago.

    Which function keys do still work "as before"?
    I would say none of them. At least "fn" key seems having no effect.
    As an example using VLC to listen music F11 / Fast Forward key should have two functions:
    F11 -> toggle VLC windows to whole screen <-> mid size window
    Fast Forward -> jump to the next song in folder
    Normally I can chose between two functions pressing "fn" key. Now "fn" key has no effect, pressing it or not F11 always change VLC window dimension.

    Is this a Laptop and the F-keys in question are labelled ("brightness up", "brightness down", ...)?
    Yes. As an example F7 (volume down) key has a loudspeaker and minus sign "-" .

  4. #14
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    1,037

    Default Re: function keys doesn't works

    Quote Originally Posted by Giorgio_os View Post
    ... At least "fn" key seems having no effect. ... Now "fn" key has no effect
    Is there a chance that just your "Fn"-key gave up (hardware defect) or does it still work with some "Fx"-keys (e.g. to change brightness)?

    Regards

    susejunky

  5. #15
    Join Date
    May 2019
    Location
    Padova - Italy
    Posts
    133

    Talking Re: function keys doesn't works

    Quote Originally Posted by susejunky View Post
    Is there a chance that just your "Fn"-key gave up (hardware defect) or does it still work with some "Fx"-keys (e.g. to change brightness)?

    Regards

    susejunky
    After my last message I had the same doubt. I checked all my os and in none fn key worked.
    Then I try to take apart the key "cap" and this probably unlock the key (that was locked in "pressed" position) now it works normally. And I hope it will keep on working.
    Thanks to all for hints.

  6. #16
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,184
    Blog Entries
    5

    Default Re: function keys doesn't works

    Quote Originally Posted by karlmistelberger View Post
    Alt+F2 started krunner in previous versions of KDE. Nothing happens with the current version.
    Plasma System Settings > Shortcuts > Krunner > Defaults wouldn't work. Logged out from KDE Plasma, moved ./.config/kglobalshortcutsrc, logged in again. That restored defaults.
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022) openSUSE Tumbleweed, KDE Plasma
    See also Blogs > KeepItSimple

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •