Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: sleep does not work

Hybrid View

  1. #1

    Question sleep does not work

    The sleep power management was working until recent updates. My desktop would go into sleep and wake up ok.Now it goes into sleep if set under power management but will not wake up requiring pressing the power button to shut down and restart.
    If I try sleep from the log in screen it just comes back to the login screen. I'm using kde desktop.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,140

    Question Re: sleep does not work

    @1chip:

    On this machine,
    Code:
    Operating System: openSUSE Leap 15.4
    KDE Plasma Version: 5.24.4
    KDE Frameworks Version: 5.90.0
    Qt Version: 5.15.2
    Kernel Version: 5.14.21-150400.24.11-default (64-bit)
    Graphics Platform: X11
    Processors: 8 × AMD Ryzen 5 3400G with Radeon Vega Graphics
    Memory: 13.5 GiB of RAM
    Graphics Processor: AMD Radeon™ Vega 11 Graphics
    suspending to RAM (ACPI S3 sleep state) either via the KDE Plasma program starter (Application Launcher) or, a 1 minute Timer in the System Settings functions exactly as expected –
    • The power button on the case begins blinking;
    • The screen receives no signal and drops into Standby Mode;
    • Hitting the Shift Key brings the machine out of the ACPI S3 sleep state – pressing the case's power button also brings the machine out of the sleep state.

    Do you have the KDE Power Management module package – “powerdevil5” – installed and, all the required dependent packages?

  3. #3

    Default Re: sleep does not work

    yes I checked powerdevil5 is installed.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,140

    Default Re: sleep does not work

    @1chip:

    Then, you'll have to inspect the systemd Journal to see what's going on – with the user “root”: “journalctl --list-boots” – select a boot where the issue occurred and then:
    journalctl -b «(negative) number from the left hand column»”.
    You didn't mention if, all the package dependencies are satisfied – you'll have to also, execute “zypper verify” and then, to check that all the files in each installed package are present and correct: “rpm --verify --all”.

  5. #5

    Default Re: sleep does not work

    Code:
      Retrieving repository 'OBS:Server:Unstable' metadata ...................................................................................................................................................................................................................[done] 
    Building repository 'OBS:Server:Unstable' cache ........................................................................................................................................................................................................................[done] 
    Loading repository data... 
    Reading installed packages... 
    Dependencies of all installed packages are satisfied. 
    localhost:~ # rpm --verify --all 
    .M....G..  g /etc/brlapi.key 
    ........P    /usr/lib64/libexec/ksysguard/ksgrd_network_helper 
    .M.......  g /usr/share/fonts/100dpi/encodings.dir 
    .M.......  g /usr/share/fonts/100dpi/fonts.scale 
    .M.......  g /usr/share/fonts/75dpi/encodings.dir 
    .M.......  g /usr/share/fonts/75dpi/fonts.scale 
    .M....G..  g /etc/brlapi.key 
    .M.......  g /var/log/boot.log 
    ....L....  c /etc/pam.d/common-account 
    ....L....  c /etc/pam.d/common-auth 
    ....L....  c /etc/pam.d/common-password 
    ....L....  c /etc/pam.d/common-session 
    .M.......    /var/lib/AccountsService/icons 
    .M.......  g /var/lib/flatpak 
    .M.......  g /run/avahi-daemon 
    .M.......  g /var/lib/ca-certificates/ca-bundle.pem 
    .M.......  g /var/lib/ca-certificates/java-cacerts 
    S.5....T.  c /etc/zypp/repos.d/repo-backports-debug-update.repo 
    S.5....T.  c /etc/zypp/repos.d/repo-sle-debug-update.repo 
    S.5....T.  c /etc/speech-dispatcher/speechd.conf 
    S.5....T.  c /etc/unixODBC/odbcinst.ini 
    .M....G..  g /var/log/lastlog 
    ....L....    /etc/cifs-utils/idmap-plugin 
    .M.......  g /var/cache/gdm 
    ......G..    /etc/cups/ssl 
    .M.......  c /var/log/NetworkManager 
    ....L....  d /usr/share/man/man1/ftp.1.gz 
    /usr/bin/clockdiff: cannot verify root:root 0755 - not listed in /etc/permissions 
    .M.......  g /etc/aliases.lmdb 
    S.5....T.  c /etc/postfix/main.cf 
    S.5....T.  c /etc/postfix/master.cf 
    .....UG..  g /run/sddm 
    S.5....T.  c /etc/sane.d/dll.conf 
    .M.......  g /usr/share/fonts/Type1/encodings.dir 
    .M.......  g /usr/share/fonts/cyrillic/encodings.dir 
    .M.......  g /usr/share/fonts/cyrillic/fonts.scale 
    .M.......  g /usr/share/fonts/truetype/encodings.dir 
    .M.......  g /etc/xml/catalog-d.xml 
    S.5....T.  c /etc/chrony.conf 
    .M.......  g /var/lib/chrony/drift 
    .M.......  g /var/cache/PackageKit 
    .M.......  g /run/mcelog 
    ....L....    /etc/ImageMagick-7 
    .M.......  g /var/lib/pulseaudio 
    SM5....T.  c /etc/fonts/conf.d/30-metric-aliases.conf 
    .......T.  c /etc/login.defs 
    /etc/cron.d/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.daily/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.hourly/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.monthly/: cannot verify root:root 0755 - not listed in /etc/permissions 
    /etc/cron.weekly/: cannot verify root:root 0755 - not listed in /etc/permissions 
    .M.......  g /run/netconfig 
    .M.......  g /run/netconfig/resolv.conf 
    .M.......  g /run/netconfig/yp.conf 
    missing     /usr/lib64/libreoffice/program/intro-highres.png 
    missing     /usr/lib64/libreoffice/program/shell/logo.svg 
    missing     /usr/lib64/libreoffice/program/shell/logo_inverted.svg 
    S.5....T.  c /etc/fonts/conf.d/10-rendering-options.conf 
    S.5....T.  c /etc/fonts/conf.d/58-family-prefer-local.conf 
    S.5....T.  c /etc/default/grub 
    .M.......  g /var/lib/power-profiles-daemon 
    .M.......  g /var/log/alternatives.log 
    .M.......  g /run/cryptsetup 
    .M.......  g /usr/share/fonts/misc/encodings.dir 
    .M.......  g /usr/share/fonts/misc/fonts.scale 
    localhost:~ #
    
    

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,140

    Default Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    Code:
      Retrieving repository 'OBS:Server:Unstable' metadata ...................................................................................................................................................................................................................[done] 
    Building repository 'OBS:Server:Unstable' cache ........................................................................................................................................................................................................................[done] 
    Loading repository data... 
    Reading installed packages... 
    Dependencies of all installed packages are satisfied. 
    
    Oh dear – you're using and Unstable Repository – and, unstable is unstable – as the name indicates …

    Further down your paste →
    • You can safely ignore the “missing” files – the LibreOffice package installs them and then, something else removes them …

    This is a behaviour which we're all living with – until we can discover why it happens …

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,140

    Question Re: sleep does not work

    @1chip:

    I believe that I've discovered what's going on with the suspend to RAM (ACPI S3 sleep state) –
    • On the other machine, I use X11 in place of Wayland due to plasmashell crashes when logging in.
    • On this machine, I was using Wayland:

    Code:
    Operating System: openSUSE Leap 15.4
    KDE Plasma Version: 5.24.4
    KDE Frameworks Version: 5.90.0
    Qt Version: 5.15.2
    Kernel Version: 5.14.21-150400.24.11-default (64-bit)
    Graphics Platform: X11
    Processors: 4 × AMD A10-5750M APU with Radeon(tm) HD Graphics
    Memory: 7.0 GiB of RAM
    Graphics Processor: AMD ARUBA
    When I suspended the machine and then hit the “Shift” key to wake it up, the “Lock” screen was tearing – completely unusable – had to <Ctrl-Alt-Backspace-Backspace> (hit Backspace twice) to restart the Display Manager.
    • I logged in again with X11 and, suspend behaved exactly as it should do …

    I suspect that, Wayland and suspend are not suited to one another yet – there may well be a repair available with a newer KDE Plasma Version.

    How are you waking up from Suspend?
    • Mouse movements don't work – you have to hit either the <Shift> key or, the <Shift-Lock> key or, the <Left-Ctrl> key.
    • I haven't tried the <Right-Ctrl> key yet …

  8. #8

    Default Re: sleep does not work

    well that didn't work well. I marked everything under unstable repository to delete and now I'm missing a bunch of things including yast

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,140

    Exclamation Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    well that didn't work well. I marked everything under unstable repository to delete and now I'm missing a bunch of things including yast
    When moving away from a Repository, you have to MOVE the packages rather than DELETE them …
    • If, you were to use the graphical YaST interface and, you simply disabled the unstable repositories then, in the YaST Software Manager, in the “Installation Summary” tab, you will possibly find everything you deleted as being “ready for re-installation”.
    • If not, you'll have to move over to the “View” tab and, choose the “Patterns” option and, for each Pattern you wish to have installed, select the “patterns- . . . ” packages.

    For a working KDE Plasma system, you need the following list of Patterns packages:
    Code:
    S  | Name                             | Summary                                            | Type
    ---+----------------------------------+----------------------------------------------------+--------
    i+ | patterns-base-apparmor           | AppArmor                                           | package
    i+ | patterns-base-base               | Minimal Base System                                | package
    i  | patterns-base-basesystem         | Base System (alias pattern for base)               | package
    i  | patterns-base-documentation      | Help and Support Documentation                     | package
    i+ | patterns-base-enhanced_base      | Enhanced Base System                               | package
    i  | patterns-base-minimal_base       | Minimal Appliance Base                             | package
    i+ | patterns-base-sw_management      | Software Management                                | package
    i+ | patterns-base-x11                | X Window System                                    | package
    i+ | patterns-base-x11_enhanced       | X Window System                                    | package
    i+ | patterns-desktop-imaging         | Graphics                                           | package
    i+ | patterns-desktop-multimedia      | Multimedia                                         | package
    i+ | patterns-devel-C-C++-devel_C_C++ | C/C++ Development                                  | package
    i+ | patterns-devel-base-devel_basis  | Base Development                                   | package
    i  | patterns-fonts-fonts             | Fonts                                              | package
    i  | patterns-fonts-fonts_opt         | Fonts                                              | package
    i+ | patterns-kde-kde                 | KDE Applications and Plasma 5 Desktop              | package
    i+ | patterns-kde-kde_imaging         | KDE Graphics                                       | package
    i+ | patterns-kde-kde_internet        | KDE Internet                                       | package
    i+ | patterns-kde-kde_multimedia      | KDE Multimedia                                     | package
    i+ | patterns-kde-kde_office          | KDE Office                                         | package
    i  | patterns-kde-kde_pim             | KDE PIM Suite                                      | package
    i+ | patterns-kde-kde_plasma          | KDE Plasma 5 Desktop Base                          | package
    i+ | patterns-kde-kde_utilities       | KDE Utilities                                      | package
    i+ | patterns-kde-kde_utilities_opt   | KDE Utilities                                      | package
    i  | patterns-kde-kde_yast            | YaST KDE User Interfaces                           | package
    i+ | patterns-network-network_admin   | Network Administration                             | package
    i+ | patterns-office-office           | Office Software                                    | package
    i+ | patterns-server-file_server      | File Server                                        | package
    i+ | patterns-server-lamp_server      | Web and LAMP Server                                | package
    i+ | patterns-yast-x11_yast           | YaST User Interfaces                               | package
    i  | patterns-yast-yast2_basis        | YaST Base Utilities                                | package
    i  | patterns-yast-yast2_desktop      | YaST Desktop Utilities                             | package
    With the possible exception of the Development patterns …

  10. #10

    Default Re: sleep does not work

    Yast is gone, I can't access any of that. I would think I would not be allowed to do this but it happened.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •