Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 42

Thread: sleep does not work

  1. #11
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,122

    Default Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    Yast is gone, I can't access any of that. I would think I would not be allowed to do this but it happened.
    Then use, from a Terminal Window (the KDE Plasma application “Konsole”) and, the user “root” «either “su --login” at a normal user's CLI prompt or, use the “Root” Konsole session profile», execute the following command:
    Code:
     # zypper install --force patterns-yast-yast2_basis patterns-yast-x11_yast patterns-yast-yast2_desktop
    You will be amazed at the number of packages which will be installed – simply answer “yes” at the Zypper prompt.

  2. #12

    Default Re: sleep does not work

    ok everything is back, had to put kde pattern back in. Now my login screen looks different.
    I disabled the OBS experimental repository. Can I delete it? Not sure where it came from.

  3. #13

    Default Re: sleep does not work

    Quote Originally Posted by dcurtisfra View Post
    @1chip:

    I believe that I've discovered what's going on with the suspend to RAM (ACPI S3 sleep state) –
    • On the other machine, I use X11 in place of Wayland due to plasmashell crashes when logging in.
    • On this machine, I was using Wayland:

    Code:
    Operating System: openSUSE Leap 15.4
    KDE Plasma Version: 5.24.4
    KDE Frameworks Version: 5.90.0
    Qt Version: 5.15.2
    Kernel Version: 5.14.21-150400.24.11-default (64-bit)
    Graphics Platform: X11
    Processors: 4 × AMD A10-5750M APU with Radeon(tm) HD Graphics
    Memory: 7.0 GiB of RAM
    Graphics Processor: AMD ARUBA
    When I suspended the machine and then hit the “Shift” key to wake it up, the “Lock” screen was tearing – completely unusable – had to <Ctrl-Alt-Backspace-Backspace> (hit Backspace twice) to restart the Display Manager.
    • I logged in again with X11 and, suspend behaved exactly as it should do …

    I suspect that, Wayland and suspend are not suited to one another yet – there may well be a repair available with a newer KDE Plasma Version.

    How are you waking up from Suspend?
    • Mouse movements don't work – you have to hit either the <Shift> key or, the <Shift-Lock> key or, the <Left-Ctrl> key.
    • I haven't tried the <Right-Ctrl> key yet …
    sleep does not work with x11 or wayland

  4. #14
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,122

    Cool Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    I disabled the OBS experimental repository. Can I delete it? Not sure where it came from.
    If you're planning to do some work doing experimental builds and repairs with newer package versions then, simply disable it and disable the automatic refresh – until such time as you begin working the issues around newer package versions.
    • If you're not interested in working on software maintenance then, delete the thing.

  5. #15
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,122

    Default Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    sleep does not work with x11 or wayland
    Then, there's some system files on your system which have been sourced from the experimental repositories.
    1. Assuming that, you've only enabled the openSUSE Leap 15.4 Repositories plus a couple of other non-openSUSE repositories such as, the Packman (Essentials) repository and the VideoLAN repository, then execute “zypper refresh --force”.
    2. Then, execute “zypper verify”.
    3. Forcibly re-install all the indicated packages.
    4. Then, in YaST Software Management, select the “RepositoriesView and then, on the “@System” selection, click the “Installed (Available)” column (probably) twice to sort on the newest changes.

    Work through the changes until all packages which were sourced from the experimental repositories have been replaced by packages from the openSUSE repositories.
    Once you've done that, you'll possibly have to select the “Package Groups” view and, the selection “Orphaned Packages” – remove all the orphaned packages – unlike children, packages without a parent repository can have unwanted effects on the system.

  6. #16

    Default Re: sleep does not work

    Ok I deleted it. Sleep and power work fine with windows 11. However not with leap 15.4 anymore.

  7. #17
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,122

    Default Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    However not with leap 15.4 anymore.
    With a little bit of housekeeping, the suspend/sleep may well begin to function as expected again …

  8. #18

    Question Re: sleep does not work

    Did all that and still does not sleep at all.

  9. #19
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    5,122

    Default Re: sleep does not work

    Quote Originally Posted by 1chip View Post
    Did all that and still does not sleep at all.
    Then, an inspection of the systemd Journal for the boot where the Suspend/Sleep issue happened is needed.
    • Near the last entries of the Journal for the boot where it happened, there should be some entries indicating why the Suspend/Sleep didn't.

    We also need an indication of the machine you're using –
    • Open the KDE Plasma Info Center – on the first window, bottom left, there's a button → “Copy to Clipboard”.
    • For non-English KDE sessions, the button is usually located bottom centre.

  10. #20

    Default Re: sleep does not work

    Code:
    ul 30 07:59:57 localhost kernel: Linux version 5.14.21-150400.24.11-default (geeko@buildhost>
    Jul 30 07:59:57 localhost kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150400.24.11>
    Jul 30 07:59:57 localhost kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating poin>
    Jul 30 07:59:57 localhost kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers' 
    Jul 30 07:59:57 localhost kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers' 
    Jul 30 07:59:57 localhost kernel: x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256 
    Jul 30 07:59:57 localhost kernel: x86/fpu: Enabled xstate features 0x7, context size is 832 b>
    Jul 30 07:59:57 localhost kernel: signal: max sigframe size: 1776 
    Jul 30 07:59:57 localhost kernel: BIOS-provided physical RAM map: 
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009ffff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000000a0000-0x00000000000fffff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x0000000000100000-0x0000000009cfffff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x0000000009d00000-0x0000000009ffffff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x000000000a000000-0x000000000a1fffff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x000000000a200000-0x000000000a20afff] ACPI>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x000000000a20b000-0x000000000affffff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x000000000b000000-0x000000000b01ffff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x000000000b020000-0x00000000d9e81fff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000d9e82000-0x00000000db363fff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000db364000-0x00000000db3e0fff] ACPI>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000db3e1000-0x00000000db4f5fff] ACPI>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000db4f6000-0x00000000dc36dfff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000dc36e000-0x00000000deffffff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000df000000-0x00000000dfffffff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000f8000000-0x00000000fbffffff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x00000000fd000000-0x00000000ffffffff] rese>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x0000000100000000-0x000000039effffff] usab>
    Jul 30 07:59:57 localhost kernel: BIOS-e820: [mem 0x000000039f000000-0x000000041effffff] rese>
    Jul 30 07:59:57 localhost kernel: NX (Execute Disable) protection: active 
    Jul 30 07:59:57 localhost kernel: e820: update [mem 0xd3a7a018-0xd3a87457] usable ==> usable
    Jul 30 07:59:57 localhost kernel: e820: update [mem 0xd3a7a018-0xd3a87457] usable ==> usable
    lines 1-31
    
    
    Operating System: openSUSE Leap 15.4
    KDE Plasma Version: 5.24.4
    KDE Frameworks Version: 5.90.0
    Qt Version: 5.15.2
    Kernel Version: 5.14.21-150400.24.11-default (64-bit)
    Graphics Platform: X11
    Processors: 8 × AMD Ryzen 5 PRO 3400G with Radeon Vega Graphics
    Memory: 13.6 GiB of RAM
    Graphics Processor: AMD Radeon™ Vega 11 Graphics

Page 2 of 5 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •