Page 1 of 5 123 ... LastLast
Results 1 to 10 of 50

Thread: Samba Server funktioniert nicht

  1. #1

    Default Samba Server funktioniert nicht

    Ich wollte über Yast den Samba-Server aufsetzen.
    Als Arbeitsgruppe habe ich "Netzwerk" eingegeben, zwei Freigaben gesetzt, die Firewall geöffnet und die Netbios-Namensauflösung über WINS aktiviert und einen Netbios-
    Namen eingegeben.
    Viele Angaben sind ja sich nicht zu tätigen.
    Vom Windows-Rechner kann der LInux-Rechner über den Netbios-Namen angepingt werden, der Rechner und die Freigaben sind jedoch nicht sichtbar und lassen sich auch nicht suchen.
    Auch in Dolphin tauchen im Netzwerk weder die Freigaben noch die Rechner auf, was tun?
    Meinen Dank an Euch bereits vielmals vorab.

  2. #2
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    1,041

    Default Re: Samba Server funktioniert nicht

    Quote Originally Posted by MrRight2004 View Post
    ... und die Netbios-Namensauflösung über WINS aktiviert ...
    Und Du hast auch einen WINS-Server in Deinem Netzwerk und der ist erreichbar?

    Quote Originally Posted by MrRight2004 View Post
    ... der Rechner und die Freigaben sind jedoch nicht sichtbar und lassen sich auch nicht suchen.
    Soweit mir bekannt wird Netbios-discovery von MS Windows 10 nicht mehr unterstützt. Du solltest Dir das hier durchlesen.

    Ob das Paket wsdd (Web Service Discovery) für openSUSE Leap 15.3 zur Verfügung steht, kann ich Dir nicht sagen. Für openSuSE Tumbleweed ist das Paket im OSS-Repository enthalten.

    Viele Grüße

    susejunky

  3. #3

    Default Re: Samba Server funktioniert nicht

    Also erst einmal vielen Dnak für die NAchricht.
    Es ist richtig, ein WINS_Server ist nicht im Netz und scheidet somit als Suchmöglichkeit auch aus.
    Mit Network-Discovery ist wohl der Netbios-Broadcast gemeint, der mit Windows 10 anscheinend nicht mehr besteht.
    Das Paket wsdd steht unter opensuse 15.3 nicht zu Verfügung, die Frage bleibt somit wie man im Netzwerk-Sequement auf freigegebene Ordner zugreifen kann, besteht hier überhaupt noch eine Möglichkeit?
    Die Beschreibung habe ich mir aus Zeitgründen noch nicht ganz durchlesen können.
    Kann man sonst zumindest bestimmte Ordner noch verbinden oder besteht gar keine Möglichkeit mehr?
    Meinen Dank vielmals an Euch vorab!

  4. #4

    Default Re: Samba Server funktioniert nicht

    Ich sehe jetzt, das wsdd auch für Lepa 15.3 unter https://build.opensuse.org/package/show/network/wsdd Versuchsweise zur Verfügung gestellt wird, dies ist alles allerdings sehr undurchsichtig.
    Kann man dies installieren oder nicht?

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,342

    Default AW: Samba Server funktioniert nicht

    Das ist das Netzwerk Repo.
    Kann man einbinden aber ich stehe auf dem Standpunkt:
    Weniger Repos ist meist ein Mehrwert

    Es ist keine gute Idee zu viele Repos einzubinden.
    Ebenso ist es keine gute Idee, irgendwelche Programme herunterzuladen und zu installieren.

    Besser ist es, mit den Bordmitteln die Verzeichnisse einzubinden.

  6. #6
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    1,041

    Default Re: Samba Server funktioniert nicht

    Quote Originally Posted by MrRight2004 View Post
    ... die Frage bleibt somit wie man im Netzwerk-Sequement auf freigegebene Ordner zugreifen kann, besteht hier überhaupt noch eine Möglichkeit?
    Auch ohne wsdd sollte es möglich sein unter openSUSE Leap 15.3 auf SMB-Netzwerkfreigaben zuzugreifen:

    • Indem man in der Adressleiste von dolphin
      smb://IP-ADRESSE-DES-FREIGEBENDEN-RECHNERS/FREIGABENAME
      eingibt (die GROSS-geschriebenen Angaben sind individuell anzupassen und es ist erforderlich, dass die Pakete kio, kio-core und kio-extra5 installiert sind).
    • Indem man die SMB-Netzwerkfreigaben mit
      Code:
      mount -t cifs -o user=BENUTZER_AUF DEM_SERVER,uid=LOKALER_BENUTZER,gid=LOKALE_GRUPPE,vers=2.1 //IP-ADRESSE-DES-FREIGEBENDEN-RECHNERS/FREIGABENAME /PFAD/ZUM/LOKALEN/ORDNER
      lokal einbindet (die GROSS-geschriebenen Angaben sind individuell anzupassen, für Details siehe man mount).


    Bitte beachte, dass bei beiden Vorgehensweisen immer Teile der Einstellungen in der Datei /etc/samba/smb.conf genutzt werden. Ich empfehle Dir daher dringend man smb.conf zu lesen.

    Unter MS Windows ist es ebenfalls möglich (auch ohne Web Service Discovery) SMB-Netzwerkfreigaben unter Angabe von IP-ADRESSE-DES-FREIGEBENDEN-RECHNERS, FREIGABENAME und BENUTZER_AUF DEM_SERVER lokal einzubinden

    Viele Grüße

    susejunky

  7. #7

    Default Re: Samba Server funktioniert nicht

    Erst einmal vielen Dnak für die Mitteilungen.
    Von meiner Seite wurde versucht die entsprechenden SMB-Freigaben über Dolphin zu erstellen.
    Merwürdigerweise werden die Authentifizierungsdaten für die Freigaben nicht akzeptiert, was nun tun?
    Meinen Dank vielmals vorab!

  8. #8

    Default Re: Samba Server funktioniert nicht

    Noch einmal die Frage, warum werden die Authentifizierungsdaten für die SMB-Freigaben nicht akzeptiert?
    Meinen Dank vielmals vorab!

  9. #9
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    715

    Default Re: Samba Server funktioniert nicht

    Quote Originally Posted by MrRight2004 View Post
    Noch einmal die Frage, warum werden die Authentifizierungsdaten für die SMB-Freigaben nicht akzeptiert?
    Meinen Dank vielmals vorab!
    Hi MrRight2004,

    also hier funktioniert Samba auf 15.3 mit Boardmitteln. Auch von Win10 kommt man an die Verzeichnisse, aber nicht von jedem. Mein Firmen-Laptop erwartet die Firmen-Domain, da geht nichts. Mit dem Laptop meiner Frau geht es. Auch Dolphin lässt uns rein. Es scheint mir mit Deinen Domain-Einstellungen zu tun zu haben. Ich habe in YaST am Server auch einen Domänennamen eingegeben. Beim Versuch des Login über Dolphin wird aber ganz Windoff-typisch "WORKGROUP" vorgeschlagen, damit geht es dann auch. Hast Du in YaST "Domänen-Controller" aktiviert? Das solltest Du besser abschalten. Die weiteren zusätzlichen Optionen in YaST würde ich nur aktivieren, wenn ich auch weiß, ob sie einen Sinn haben. (Ich bin mir da auch nicht sicher....)
    Ansonsten brauchen die Helfer hier sicher mehr Details Deiner Einstellungen, die Du vorgenommen hast. Welche Freigaben mit welchen Parametern hast Du aktiviert etc.

  10. #10

    Default Re: Samba Server funktioniert nicht

    Ich habe in Dolphin die SMB-FReigabe gesetzt: smb://192.168.052/Bilder
    Im anschließenden Authentifikazionsdialog gebe ich ein: Name des Users/ Domäne: NETZWERK/Paßwort
    Auch der Server ist Teil dieser Arbeitsgruppe.
    Dennoch Meldung: Zugriff verweigert, hier müßten ja doch zumindest Leserechte gelten.
    Was tun?
    Meinen Dank im voraus!

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •