Results 1 to 6 of 6

Thread: conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

  1. #1

    Default conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

    on my laptop with opensuse argon with KDE I used yast>software management> to update plasma5-workspace-branding-openSUSE
    but these conflict popped up:

    Code:
    #### YaST2 conflicts list - generated 2022-07-02 19:15:03 ####
    
    
    the to be installed plasma5-workspace-branding-openSUSE-84.87~git20220602T134713~22403ba-lp153.483.1.noarch requires 'plasma5-workspace >= 5.25.2', but this requirement cannot be provided
    not installable providers: plasma5-workspace-5.25.2-lp153.658.1.x86_64[KDE-Frameworks(neon)]
        [ ] Following actions will be done:
    deinstallation of python3-qt5-5.15.6-lp153.193.8.x86_64
    deinstallation of python3-qt3d-qt5-5.15.4-lp153.29.10.x86_64
    deinstallation of python3-qt5-devel-5.15.6-lp153.193.8.x86_64
    deinstallation of python3-qtdatavis3d-qt5-5.15.4-lp153.28.10.x86_64
    deinstallation of python3-qtwebengine-qt5-5.15.6-lp153.34.1.x86_64
    deinstallation of python3-vtk-9.1.0-lp153.177.11.x86_64
    deinstallation of python3-qscintilla-qt5-2.13.1-lp153.3.3.x86_64
    deinstallation of hplip-3.21.10-4.3.1.x86_64
    deinstallation of python3-qt3d-qt5-sip-5.15.4-lp153.29.10.x86_64
    deinstallation of python3-qtdatavis3d-qt5-sip-5.15.4-lp153.28.10.x86_64
    deinstallation of python3-qtwebengine-qt5-sip-5.15.4-lp153.35.2.x86_64
    deinstallation of hplip-scan-utils-3.21.10-4.3.1.x86_64
        [ ] do not install plasma5-workspace-branding-openSUSE-84.87~git20220602T134713~22403ba-lp153.483.1.noarch
    
    
        [ ] break plasma5-workspace-branding-openSUSE-84.87~git20220602T134713~22403ba-lp153.483.1.noarch by ignoring some of its dependencies
    what I have to do?
    it seems that yast want to deinstall hplip and python3, but I need hplip and python and I don't want to deinstall
    Last edited by malcolmlewis; 02-Jul-2022 at 10:45. Reason: Fix misplaced code tags

  2. #2
    Join Date
    Sep 2012
    Posts
    7,859

    Default Re: conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

    Quote Originally Posted by pier_andreit View Post
    what I have to do?
    You have to fix all those packages so they build against KDE 5.25.

    And please, use code tags around computer text. You are not newbie on these forums to not be aware of it.

  3. #3

    Angry Re: conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

    i have the same problem...

    as the op said, we use argon... and not vanilla...

    so, it would be much appreciated, if the maintainers of hplip could fix the dependencies...

    hplip-3.22.4-lp153.242.1.x86_64

    depends on:

    python3-qt5-5.15.6-lp153.193.8.x86_64

    depends on:

    libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit)
    libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit)


    or, as 'zypper' would say:

    Code:
    Computing upgrade...                                                                                                                   
    2 Problems:                                                                                                                            
    Problem: the installed python3-qt5-5.15.6-lp153.193.8.x86_64 requires 'libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided                                                                                                                
    Problem: the installed python3-qt5-5.15.6-lp153.193.8.x86_64 requires 'libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided                                                                                                               
                                                                                                                                           
    Problem: the installed python3-qt5-5.15.6-lp153.193.8.x86_64 requires 'libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided                                                                                                                
      deleted providers: libQt5Core5-5.15.2+kde294-lp153.6.1.x86_64                                                                        
     Solution 1: Following actions will be done:                                                                                           
      keep obsolete libQt5Core5-5.15.2+kde294-lp153.6.1.x86_64                                                                                                                                                                                                                    
      keep obsolete libQt5Gui5-5.15.2+kde294-lp153.6.1.x86_64                                                                              
      keep obsolete libQt5Test5-5.15.2+kde294-lp153.6.1.x86_64                                                                             
      keep obsolete libQt5Widgets5-5.15.2+kde294-lp153.6.1.x86_64                                                                          
      keep obsolete libQt5DBus5-5.15.2+kde294-lp153.6.1.x86_64                                                                             
      keep obsolete libQt5Quick3D5-5.15.2+kde19-lp153.22.4.x86_64                                                                          
      keep obsolete libQt5Sql5-sqlite-5.15.2+kde294-lp153.6.1.x86_64                                                                       
      keep obsolete libQt5Sql5-5.15.2+kde294-lp153.6.1.x86_64                                                                              
     Solution 2: deinstallation of libQt5Quick3D5-5.15.2+kde19-lp153.22.4.x86_64                                                           
     Solution 3: deinstallation of python3-qt5-5.15.6-lp153.193.8.x86_64                                                                   
     Solution 4: break python3-qt5-5.15.6-lp153.193.8.x86_64 by ignoring some of its dependencies                                          
                                                                                                                                           
    Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 3                                              
    Applying solution 3                                                
    
    Problem: the installed python3-qt5-5.15.6-lp153.193.8.x86_64 requires 'libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided                                                                                                               
      deleted providers: libQtQuick5-5.15.2+kde43-lp153.2.2.x86_64                                                                         
     Solution 1: Following actions will be done:                       
      keep obsolete libQtQuick5-5.15.2+kde43-lp153.2.2.x86_64          
      keep obsolete libQt5Gui5-5.15.2+kde294-lp153.6.1.x86_64          
      keep obsolete libQt5Test5-5.15.2+kde294-lp153.6.1.x86_64         
      keep obsolete libQt5Widgets5-5.15.2+kde294-lp153.6.1.x86_64                                                                          
      keep obsolete libQt5DBus5-5.15.2+kde294-lp153.6.1.x86_64         
      keep obsolete libKF5ConfigQml5-5.95.0-lp153.277.1.x86_64         
      keep obsolete libQt5Xml5-5.15.2+kde294-lp153.6.1.x86_64          
     Solution 2: deinstallation of hplip-3.22.4-lp153.242.1.x86_64                                                                         
     Solution 3: deinstallation of libKF5ConfigQml5-5.95.0-lp153.277.1.x86_64                                                              
     Solution 4: break python3-qt5-5.15.6-lp153.193.8.x86_64 by ignoring some of its dependencies                                          
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c/d/?] (c): 2
    greetings...

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,224

    Default AW: conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

    Post your Repo list:
    Code:
    zypper lr -d

  5. #5
    Join Date
    Sep 2012
    Posts
    7,859

    Default Re: conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

    Quote Originally Posted by hemathor View Post
    Code:
    Problem: the installed python3-qt5-5.15.6-lp153.193.8.x86_64 requires 'libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided
    So python3-qt5 has to be fixed to build with whatever versions KDE/Qt currently have. Posting on this forum is unlikely to achieve it. Maintainers are not present here (with very rare exceptions). Open bug report.

  6. #6

    Lightbulb Re: conflict updating plasma5-workspace-branding-openSUSE deinstallation of python3-qt5-5.15.6

    I fixed it: https://build.opensuse.org/package/s...Qt5/python-qt5

    Next time open a bug report with the right people.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •