Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: After using Yast sound to add sound card . . . no sound?

  1. #11

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by deano_ferrari View Post
    For the majority of users, there should be no reason to require audio driver configuration with YaST. If you still think there are issues, run the alsa-info.sh diagnostic script as described here...
    https://en.opensuse.org/SDB:Audio_tr..._to_run_script
    ...and post the link (to the output) that it generates here.
    @deano_ferrari:

    So I ran the script and went through the steps to get:

    Your ALSA information is located at http://alsa-project.org/db/?f=be31d8...aa4f8cca8f3447
    Please inform the person helping you.

    Quote Originally Posted by deano_ferrari View Post
    I still recommend that you run the alsa-info.sh diagnistic script as already advised. Share the link that it provides here, and someone can check all the pertinent details.


    No errors of any kind (when launched from the user console)? Anyway, perhaps show us the output from
    Code:
    pactl list

    There should be no need to do that - the daemon is already running from when you logged in to your preferred desktop.
    "pactl list" shows a very large list of data . . . numerous modules and so forth. Sound is now working, so I don't believe there is any need to scroll down through a long list???

    [edit]: I see now in running a zypper update that I must have locked "pipewire" some time back when there was some dependency issue with pipewire??? [/edit]

  2. #12
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by non_space View Post
    Sound is now working, so I don't believe there is any need to scroll down through a long list???
    Yes, if sound is now working there is no point wasting any further time on it.
    openSUSE Leap 15.4; KDE Plasma 5

  3. #13

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by deano_ferrari View Post
    Yes, if sound is now working there is no point wasting any further time on it.
    @deano_ferrari:

    Well, I only ran that script because you wanted me to . . . sound was working then . . . etc. : - ))

    I found my previous thread about the issues with "pipewire" where I guess someone must have recommended that I lock it for that zypper could upgrade the TW system . . . . Has that issue been resolved so that pipewire could be unlocked??

    Or, no reason to mess with it . . . pulseaudio and/or ALSA are all over the sound production aspect of the system???

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by non_space View Post
    @deano_ferrari:

    Well, I only ran that script because you wanted me to . . . sound was working then . . . etc. : - ))
    Yep, I get that....however these steps are for your own diagnostic education

    No need to trawl through such output when things are now reported as working.

    I found my previous thread about the issues with "pipewire" where I guess someone must have recommended that I lock it for that zypper could upgrade the TW system . . . . Has that issue been resolved so that pipewire could be unlocked??
    I've been using pipewire (openSUSE Leap 15.3) for months with no issue. I have no idea about what you encountered, but easy enough to switch over to it. If you need guidance with that, I recommend starting a new thread dedicated to that.
    openSUSE Leap 15.4; KDE Plasma 5

  5. #15

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by deano_ferrari View Post
    Yep, I get that....however these steps are for your own diagnostic education

    No need to trawl through such output when things are now reported as working.


    I've been using pipewire (openSUSE Leap 15.3) for months with no issue. I have no idea about what you encountered, but easy enough to switch over to it. If you need guidance with that, I recommend starting a new thread dedicated to that.
    Thanks for the pointers . . . SUSE still is "a whole new bag" in my linux learning process . . . .

    OK on the new thread for pipewire . . . . I don't really do enough with sound to make it a "need to know" . . . I just saw malcolmlewis' comment about "I use pipewire && JB Morgan for my sound effects . . . " ??? Something like that. It only came on my radar awhile back when it caused a jam up for zypper . . . .

  6. #16
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,000

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by non_space View Post
    Thanks for the pointers . . . SUSE still is "a whole new bag" in my linux learning process . . . .

    OK on the new thread for pipewire . . . . I don't really do enough with sound to make it a "need to know" . . . I just saw malcolmlewis' comment about "I use pipewire && JB Morgan for my sound effects . . . " ??? Something like that. It only came on my radar awhile back when it caused a jam up for zypper . . . .
    zypper readily installed whatever it took to make it happen:
    Code:
    karl@erlangen:~> systemctl list-unit-files --user '*wire*' 
    UNIT FILE                        STATE    VENDOR PRESET
    pipewire-pulse.service           disabled disabled     
    pipewire-session-manager.service alias    -            
    pipewire.service                 enabled  disabled     
    wireplumber.service              enabled  enabled      
    wireplumber@.service             disabled disabled     
    pipewire-pulse.socket            enabled  enabled      
    pipewire.socket                  enabled  enabled      
    
    7 unit files listed. 
    karl@erlangen:~> systemctl list-units --user '*wire*'      
      UNIT                   LOAD   ACTIVE SUB     DESCRIPTION                       
      pipewire-pulse.service loaded active running PipeWire PulseAudio 
      pipewire.service       loaded active running PipeWire Multimedia Service 
      wireplumber.service    loaded active running Multimedia Service Session Manager
      pipewire-pulse.socket  loaded active running PipeWire PulseAudio 
      pipewire.socket        loaded active running PipeWire Multimedia System Socket 
    
    LOAD   = Reflects whether the unit definition was properly loaded. 
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB. 
    SUB    = The low-level unit activation state, values depend on unit type. 
    5 loaded units listed. Pass --all to see loaded but inactive units, too. 
    To show all installed unit files use 'systemctl list-unit-files'. 
    karl@erlangen:~> 
    When running pulseaudio the audio applet in the system tray frequently experienced surprising changes upon upgrading the system. Since switching to pipewire the applet looks the same. No more changes encountered.
    Code:
    karl@erlangen:~> inxi -Ay132 
    Audio:     Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X] driver: snd_hda_intel 
               Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel 
               Sound Server-1: ALSA v: k5.18.6-1-default running: yes 
               Sound Server-2: PipeWire v: 0.3.52 running: yes 
    karl@erlangen:~> 
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

  7. #17

    Default Re: After using Yast sound to add sound card . . . no sound?

    @karlmistelberger:

    Thanks for showing those commands . . . oddly, today I'm in Gecko Plasma rolling and checking those commands there brought "nothing found" . . . and same for "inxi" . . . "command not found"???

    I guess I didn't install it yet? And perhaps it isn't using pipewire? I believe it comes with Packman already installed . . . .

    Anyway, it'll be a day or so before I rotate back to straight TW to check out the sound status . . . . As you mentioned it did seem like the sound applet was changing . . . intermittently . . . . Perhaps I'll try to unlock pipewire then and see how that fares??

  8. #18

    Default Re: After using Yast sound to add sound card . . . no sound?

    @et al:

    I recently unlocked pipewire and running "inxi -A" now shows extra stuff . . . .

    Code:
    ~> inxi -A
    Audio:
      Device-1: Intel 82801JI HD Audio driver: snd_hda_intel
      Device-2: NVIDIA GK110 High Definition Audio driver: snd_hda_intel
      Sound Server-1: ALSA v: k5.18.9-2-default running: yes
      Sound Server-2: PulseAudio v: 16.0 running: yes
      Sound Server-3: PipeWire v: 0.3.54 running: yes

  9. #19
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by non_space View Post
    @et al:

    I recently unlocked pipewire and running "inxi -A" now shows extra stuff . . . .

    Code:
    ~> inxi -A
    Audio:
      Device-1: Intel 82801JI HD Audio driver: snd_hda_intel
      Device-2: NVIDIA GK110 High Definition Audio driver: snd_hda_intel
      Sound Server-1: ALSA v: k5.18.9-2-default running: yes
      Sound Server-2: PulseAudio v: 16.0 running: yes
      Sound Server-3: PipeWire v: 0.3.54 running: yes
    Ok, but there should be no need to have PulseAudio active (for most application use cases). Instead you can install "pipewire-pulseaudio" to cover for that scenario, and use pipewire exclusively. (That will remove the pulseaudio package.)
    openSUSE Leap 15.4; KDE Plasma 5

  10. #20

    Default Re: After using Yast sound to add sound card . . . no sound?

    Quote Originally Posted by deano_ferrari View Post
    Ok, but there should be no need to have PulseAudio active (for most application use cases). Instead you can install "pipewire-pulseaudio" to cover for that scenario, and use pipewire exclusively. (That will remove the pulseaudio package.)
    @deano_ferrari:

    Alrighty, thanks for the suggestion on it . . . traditionally I have been a "belt AND suspenders" kind of a guy, so I guess now I am a "belt, suspenders, and belt" person??

    I don't mess with sound stuff too much, basically just trying to "keep up" with the TW rolling upgrades . . . but somewhere in the history pipewire got into dependency issues . . . now seemingly on the other side of them.

    I'll look into this combo package when I rotate back to TW . . . tomorrow possibly . . . .

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •