Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Annoying behavior when typing accents.

  1. #1
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    31

    Default Annoying behavior when typing accents.

    I know is not a big deal and maybe it's a silly question, but this is really annoying me and I hope somebody help me.

    After installing 15.4 in my old laptop, I notice something different. Every time that I type some accent key they show up in the text box with a underline character, just like the image. They usually stay hide until I press another key.


    On KDE this only happen on browsers, but when using Gnome, this happen everywhere. I made a quick test using another VM with KDE Neon and the typing works normally, just like in the Opensuse 15.3. So it's a Opensuse 15.4 thing.

    Any Idea to fix that?

  2. #2
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    31

    Default Re: Annoying behavior when typing accents.

    I made another test and installed Falkon and Konqueror, two Qt browsers, and there is no annoying underline on both when typing accents. So I can only conclude that is another GTK issue.

  3. #3
    Join Date
    Jun 2020
    Location
    Brazil
    Posts
    4

    Default Re: Annoying behavior when typing accents.

    Não é um “comportamento estranho”, é uma funcionalidade.

    Quaisquer método de entrada que use GTK há de se comportar à mesma, ajuda ao se utilizar linguagens de programação onde tem-se de escrever o acento grave mais de uma vez, a exemplo do markdown.

    E não, aparentemente, não há volta.

  4. #4
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    31

    Default Re: Annoying behavior when typing accents.

    E não, aparentemente, não há volta.
    Esse era o meu temor. Está parecido quando o google muda a interfaçe do youtube sem ninguém pedir por tal e todo mundo tem que engolir. Faz parte.

    O jeito é se adaptar(ou se o TOC realmente bater pesado, pensar em mudar pro KDE neon). Mas acho que ficarei mais um tempinho usando o 15.3 no PC principal.

    Obrigado pela atenção.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,934

    Default Re: Annoying behavior when typing accents.

    Quote Originally Posted by McCloud View Post
    So I can only conclude that is another GTK issue.
    Or, a VirtualBox issue – you seem to be running Leap in a Virtual Machine …

  6. #6

    Default Re: Annoying behavior when typing accents.

    Certainly not. I don't see this effect. I have a German keyboard and layout German (dead tilde). When I type Portuguese special characters everything is fine. Which is your keyboard and layout? Do you start Plasma Wayland or X11?

    Best regards,
    Bequimao

  7. #7
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    31

    Default Re: Annoying behavior when typing accents.

    Quote Originally Posted by dcurtisfra View Post
    Or, a VirtualBox issue – you seem to be running Leap in a Virtual Machine …
    I use virtualbox only to make some tests and get some screenshots to post. On my laptop, with a fresh and normal install of 15.4 running KDE, this happens too.

    Quote Originally Posted by Bequimao View Post
    When I type Portuguese special characters everything is fine. Which is your keyboard and layout? Do you start Plasma Wayland or X11?
    My notebook is an Acer with a PT-BR keyboard, with defaults settings. And I'm starting using X11.

    And the underline shows up only when I type accents keys(~ ` ´ ^) , when I press the Ç key, no underline.

    Really weird.

  8. #8
    Join Date
    Jun 2020
    Location
    Brazil
    Posts
    4

    Default Re: Annoying behavior when typing accents.


  9. #9
    Join Date
    Jun 2019
    Location
    São Paulo - Brazil
    Posts
    31

    Default Re: Annoying behavior when typing accents.

    Quote Originally Posted by JulianoSC View Post
    Great. Now I have a reason to hate Gnome/GTK devs even more.

  10. #10

    Default Re: Annoying behavior when typing accents.

    Now I see the same behaviour with my German dead tilde keyboard. Sorry, disregard my post #6.

    It is really annoying. One might even think that dead keys stopped working and stop typing,

    Abraços
    Bequimão

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •