Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Corrupted text at boot when graphics mode begin - how to fix?

  1. #1

    Question Corrupted text at boot when graphics mode begin - how to fix?

    I've had a problem with corrupted (garbled) text in boot for quite some time. Booting starts fine, text is readable but once graphic mode kicks in all texts become corrupted. It's like every x th vertical line is missing. It's possible to guess quite much of the text but not so easy. Almost impossible to fix something from shell if GUI doesn't work for some reason.

    These are kernel boot parameters:
    Code:
    terminal=console nomode set iommu=1 amd_iommu=on rd.driver.pre=vfio-pci amdgpu.dc=0
    Console resolution has been set to 3840x2160.

    I've tried changing above parameters and resolution many many times without any impact. Yes, resolution changes but text remains corrupted.

    CPU (if that matters): Ryzen 1900X
    GFX: Radeon 540/540X/550/550X / RX 540X/550/550X (according to HW info)

    Would be really nice to get this problem solved.

  2. #2
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,250
    Blog Entries
    15

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Hi
    You have nomodeset active? (Or it's a typo in your output I see nomode set), anyway that should not be needed.

    For vfio-pci passthrough why that entry, I've normally set via modprobe.d files, I'm on intel and use intel_iommu=on

    For console fonts I use vconsole.font=ter-v32b video=1920x1080@60 to set font and resolution as well as the same font in /etc/vconsole.conf.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,989
    Blog Entries
    1

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by paju-21 View Post
    Code:
    terminal=console nomode set iommu=1 amd_iommu=on rd.driver.pre=vfio-pci amdgpu.dc=0
    How did you go about deciding any of those might be needed? What results when you use none of them? Have you tried plymouth=0 or just removing plymouth altogether? Does the problem persist indefinitely in any graphics mode, or is this only until you get logged in from a GUI login manager? Are there *.conf files anywhere in /etc/X11/ directed to graphics or screen configuration? What time did this start, after an upgrade? After switching kernel, e.g. from 5.16.x to 5.17.x? Have you tried increasing BIOS configuration for minimum RAM allocated to graphics?

    Console resolution has been set to 3840x2160.
    Has been set how exactly?
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  4. #4

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You have nomodeset active? (Or it's a typo in your output I see nomode set), anyway that should not be needed.

    For vfio-pci passthrough why that entry, I've normally set via modprobe.d files, I'm on intel and use intel_iommu=on

    For console fonts I use vconsole.font=ter-v32b video=1920x1080@60 to set font and resolution as well as the same font in /etc/vconsole.conf.

    nomode set was actually not typo. Didn't see the error before you lifted it up It used to be correctly written but didn't have any impact. Removed now.

    Don't recall anymore from where I got these settings but these were recommendations for virtual machines and Ryzen.

    vconsole.conf has following (never touched this file):
    Code:
    
    KEYMAP=fi-kotoistus 
    FONT=eurlatgr.psfu 
    FONT_MAP= 
    FONT_UNIMAP=
    
    I'll add those settings to see if they make any difference.

  5. #5

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by mrmazda View Post
    How did you go about deciding any of those might be needed? What results when you use none of them? Have you tried plymouth=0 or just removing plymouth altogether? Does the problem persist indefinitely in any graphics mode, or is this only until you get logged in from a GUI login manager? Are there *.conf files anywhere in /etc/X11/ directed to graphics or screen configuration? What time did this start, after an upgrade? After switching kernel, e.g. from 5.16.x to 5.17.x? Have you tried increasing BIOS configuration for minimum RAM allocated to graphics?

    Has been set how exactly?
    Don't recall anymore exactly the purpose of those settings but I found these settings prior reinstalling OS. These are for virtual machine usage and Ryzen (or AMD in general, don't recall). Haven't rechecked if these are needed. amdgpu setting was to get rid off power saving issues with AMD card and HDMI. Haven't checked if the root cause have been solved.

    Haven't tried plymouth=0 but will test it. Plymouth is installed.

    The problem only starts after (my assumption, not 100% sure) graphics mode is set during boot. Prior this I guess some kind of VESA mode is used. Problem lasts until GUI login screen appear. Then there's no issue anymore. KDE consoles or virtual screen don't have any issue.

    /etc/X11/xorg.conf.install can be found. Content:
    Code:
    Section "Device" 
      Identifier "vboxvideo" 
      Driver  "vboxvideo" 
    EndSection 
    
    Section "Screen" 
      Identifier "vboxvideo" 
      Device "vboxvideo" 
    EndSection 
    
    
    Section "Device" 
      Identifier "vmware" 
      Driver  "vmware" 
    EndSection 
    
    Section "Screen" 
      Identifier "vmware" 
      Device "vmware" 
    EndSection 
    
    
    Section "Device" 
      Identifier "modesetting" 
      Driver  "modesetting" 
      Option "PreferCloneMode" "true" 
    EndSection 
    Section "Screen" 
      Identifier "modesetting" 
      Device "modesetting" 
    EndSection 
    
    
    Section "Device" 
      Identifier "fbdev" 
      Driver  "fbdev" 
    EndSection 
    Section "Screen" 
      Identifier "fbdev" 
      Device "fbdev" 
    EndSection 
    
    
    Section "Device" 
      Identifier "vesa" 
      Driver  "vesa" 
    EndSection 
    
    Section "Screen" 
      Identifier "vesa" 
      Device "vesa" 
    EndSection 
    
    
    Section "ServerLayout" 
      Identifier "Layout" 
      Screen  "vboxvideo" 
      Screen  "vmware" 
      Screen  "modesetting" 
      Screen  "fbdev" 
      Screen  "vesa" 
    EndSection
    
    I'm not using vmware nor VirtualPC. Just KVM (qemu).

    Don't recall exactly when this started but way more than one year ago. Probably between 2 to 3 years. I've tried to solve this few times without success. Normally I don't shutdown computer as it is both server and workstation. Although past year or two the stability of KDE and Firefox has gone downwards leading to fully frozen GUI which freezes pretty much everything. Not even SSH server can respond. Keyboard doesn't respond in any way except via magic keys to shutdown the computer. But this is different matter.

    Have not increased RAM for graphics. Not sure if that setting in BIOS even exist because Ryzen doesn't have integrated GPU. I'm using quite basic AMD GFX card.

  6. #6
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,989
    Blog Entries
    1

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by paju-21 View Post
    The problem only starts after (my assumption, not 100% sure) graphics mode is set during boot. Prior this I guess some kind of VESA mode is used. Problem lasts until GUI login screen appear. Then there's no issue anymore. KDE consoles or virtual screen don't have any issue.
    What you've described here is the period when Plymouth is active.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  7. #7
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,250
    Blog Entries
    15

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by paju-21 View Post
    Don't recall anymore exactly the purpose of those settings but I found these settings prior reinstalling OS. These are for virtual machine usage and Ryzen (or AMD in general, don't recall). Haven't rechecked if these are needed. amdgpu setting was to get rid off power saving issues with AMD card and HDMI. Haven't checked if the root cause have been solved.

    Haven't tried plymouth=0 but will test it. Plymouth is installed.

    The problem only starts after (my assumption, not 100% sure) graphics mode is set during boot. Prior this I guess some kind of VESA mode is used. Problem lasts until GUI login screen appear. Then there's no issue anymore. KDE consoles or virtual screen don't have any issue.

    /etc/X11/xorg.conf.install can be found. Content:
    Code:
    Section "Device" 
      Identifier "vboxvideo" 
      Driver  "vboxvideo" 
    EndSection 
    
    Section "Screen" 
      Identifier "vboxvideo" 
      Device "vboxvideo" 
    EndSection 
    
    
    Section "Device" 
      Identifier "vmware" 
      Driver  "vmware" 
    EndSection 
    
    Section "Screen" 
      Identifier "vmware" 
      Device "vmware" 
    EndSection 
    
    
    Section "Device" 
      Identifier "modesetting" 
      Driver  "modesetting" 
      Option "PreferCloneMode" "true" 
    EndSection 
    Section "Screen" 
      Identifier "modesetting" 
      Device "modesetting" 
    EndSection 
    
    
    Section "Device" 
      Identifier "fbdev" 
      Driver  "fbdev" 
    EndSection 
    Section "Screen" 
      Identifier "fbdev" 
      Device "fbdev" 
    EndSection 
    
    
    Section "Device" 
      Identifier "vesa" 
      Driver  "vesa" 
    EndSection 
    
    Section "Screen" 
      Identifier "vesa" 
      Device "vesa" 
    EndSection 
    
    
    Section "ServerLayout" 
      Identifier "Layout" 
      Screen  "vboxvideo" 
      Screen  "vmware" 
      Screen  "modesetting" 
      Screen  "fbdev" 
      Screen  "vesa" 
    EndSection
    
    I'm not using vmware nor VirtualPC. Just KVM (qemu).

    Don't recall exactly when this started but way more than one year ago. Probably between 2 to 3 years. I've tried to solve this few times without success. Normally I don't shutdown computer as it is both server and workstation. Although past year or two the stability of KDE and Firefox has gone downwards leading to fully frozen GUI which freezes pretty much everything. Not even SSH server can respond. Keyboard doesn't respond in any way except via magic keys to shutdown the computer. But this is different matter.

    Have not increased RAM for graphics. Not sure if that setting in BIOS even exist because Ryzen doesn't have integrated GPU. I'm using quite basic AMD GFX card.
    Hi
    Just to clarify Tumbleweed is the host operating system, or your running Tumbleweed in a virtual machine?

    If the host is running Tumbleweed, then there is no need for an /etc/X11/xorg.conf file.... there is no need for vfio-pci either (unless your planning on GPU or other hardware passthrough eg SATA).

    Yes, the HDMI bug is still present in my last check (I run an RX550 GPU as primary graphics) Ref: https://gitlab.freedesktop.org/drm/amd/-/issues/662

    My /etc/vconsole.conf file contains;

    Code:
    KEYMAP=us
    FONT=ter-v32b
    FONT_MAP=
    FONT_UNIMAP=
    Font is the same as the kernel option....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Just to clarify Tumbleweed is the host operating system, or your running Tumbleweed in a virtual machine?

    If the host is running Tumbleweed, then there is no need for an /etc/X11/xorg.conf file.... there is no need for vfio-pci either (unless your planning on GPU or other hardware passthrough eg SATA).

    Yes, the HDMI bug is still present in my last check (I run an RX550 GPU as primary graphics) Ref: https://gitlab.freedesktop.org/drm/amd/-/issues/662

    My /etc/vconsole.conf file contains;

    Code:
    KEYMAP=us
    FONT=ter-v32b
    FONT_MAP=
    FONT_UNIMAP=
    Font is the same as the kernel option....
    Thumbleweed is host. I also have one virtual machine with Tumbleweed and that works fine in boot as well (no corrupted text there).

    Took out vfio-pci --> no impact. (Now I remembered that I was planning to utilize better video performance for virtual machine via passthrough but that didn't turn out to be success..)
    Added earlier plymouth=0 to kernel boot parameters --> no impact.
    Changed vconsole.conf FONT to ter-v32b --> no impact.

  9. #9

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by mrmazda View Post
    What you've described here is the period when Plymouth is active.
    OK. I added plymouth=0 to kernel parameters but that did not help. Incorrect place?

    Plymouth is not familiar to me. Apparently provides high res graphs for boot but something seems to be broken with it. Should I just uninstall it? zypper rm plymouth. Or is it otherwise valuable package?

  10. #10
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,989
    Blog Entries
    1

    Default Re: Corrupted text at boot when graphics mode begin - how to fix?

    Quote Originally Posted by paju-21 View Post
    OK. I added plymouth=0 to kernel parameters but that did not help. Incorrect place?
    That's the option on the Linuxrc web page. Added at the Grub menu via E key? Only to /etc/default/grub? Or added to /etc/default/grub and grub.cfg regenerated? Other possibilities, besides uninstalling, are noplymouth and plymouth.enable=0

    Plymouth is not familiar to me. Apparently provides high res graphs for boot but something seems to be broken with it. Should I just uninstall it? zypper rm plymouth. Or is it otherwise valuable package?
    Value is in the eye of the beholder. From where I sit, it's primarily bling/bloat, imitating Windows startup. It's installed on none of my hundreds of Gnu/Linux installations that don't depend on it.

    Something seemingly unrelated: In BIOS, disable the graphical curtain that hides POST messages.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •