Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Internal hard drives show up as removable media

  1. #1

    Default Internal hard drives show up as removable media

    I used the GUI partitioner tool within yast to create and mount the partitions on a few internal hard drives. The exact same way I did it many times before with no issue.
    But this time, I somehow get the partitions/drives show up as removable media e.g. in Dolphin. And I have no idea where I went wrong. How do I fix this, and/or avoid the problem when creating new partitions?

    /etc/fstab looks like this:
    Code:
    
    UUID=b4af5d0f-1469-45e5-94fe-f224c222f63a  /          ext4  defaults      0  1 
    UUID=1003-1857                             /boot/efi  vfat  utf8          0  2 
    UUID=177ef1d2-5d85-435f-aa1e-2e7edc576c3f  swap       swap  defaults      0  0 
    UUID=b6e4aed6-1f8e-490b-ac15-bb93c3966ee3  /scratch   ext4  data=ordered  0  2 
    UUID=f9416a21-06a1-4907-b5cd-463a21de4a8c  /home      ext4  data=ordered  0  2 
    UUID=82340b75-e854-4f63-a9c4-f7dedd583a2d  /data3     ext4  data=ordered  0  2 
    UUID=92718871-9173-41f1-8bcf-3796a660160b  /data2     ext4  data=ordered  0  2 
    UUID=10923ed7-50df-434a-a9d1-6d29e8d0e7ce  /data1     ext4  data=ordered  0  2
    
    lsblk:
    Code:
    NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT 
    sda           8:0    1  14.6T  0 disk  
    └─sda1        8:1    1  14.6T  0 part /data1 
    sdb           8:16   1  14.6T  0 disk  
    └─sdb1        8:17   1  14.6T  0 part /data2 
    sdc           8:32   1  14.6T  0 disk  
    └─sdc1        8:33   1  14.6T  0 part /data3 
    nvme0n1     259:0    0 953.9G  0 disk  
    ├─nvme0n1p1 259:1    0   512M  0 part /boot/efi 
    ├─nvme0n1p2 259:2    0 102.4G  0 part / 
    ├─nvme0n1p3 259:3    0 102.4G  0 part [SWAP] 
    └─nvme0n1p4 259:4    0 748.6G  0 part /home 
    nvme1n1     259:6    0   5.8T  0 disk  
    └─nvme1n1p1 259:7    0   5.8T  0 part /scratch
    I assume "RM" in lsblk stands for removable media. But again, no idea where I messed this up.

  2. #2

    Default Re: Internal hard drives show up as removable media

    For the record, the problematic ones are 3.5" SATA hard drives. Mainboard is a Gigabyte MZ72-HB0.
    The two NVMe SSDs in the system are fine.

    I read other sources where similar problems could be solved by disabling some hot-plug settings in bios. I only found one such setting in my bios, and neither of the available options changed anything. For SATA configuration, there are no settings that can be changed in my bios.

  3. #3
    Join Date
    Sep 2012
    Posts
    7,662

    Default Re: Internal hard drives show up as removable media

    "removable" indication comes directly from kernel (/sys/block/sda/removable) and is set according to SCSI INQUIRY command response. You should also see "attached removable SCSI disk" or similar in kernel log on boot. Reboot, and provide full output of "journalctl -b" immediately after boot (upload to https://susepaste.org/).

  4. #4

    Default Re: Internal hard drives show up as removable media

    https://susepaste.org/73277471

    there are indeed entries for each of these HDDs: "Attached SCSI removable disk"
    I deleted the partitions on these disks since I made the initial post, if anyone is wondering about inconsistencies. But lsblk still shows the disks themselves as removable media.

  5. #5
    Join Date
    Sep 2012
    Posts
    7,662

    Default Re: Internal hard drives show up as removable media

    Quote Originally Posted by flotus1 View Post
    I read other sources where similar problems could be solved by disabling some hot-plug settings in bios.
    This was fixed in kernel 4.5.

    Where disks are connected? This motherboard has 4 internal SATA ports and three SlimSAS ports.

  6. #6

    Default Re: Internal hard drives show up as removable media

    They are connected to the SATA ports

  7. #7
    Join Date
    Sep 2012
    Posts
    7,662

    Default Re: Internal hard drives show up as removable media

    Quote Originally Posted by flotus1 View Post
    They are connected to the SATA ports
    Code:
    May 26 08:32:27 localhost kernel: ahci 0000:43:00.0: flags: 64bit ncq sntf ilck pm led clo only pmp fbs pio slum part ems sxs
    SXS means host controller supports eSATA. Linux kernel marks device as removable if it is connected to eSATA port. Unfortunately, I am not sure how it can be verified from user space. So it looks like your BIOS marks these ports as eSATA. There is really nothing that can be done here from kernel side. It is not a kernel bug.

  8. #8
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,837

    Default Re: Internal hard drives show up as removable media

    Quote Originally Posted by flotus1 View Post
    I read other sources where similar problems could be solved by disabling some hot-plug settings in bios. I only found one such setting in my bios, and neither of the available options changed anything. For SATA configuration, there are no settings that can be changed in my bios.
    To my experience bios hot plug settings won't never flag drives as removable. Check automounter configuration for drive, e.g. .config/kded_device_automounterrc.
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

  9. #9

    Default Re: Internal hard drives show up as removable media

    All right, thanks for the effort.
    So I guess I would need to find out how to get the board to not flag these ports as eSATA. So far, I could not find any bios setting that might be responsible. And Gigabyte enterprise support won't be any help either, they just don't reply to tickets.

    What do you think of the workaround proposed here: https://bbs.archlinux.org/viewtopic.php?id=208514

    If your BIOS won't let you change the hotplug flag, you can work around this with udev rules. For example:

    #/etc/udev/rules.d/62-internal-disk.rules

    # don't show any partition of disk sda or sdb on the desktop
    KERNEL=="sd[a-b]*",ENV{UDISKS_IGNORE}="1"
    # don't show any member of lvm volume group j on the desktop
    ENV{DM_VG_NAME}=="j",ENV{UDISKS_IGNORE}="1"
    This will also remove the devices from the 'Places' panel in Dolphin.

  10. #10

    Default Re: Internal hard drives show up as removable media

    Quote Originally Posted by karlmistelberger View Post
    To my experience bios hot plug settings won't never flag drives as removable. Check automounter configuration for drive, e.g. .config/kded_device_automounterrc.
    Where would i find that? It's not in the user home directory.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •