Results 1 to 6 of 6

Thread: Windows 10 No Longer a Boot Option After openSUSE Installation

  1. #1

    Default Windows 10 No Longer a Boot Option After openSUSE Installation

    Hi everyone,

    I realize there are few other posts similar to this one floating around on the forums, but I was either unable to make the solutions work or to understand them. As the title suggests, I recently installed openSUSE onto a partition, however I am not seeing a boot option for Windows 10 now. I'm entirely new to a non-MS OS, so detailed instructions are appreciated.

    sudo os-prober
    doesn't return anything, Probe Foreign OS is selected in the Boot Loader.

    sudo fdisk -l


    Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
    Disk model: Samsung SSD 850
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x3fe102d9

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 1874321407 1874319360 893.7G 7 HPFS/NTFS/exFAT
    /dev/sda2 1952446464 1953519615 1073152 524M 27 Hidden NTFS WinRE
    /dev/sda3 1874321408 1874847743 526336 257M ef EFI (FAT-12/16/32)
    /dev/sda4 1874847744 1952446463 77598720 37G f W95 Ext'd (LBA)
    /dev/sda5 1874849792 1948250111 73400320 35G 83 Linux
    /dev/sda6 1948252160 1952446463 4194304 2G 82 Linux swap / Solaris

    Partition table entries are not in disk order.

    sudo blkid

    /dev/sda1: LABEL="New Volume" BLOCK_SIZE="512" UUID="A6CEA828CEA7EF2D" TYPE="ntfs" PARTUUID="3fe102d9-01"
    /dev/sda2: BLOCK_SIZE="512" UUID="DEAAE245AAE219B3" TYPE="ntfs" PARTUUID="3fe102d9-02"
    /dev/sda3: UUID="657D-25A4" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="3fe102d9-03"
    /dev/sda5: UUID="a3cf18c9-64ad-4f73-825d-731476ee2d74" UUID_SUB="a1a23395-8c9b-41a0-a98c-2ef1e99a0903" BLOCK_SIZE="4096" TYPE="btrfs" PARTUUID="3fe102d9-05"
    /dev/sda6: UUID="149b8fda-5680-4fed-8829-cbafbc2f7bea" TYPE="swap" PARTUUID="3fe102d9-06

    Thanks!

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,983
    Blog Entries
    3

    Default Re: Windows 10 No Longer a Boot Option After openSUSE Installation

    I'm partly guessing here.

    You are using a DOS partition table
    Code:
    Disklabel type: dos
    However, you have an EFI partition:
    Code:
    /dev/sda3 1874321408 1874847743 526336 257M ef EFI (FAT-12/16/32)
    As far as I know, Windows can only use traditional BIOS/MBR booting when DOS partitioning is used.

    It seems likely that you have openSUSE booting with UEFI, and Windows booting with BIOS/MBR. And that would cause the problem that you are having.

    If I am correct, you should be able to set your BIOS to boot Windows -- but then it would not boot openSUSE.

    If you can get that working, then we can tell you how to modify openSUSE to also use BIOS/MBR booting, and thus avoid the problem. This will require having the install media available (to boot the rescue system).
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  3. #3

    Default Re: Windows 10 No Longer a Boot Option After openSUSE Installation

    Thanks for the response!

    Quote Originally Posted by nrickert View Post
    you should be able to set your BIOS to boot Windows
    This can be done through the startup menu?

    Quote Originally Posted by nrickert View Post
    This will require having the install media available (to boot the rescue system).
    The openSUSE installation media?

    I'm less than tech savvy so detailed steps are helpful. Thanks again!

  4. #4

    Default Re: Windows 10 No Longer a Boot Option After openSUSE Installation

    Quote Originally Posted by Seristal View Post
    This can be done through the startup menu?!
    I've managed to boot back into Windows through the aforementioned method.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,983
    Blog Entries
    3

    Default Re: Windows 10 No Longer a Boot Option After openSUSE Installation

    Quote Originally Posted by Seristal View Post
    I've managed to boot back into Windows through the aforementioned method.
    Good. At least that shows that Windows is not actually broken.

    I'm not sure what's the easiest way to go from here.

    Let me put that differently. If it were my system, I would not have any problems fixing it. But I'm not sure what will be the least confusing to you.

    Can you still get into openSUSE? If you can, then use

    Yast --> System --> Bootloader

    It should show a box where it lists:

    Boot Loader
    GRUB2 for EFI

    You should be able to change that to:

    GRUB2

    Save those changes.

    And this is where it now gets confusing. You will need to retry the steps you used to boot Windows. But this time, it should boot openSUSE though with a Windows option in the menu. But, more confusing, it is possible that the Windows option might not be there. In that case, check the output from
    Code:
    sudo efibootmgr -v
    and it will probably give an error message, something like "efivars not available". If that happens, then you booted the right way.

    I think I'll wait for further feedback from you before suggesting anything further.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  6. #6

    Default Re: Windows 10 No Longer a Boot Option After openSUSE Installation

    Hi, I don't know, if it will help you, but I had the same problem today, which led me into installing leap twice. All was my fault - I had windows installed as uefi, but booted my usb stick by name without uefi word. System booted to leap, but windows were not visible. So I needed to reboot, selected boot option of my lexar usb stick with "UEFI" word and then it worked, now I have dual boot working again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •