Results 1 to 2 of 2

Thread: SLES SAP 12.4 - cannot re-register in Azure - object has no attribute 'generateRegionSrvArgs'

  1. #1

    Default SLES SAP 12.4 - cannot re-register in Azure - object has no attribute 'generateRegionSrvArgs'

    Hello

    Cleaned repos and all other Azure cloud connection data per this KB: https://www.suse.com/support/kb/doc/?id=000019085


    But when trying to regiter:
    Code:
     # /usr/sbin/registercloudguest --force-new
    I get

    Code:
    /etc/zypp/repos.d # /usr/sbin/registercloudguest --force-new
    Traceback (most recent call last):
      File "/usr/sbin/registercloudguest", line 279, in <module>
        region_smt_data = utils.fetch_smt_data(cfg, proxies)
      File "/usr/lib/python3.4/site-packages/cloudregister/registerutils.py", line 238, in fetch_smt_data
        api = add_region_server_args_to_URL(api, cfg)
      File "/usr/lib/python3.4/site-packages/cloudregister/registerutils.py", line 87, in add_region_server_args_to_URL
        regionSrvArgs = mod.generateRegionSrvArgs()
    AttributeError: 'module' object has no attribute 'generateRegionSrvArgs'
    Does maybe anybody know how to move from here? Didnt find anything on the Internets

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,702

    Default Re: SLES SAP 12.4 - cannot re-register in Azure - object has no attribute 'generateRegionSrvArgs'

    Sorry, you are at the wrong forums. This is openSUSE, for SLES/SLED better go to https://community.suse.com/
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •