Results 1 to 4 of 4

Thread: Docker-compose version

  1. #1

    Default Docker-compose version

    Hello, I need to install docker-compose version 3.8 and using YAST this is the only version I found:

    docker-compose version 1.25.1, build a82fef0
    docker-py version: 4.2.0
    CPython version: 3.6.15
    OpenSSL version: OpenSSL 1.1.1d 10 Sep 2019


    To execute this command:


    docker-compose up
    this is the console output:


    Version in "./docker-compose.yml" is unsupported. You might be seeing this error because you're using the wrong Compose file version. Either specify a supported version (e.g "2.2" or "3.3") and place your service definitions under the `services` key, or omit the `version` key and place your service definitions at the root of the file to use version 1.For more on the Compose file format versions, see https://docs.docker.com/compose/compose-file/


    How can I install a different verison of docker-compose?

    Thanks.

  2. #2
    Join Date
    Sep 2012
    Posts
    7,640

    Default Re: Docker-compose version

    Quote Originally Posted by julianov View Post
    I need to install docker-compose version 3.8
    Such version does not exist. Where have you got this version number from?

  3. #3

    Default Re: Docker-compose version

    Quote Originally Posted by arvidjaar View Post
    Such version does not exist. Where have you got this version number from?
    Thanks for the reply. I need this version:



  4. #4
    Join Date
    Sep 2012
    Posts
    7,640

    Default Re: Docker-compose version

    You confuse compose file format version with docker-compose program version. Compose 3.8 is supported starting with docker-compose 1.25.5. docker-compose 1.28.5 is available from devel:languages:python:backports (https://software.opensuse.org//downl...docker-compose)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •