Results 1 to 3 of 3

Thread: Versión de docker compose

  1. #1

    Default Versión de docker compose

    Hola a todos.

    Al instalar docker compose a través de Yast, tengo lo siguiente:

    Code:
    docker-compose version 1.25.1, build a82fef0
    docker-py version: 4.2.0
    CPython version: 3.6.15
    OpenSSL version: OpenSSL 1.1.1d  10 Sep 2019
    Tengo que ejecutar el siguiente docker con:

    Code:
    docker-compose up
    y obtengo la siguiente salida por consola:

    Code:
    Version in "./docker-compose.yml" is unsupported. You might be seeing this error because you're using the wrong Compose file version. Either specify a supported version (e.g "2.2" or "3.3") and place your service definitions under the `services` key, or omit the `version` key and place your service definitions at the root of the file to use version 1.For more on the Compose file format versions, see https://docs.docker.com/compose/compose-file/
    ¿Cómo puedo instalar una versión más nueva de docker compose? el archivo que tengo que levantar es tiene la versión version: "3.8"

  2. #2

    Default Re: Versión de docker compose

    En su día, instale docker y funcionaba.

    Voy a ver.

    PD: No veo el paquete docker-compose, como no sea esto, ¿lo es?.
    Code:
    zypper se docker | grep -i compose
      | python2-docker-compose                | Tool to define and run complex applications using Docker     | paquete
      | python3-docker-compose                | Tool to define and run complex applications using Docker     | paquete
    
    
    Para que sirve el comando
    docker-compose
    Last edited by DiabloRojo; 24-May-2022 at 07:38.
    "I know that I know nothing" Socrates
    "Do not pretend things happen the way you want. Want, rather, that occur as they occur, and be happy" Epictetus
    "Compound interest, the eighth wonder of the world" Mayer Amschel Rothschild

  3. #3
    Join Date
    Mar 2014
    Location
    Canary Island Lat. 27.994547-15.405127 Lon-160m sea level
    Posts
    233

    Default Re: Versión de docker compose

    Hola:

    Con permiso.

    Según la web, es un programa o utilidad que sirve para trabajar con contenedores (contenedores de software) .

    Y no se si necesita alguna cuenta de azure .

    Saludos cordiales .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •