Results 1 to 6 of 6

Thread: No audio device found on Thinkpad

  1. #1

    Default No audio device found on Thinkpad

    Hello, I have a Thinkpad X1 Yoga 4th gen which has a Whiskey Lake SoC i7-8665u. I have having Ubuntu for a while. But, these days I thought about switching to OpenSUSE Tumbleweed. At the momemt, I have installed Tumbleweed on an external NVMe SSD in anUSB case to try it out. Almost everything works fine and this morning I was actually thinking about interchanging the SSDs to make OpenSuse beeing installed internally. But, then I realised that there is no sound at all.

    Of course, my Laptop does have a sound card, which works pretty fine on Kubuntu 21.10.
    I hope that it isn't a problem that the language on the screenshots is Dutch.


    As I enter »lspci -v« there is an audio controller found well. Due to the text length restrictions here I can't submit the entire output of »lspci -v«. If I search for "audio" in Konsole this is the section found:
    Code:
    
    00:1f.3 Audio device: Intel Corporation Cannon Point-LP High Definition Audio Controller (rev 11) (prog-i
    f 80) 
            Subsystem: Lenovo Device 2292 
            Flags: bus master, fast devsel, latency 64, IRQ 16, IOMMU group 13 
            Memory at ea33c000 (64-bit, non-prefetchable) [size=16K] 
            Memory at ea000000 (64-bit, non-prefetchable) [size=1M] 
            Capabilities: [50] Power Management version 3 
            Capabilities: [80] Vendor Specific Information: Len=14 <?> 
            Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+ 
            Kernel driver in use: sof-audio-pci-intel-cnl 
            Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci_intel_cnl 
    
    
    
    
    
    But why doesn't it work? What packages am I missing?

  2. #2

    Default Re: No audio device found on Thinkpad

    Sorry, I can't link the screenshots here.
    Last edited by Vitali's_paradox; 21-May-2022 at 02:16. Reason: issues

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: No audio device found on Thinkpad

    Please start by sharing the output from the following commands...
    Code:
    inxi -Aa
    Code:
    sudo dmesg | egrep -i "snd|firmware"


    Is sof-firmware installed?
    Code:
    zypper se sof-firmware


    openSUSE Leap 15.4; KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: No audio device found on Thinkpad

    Quote Originally Posted by Vitali's_paradox View Post
    Sorry, I can't link the screenshots here.
    That can be accomplished using https://paste.opensuse.org/
    openSUSE Leap 15.4; KDE Plasma 5

  5. #5
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    133

    Default Re: No audio device found on Thinkpad

    Quote Originally Posted by deano_ferrari View Post

    Is sof-firmware installed?
    Code:
    zypper se sof-firmware
    I had a similar problem with a "Lenovo ThinkBook 14 G2 ITL (Serial Number MP23GGAX)" using Leap 15.3, installing sof-firmware solved.
    TNX Deano.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: No audio device found on Thinkpad

    Quote Originally Posted by acez View Post
    I had a similar problem with a "Lenovo ThinkBook 14 G2 ITL (Serial Number MP23GGAX)" using Leap 15.3, installing sof-firmware solved.
    TNX Deano.
    Well done!
    openSUSE Leap 15.4; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •