Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: openvpn suppprt for proton vpn - kde

  1. #21

    Default Re: openvpn suppprt for proton vpn - kde

    removed all the repos, but the home:avicenzi project repo

    https://software.opensuse.org//downl...manualopenSUSE



    Code:
    #### YaST2 conflicts list - generated 2022-05-23 01:03:20 ####
    
    nothing provides 'python3-protonvpn-nm-lib >= 3.4.0' needed by the to be installed protonvpn-gui-1.5.1-lp153.6.1.noarch
    
    opesuse 15.3 link - yast install
    
    
    
        [ ] do not install protonvpn-gui-1.5.1-lp153.6.1.noarch
    
        [ ] break protonvpn-gui-1.5.1-lp153.6.1.noarch by ignoring some of its dependencies
    
    
    
    
    #### YaST2 conflicts list END ###
    Nothing in yast. Searching the web for opensuse downloads or github

    trying manual method.

    Code:
    # zypper refresh 
    Repository 'dvd' is up to date.                                                                                                                                           
    Repository 'openSUSE:Backports:SLE-15-SP3' is up to date.                                                                                                                 
    Repository 'home:avicenzi' is up to date.                                                                                                                                 
    Repository 'packman' is up to date.                                                                                                                                       
    Repository 'Update repository of openSUSE Backports' is up to date.                                                                                                       
    Repository 'Non-OSS Repository' is up to date.                                                                                                                            
    Repository 'Main Repository' is up to date.                                                                                                                               
    Repository 'Update repository with updates from SUSE Linux Enterprise 15' is up to date.                                                                                  
    Repository 'Main Update Repository' is up to date.                                                                                                                        
    Repository 'Update Repository (Non-Oss)' is up to date.                                                                                                                   
    All repositories have been refreshed.
    
    #zypper install protonvpn-gui 
    Loading repository data... 
    Warning: Repository 'openSUSE:Backports:SLE-15-SP3' appears to be outdated. Consider using a different mirror or server. 
    Reading installed packages... 
    Resolving package dependencies... 
    
    Problem: nothing provides 'python3-protonvpn-nm-lib >= 3.4.0' needed by the to be installed protonvpn-gui-1.5.1-lp153.6.1.noarch 
     Solution 1: do not install protonvpn-gui-1.5.1-lp153.6.1.noarch 
     Solution 2: break protonvpn-gui-1.5.1-lp153.6.1.noarch by ignoring some of its dependencies 
    
    Choose from above solutions by number or cancel [1/2/c/d/?] (c): c
    

  2. #22

    Default Re: openvpn suppprt for proton vpn - kde

    Can opensuse 15.4 support protonvpn? Not a third party add on, but official support.

  3. #23
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,990
    Blog Entries
    1

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by lord_valarian View Post
    Can opensuse 15.4 support protonvpn? Not a third party add on, but official support.
    Yes, just as the current Leap version supports OpenVPN connectivity via NetworkManager. Read posts #13 and #17 again.
    Last edited by deano_ferrari; 27-May-2022 at 21:03.
    openSUSE Leap 15.3; KDE Plasma 5

  4. #24

    Default Re: openvpn suppprt for proton vpn - kde

    Yes, I finally got the openvpn connection to work. I did a 'dns leak test' on the web. It showed my location as out of state.


    'protonvpn c -f' finds the fastest server and connects to it.

    Since protonvpn won't support opensuse 15.3 GUI, A GUI that supports this functionality. So far none presented are fully supported. The last one is missing a library to use it. That library requires another linux distro.


    I'm asking for opensuse 15.4 (or 15.3) to support this functionality. ?

    It would take me long time to understand and make it in bash. I'm already into other projects.

  5. #25
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,990
    Blog Entries
    1

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by lord_valarian View Post
    Since protonvpn won't support opensuse 15.3 GUI, A GUI that supports this functionality. So far none presented are fully supported. The last one is missing a library to use it. That library requires another linux distro.


    I'm asking for opensuse 15.4 (or 15.3) to support this functionality. ?
    I have no idea about any third party GUI, but have you tried using NetworkManager for managing the OpenVPN connectivity?
    openSUSE Leap 15.3; KDE Plasma 5

  6. #26

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by deano_ferrari View Post
    I have no idea about any third party GUI, but have you tried using NetworkManager for managing the OpenVPN connectivity?
    If you look back over the messages, there several links to third party GUI's. They all don't work for various reasons.

    It works, but only one connection at a time. You have look at protonmail vpn list. Then, pick the lowest load server. Then add it to the connection list. --- The old cli 'protonvpn c -f' does this for you. --- So if your connection gets too high a load, you need go back on protonvpn list and find another server. Then, set it up again. Repeating this process again and again with every new server you add.

    An officially support gui for opensuse...

  7. #27
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,990
    Blog Entries
    1

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by lord_valarian View Post
    If you look back over the messages, there several links to third party GUI's. They all don't work for various reasons.
    I get that...you need to direct your request to ProtonVPN regarding support.

    It works, but only one connection at a time.
    Ok, then be pragmatic and use the CLI.
    openSUSE Leap 15.3; KDE Plasma 5

  8. #28
    Join Date
    Sep 2012
    Posts
    7,690

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by lord_valarian View Post
    An officially support gui for opensuse...
    I am not sure what "official" means here. Supported by vendor? Contact ProtonVPN, request them to provide and maintain package for openSUSE. Support by "openSUSE"? Nobody stops you from packaging this application for openSUSE. You do not need to start from scratch, start with existing projects and fix whatever problems are there.

  9. #29

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by deano_ferrari View Post
    I get that...you need to direct your request to ProtonVPN regarding support.


    Ok, then be pragmatic and use the CLI.
    The CLI 'protonvpn --help' is no longer supported.

    I've send many messages to protonvpn. They will not be supporting opensuse now or in the future.

  10. #30

    Default Re: openvpn suppprt for proton vpn - kde

    Quote Originally Posted by arvidjaar View Post
    I am not sure what "official" means here. Supported by vendor? Contact ProtonVPN, request them to provide and maintain package for openSUSE. Support by "openSUSE"? Nobody stops you from packaging this application for openSUSE. You do not need to start from scratch, start with existing projects and fix whatever problems are there.
    Repeating, protonvpn will not be supporting opensuse now or in the future.

    Linux bash i'm a master at code, however, that will take a very long time and i'm already full with other projects.

    Networking i'm only novice skill. I still can't get my wifi router to work, weeks later I figure out it's might be broke.

    I still can't compile clamav from the C source code. I had to give up on 'scanvirus' C code version. Modifying a C code source that includes networking is far outside my skill set.

    'Officially' means someone else in the community doing the work. I'm making a request for someone else to take up the challenge.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •