openSUSE Security Update: Security update for python-numpy______________________________________________________________________________Announcement ID: openSUSE-SU-2022:0134-1Rating: importantReferences: #1190345 #1193907 #1193913 Cross-References: CVE-2021-21897 CVE-2021-33430 CVE-2021-41496 CVSS scores: CVE-2021-21897 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2021-21897 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVE-2021-33430 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2021-33430 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVE-2021-41496 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVE-2021-41496 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HAffected Products: openSUSE Backports SLE-15-SP3 openSUSE Leap 15.3______________________________________________________________________________ An update that fixes three vulnerabilities is now available.Description: This update for python-numpy fixes the following issues: - CVE-2021-33430: Fixed buffer overflow that could lead to DoS in PyArray_NewFromDescr_int function of ctors.c (bsc#1193913). - CVE-2021-41496: Fixed buffer overflow that could lead to DoS in array_from_pyobj function of fortranobject.c (bsc#1193907).Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-134=1 - openSUSE Backports SLE-15-SP3: zypper in -t patch openSUSE-2022-134=1Package List: - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): python-numpy-debugsource-1.17.3-10.1 python-numpy_1_17_3-gnu-hpc-debugsource-1.17.3-10.1 python3-numpy-1.17.3-10.1 python3-numpy-debuginfo-1.17.3-10.1 python3-numpy-devel-1.17.3-10.1 python3-numpy-gnu-hpc-1.17.3-10.1 python3-numpy-gnu-hpc-devel-1.17.3-10.1 python3-numpy_1_17_3-gnu-hpc-1.17.3-10.1 python3-numpy_1_17_3-gnu-hpc-debuginfo-1.17.3-10.1 python3-numpy_1_17_3-gnu-hpc-devel-1.17.3-10.1 - openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64): dxflib-devel-3.17.0-bp153.2.3.1 libdxflib-3_17_0-1-3.17.0-bp153.2.3.1References: https://www.suse.com/security/cve/CVE-2021-21897.html https://www.suse.com/security/cve/CVE-2021-33430.html https://www.suse.com/security/cve/CVE-2021-41496.html https://bugzilla.suse.com/1190345 https://bugzilla.suse.com/1193907 https://bugzilla.suse.com/1193913

More...