It's always been my experience (so far) that one needs to do:
Code:
systemctl start service
before doing:
Code:
systemctl enable service
I concluded over the years that if there isn't a service file (which "start" initiates), it won't/can't be enabled.
But that's just my two-cents worth.

As well, maybe becoming root
Code:
su -
instead of using
Code:
sudo
might help (I'm not fully sure about that, though). Worth a try (it's free).