Results 1 to 4 of 4

Thread: Latest strongswan-ipsec crashes on startup

  1. #1

    Default Latest strongswan-ipsec crashes on startup

    Yesterday I updated my tumbleweed to the latest build. Since then, my strongswan has been crashing immediately after each restart attempt.

    This is in the logs, apparently after the certificates have been loaded. Until the upgrade my IPSEC connections had been working smoothly.

    ```
    ay 15 14:47:13 soot charon-systemd[8660]: thread 8 received 11
    May 15 14:47:13 soot charon-systemd[8660]: dumping 20 stack frame addresses:
    May 15 14:47:13 soot charon-systemd[8660]: /lib64/libc.so.6 @ 0x7f4b30b49000 [0x7f4b30b9f7c0]
    May 15 14:47:13 soot charon-systemd[8660]: -> ??
    May 15 14:47:13 soot charon-systemd[8660]: /usr/lib64/ipsec/plugins/libstrongswan-vici.so @ 0x7f4>
    May 15 14:47:13 soot charon-systemd[8683]: addr2line: DWARF error: unable to read alt ref 12804
    May 15 14:47:13 soot charon-systemd[8683]: addr2line: DWARF error: unable to read alt ref 11037
    May 15 14:47:13 soot charon-systemd[8683]: addr2line: DWARF error: unable to read alt ref 57413
    May 15 14:47:13 soot charon-systemd[8660]: ->
    May 15 14:47:13 soot charon-systemd[8660]: /usr/lib64/ipsec/plugins/libstrongswan-vici.so @ 0x7f4>
    May 15 14:47:13 soot charon-systemd[8684]: addr2line: DWARF error: unable to read alt ref 12804
    May 15 14:47:13 soot charon-systemd[8684]: addr2line: DWARF error: unable to read alt ref 11037
    May 15 14:47:13 soot charon-systemd[8684]: addr2line: DWARF error: unable to read alt ref 57413
    May 15 14:47:13 soot charon-systemd[8660]: ->
    ...
    ```

    (The addr2line errors only appeared after I installed the debuginfo packages. Not sure why that happens.)

    Any ideas how to debug this? Maybe something wrong with the certificates?

  2. #2

    Default Re: Latest strongswan-ipsec crashes on startup

    I've narrowed it down to these two lines in the child settings:
    ```
    ipcomp = yes

    hostaccess = yes
    ```

    If I comment out both it works, leaving either one active makes it crash. I suspect it's an upstream problem, will report there.

  3. #3

    Default Re: Latest strongswan-ipsec crashes on startup


  4. #4

    Default Re: Latest strongswan-ipsec crashes on startup

    Package with preliminary fix is here: https://build.opensuse.org/package/s...hes/strongswan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •