Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Can systemctl start elasticsearch but not systemctl enable it

  1. #1

    Unhappy Can systemctl start elasticsearch but not systemctl enable it

    I guess this belongs here since i'm trying to get elasticsearch to start at boot. I get the following error when trying to enable elasticsearch. It starts without issue.

    Code:
    # systemctl enable elasticsearch.service 
    Synchronizing state of elasticsearch.service with SysV service script with /usr/lib/systemd/systemd-sysv-install.
    Executing: /usr/lib/systemd/systemd-sysv-install enable elasticsearch
    ln -sf ../elasticsearch /etc/init.d/rc2.d/S50elasticsearch
    ln: failed to create symbolic link '/etc/init.d/rc2.d/S50elasticsearch': No such file or directory
    It's the latest stable version. I had installed version 8.2 at first, but it was incompatible with nextcloud, so I had to purge that install and start over. I don't know if the problem is related.

    Code:
    Name : elasticsearchEpoch : 0
    Version : 7.17.3
    Can anyone help with this?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    It seems that this product is not from the standard openSUSE OSS repo.

    It tries to use /etc/init.d/rc2.d which directory belongs to the old SystemV ways of doing (as the message also says). but in openSUSE that directory is no longer in use and most probably not available anymore.

    In other words, your product is not up-to-date with the systemd way of working as used in openSUSE.
    Maybe when you create that directory (as root of course), it might do something, but that then will of course be no guarantee for working in the future. It is then more a sort of by-pass.
    Henk van Velden

  3. #3

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by hcvv View Post
    It seems that this product is not from the standard openSUSE OSS repo.

    It tries to use /etc/init.d/rc2.d which directory belongs to the old SystemV ways of doing (as the message also says). but in openSUSE that directory is no longer in use and most probably not available anymore.
    This is what I suspected. Is there a good workaround? A startup script for the service or maybe a separate systemd service that just says "systemctl start elasticsearch"?

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,000

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by sunscape View Post
    This is what I suspected. Is there a good workaround? A startup script for the service or maybe a separate systemd service that just says "systemctl start elasticsearch"?
    They have a nice installation page: https://www.netbraintech.com/docs/ie...h-on-linux.htm Do these instructions work?
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

  5. #5

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by karlmistelberger View Post
    They have a nice installation page: https://www.netbraintech.com/docs/ie...h-on-linux.htm Do these instructions work?
    So, this happened. There is an executable "elastic search" in /etc/init.d/

    I renamed it, ran "systemctl enable elastic search" , and then I restored the name and reboot. The service started and is running without issue.
    ???

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by sunscape View Post
    There is an executable "elastic search" in /etc/init.d/
    Most people do not like this sort of conclusions without the real computer facts shown. In this case we would like to have seen
    Code:
    ls -l /etc/init.d
    (or similar) with the full output. The more because the file name you use seems to contain a blank space, which is not a problem in itself, but often people have problems in handling this correct.
    Last edited by hcvv; 11-May-2022 at 03:18.
    Henk van Velden

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,000

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by sunscape View Post
    So, this happened. There is an executable "elastic search" in /etc/init.d/ I renamed it, ran "systemctl enable elastic search" , and then I restored the name and reboot. The service started and is running without issue.
    Thanks for the feedback. Users always may want to try first what the maintainers recommend and see whether it works.
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,944

    Question Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by sunscape View Post
    I guess this belongs here since i'm trying to get elasticsearch to start at boot.
    Yes, but, “Elasticsearch” seems to be a product with a Server Side Public License (SSPL) – <https://en.wikipedia.org/wiki/Elasticsearch> – meaning, it's possibly commercial …

  9. #9

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by hcvv View Post
    Most people do not like this sort of conclusions without the real computer facts shown. In this case we would like to have seen
    Code:
    ls -l /etc/init.d
    (or similar) with the full output. The more because the file name you use seems to contain a blank space, which is not a problem in itself, but often people have problems in handling this correct.
    Code:
    ls -l /etc/init.d/elasticsearch-rwxr-x--- 1 root root 3853 Apr 19 04:14 /etc/init.d/elasticsearch
    The space is just from my auto type keyboard on my phone.

  10. #10

    Default Re: Can systemctl start elasticsearch but not systemctl enable it

    Quote Originally Posted by dcurtisfra View Post
    Yes, but, “Elasticsearch” seems to be a product with a Server Side Public License (SSPL) – <https://en.wikipedia.org/wiki/Elasticsearch> – meaning, it's possibly commercial …
    I'll check out opensearch. If it can work as a drop in replacement with nextcloud then it sounds great.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •