Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

  1. #11

    Default Re: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

    https://www.kernel.org/doc/html/late...n/nct6683.html

    The driver has only been tested with the Intel firmware, and by default only instantiates on Intel boards. To enable it on non-Intel boards, set the ‘force’ module parameter to 1.
    https://www.phoronix.com/scan.php?pa...k-Some-Sensors
    https://www.phoronix.com/scan.php?pa...-Sensors-Linux
    https://github.com/torvalds/linux/bl...wmon/nct6683.c

    There is no support for your hardware with Leap 15.3's standard kernel.
    May work with Leap 15.4 or Leap 15.3 with a new kernel.

  2. #12

    Default Re: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If you run `sensors-detect --auto` does it show a NC type sensor? If you add the following to grub kernel options `acpi_enforce_resources=lax` does that make a difference?
    It does not make a difference. I got a list when I ran:

    Code:
    find /lib/modules -name nct* 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct6775.ko.xz 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct6683.ko.xz 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct7802.ko.xz 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct7904.ko.xz
    
    I tried to run modprobe on each of the entries, but the output of sensors is just a few lines, no CPU temp.

    Dag R

  3. #13

    Default Re: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

    Quote Originally Posted by Svyatko View Post
    That's what I was afraid of, but I have read about some users who manged to work it out, but they may have other kernels or the motherboard is not exactly like the one I have.

    Dag

  4. #14
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,834

    Default Re: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

    Quote Originally Posted by dagring View Post
    It does not make a difference. I got a list when I ran:

    Code:
    find /lib/modules -name nct* 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct6775.ko.xz 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct6683.ko.xz 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct7802.ko.xz 
    /lib/modules/5.3.18-150300.59.63-default/kernel/drivers/hwmon/nct7904.ko.xz
    
    I tried to run modprobe on each of the entries, but the output of sensors is just a few lines, no CPU temp.
    It definitely works with Tumbleweed:
    Code:
    erlangen:~ # inxi -as      
    Sensors:   Message: No sensor data found. Is lm-sensors configured? 
    erlangen:~ # modprobe nct6683                              
    erlangen:~ # inxi -as         
    Sensors:   System Temperatures:cpu: N/A mobo: N/A gpu: amdgpu temp: 54.0 C 
               Fan Speeds (RPM):cpu: 1143 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 fan-7: 0 fan-8: 0 fan-9: 0 fan-10: 0 
               gpu: amdgpu fan: 970 
    erlangen:~ #
    Did you rerun sensors-detect --auto?
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

  5. #15

    Default Re: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

    Quote Originally Posted by karlmistelberger View Post
    It definitely works with Tumbleweed:
    Code:
    erlangen:~ # inxi -as      
    Sensors:   Message: No sensor data found. Is lm-sensors configured? 
    erlangen:~ # modprobe nct6683                              
    erlangen:~ # inxi -as         
    Sensors:   System Temperatures:cpu: N/A mobo: N/A gpu: amdgpu temp: 54.0 C 
               Fan Speeds (RPM):cpu: 1143 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 fan-7: 0 fan-8: 0 fan-9: 0 fan-10: 0 
               gpu: amdgpu fan: 970 
    erlangen:~ #
    Did you rerun sensors-detect --auto?
    Not for Leap 15.3 with standard kernel: https://forums.opensuse.org/showthre...01#post3127001

  6. #16

    Default Re: lm sensors Asus motherboard ROG STRIX B450-F GAMING II

    Quote Originally Posted by karlmistelberger View Post
    It definitely works with Tumbleweed:
    Code:
    erlangen:~ # inxi -as      
    Sensors:   Message: No sensor data found. Is lm-sensors configured? 
    erlangen:~ # modprobe nct6683                              
    erlangen:~ # inxi -as         
    Sensors:   System Temperatures:cpu: N/A mobo: N/A gpu: amdgpu temp: 54.0 C 
               Fan Speeds (RPM):cpu: 1143 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 fan-7: 0 fan-8: 0 fan-9: 0 fan-10: 0 
               gpu: amdgpu fan: 970 
    erlangen:~ #
    Did you rerun sensors-detect --auto?
    You have kernel 5.17 see this article https://www.phoronix.com/scan.php?pa...mp-New-AMD-Zen

    Dag R

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •