Results 1 to 5 of 5

Thread: Foutmelding "Signature verification for Repository openSUSE_Leap_15.3_1 failed".

  1. #1

    Default Foutmelding "Signature verification for Repository openSUSE_Leap_15.3_1 failed".

    Hallo,


    Sinds een tijdje krijg ik de volgende KDE Plasma melding in beeld.

    Software Updates
    Fout tijdens bijwerken
    Signature verification for Repository openSUSE_Leap_15.3_1 failed

    Ik gebruik OpenSUSE Leap 15.3 met KDE Plasma.



    Op 25 april kreeg ik na de commando's "su" en "zypper ref" de volgende melding,

    Code:
    Ophalen van metagegevens uit opslagruimte 'Update repository with updates from SUSE Linux Enterprise 15' ................................................................................................................................................................[fout]
    Opslagruimte Update repository with updates from SUSE Linux Enterprise 15 is ongeldig.
    [repo-sle-update|http://download.opensuse.org/update/leap/15.3/sle/] Geen geldige metagegevens op de gespecificeerde URL gevonden
    Geschiedenis:
     - Bestand './repodata/LangeCodeVerwijderd-updateinfo.xml.gz' niet gevonden op medium 'http://download.opensuse.org/update/leap/15.3/sle/'
     - Can't provide ./repodata/LangeCodeVerwijderd-updateinfo.xml.gz
    
    Controleer of de gedefinieerde URI's voor deze opslagruimte verwijzen naar een geldige opslagruimte.
    Slaat opslagruimte 'Update repository with updates from SUSE Linux Enterprise 15' over vanwege bovengenoemde fout.
    Op de plaats van de tekst "LangeCodeVerwijderd" stond (hoe kan het ook anders) een lange code.
    Omdat ik niet zeker weet of deze code "privacy gevoelig" is, heb ik 'm voor de zekerheid toch maar vervangen door "LangeCodeVerwijderd".

    Toen ik op 4 mei weer de commando's "su" en "zypper ref" gaf kreeg ik de volgende meldingen.

    Code:
    Ophalen van metagegevens uit opslagruimte 'Update repository with updates from SUSE Linux Enterprise 15' ..............................................................................................................................................................[gereed]
    Cache van opslagruimte 'Update repository with updates from SUSE Linux Enterprise 15' wordt gebouwd ...................................................................................................................................................................[gereed]
    Alle opslagruimtes zijn vernieuwd.
    De foutmelding van 25 april was verdwenen, maar ik krijg nog wel de Plasma foutmelding.

    Als ik naar "Yast / Geconfigureerde opslagruimtes / GPG Sleutels" ga dan komen de volgende 4 GPG sleutels van OpenSUSE in beeld.


    Naam: SuSE Package Signing Key <build@suse.de>
    Vingerafdruk: [Vingerafdruk verwijderd]
    Aangemaakt: 21-09-20
    Verlopen: 20-09-24


    Naam: openSUSE:Backports OBS Project <openSUSE:Backports@build.opensuse.org>
    Vingerafdruk: [Vingerafdruk verwijderd]
    Aangemaakt: 26-11-21
    Verlopen: 04-02-24


    Naam: openSUSE Project Signing Key <opensuse@opensuse.org>
    Vingerafdruk: [Vingerafdruk verwijderd]
    Aangemaakt: 05-05-14
    Verlopen: 02-05-24


    Naam: SuSE Package Signing Key <build@suse.de>
    Vingerafdruk: [Vingerafdruk verwijderd]
    Aangemaakt: 15-03-18
    Verlopen: 14-03-22 (De sleutel is verlopen.)

    Ik heb het vermoeden dat de laatste repo de problemen veroorzaakt.

    Ik krijg bij deze repo de volgende knoppen, "Toevoegen", "Bewerken" en "Verwijderen".
    De knop "Bewerken" is "grijs" en kan niet aangeklikt worden.
    De overige 2 knoppen zijn wel aan te klikken maar ik heb dat (nog) niet gedaan.

    Kan ik het probleem met de knoppen "Toevoegen" of "Verwijderen" oplossen ?
    Of is er een andere oplossing ?

    De URL van "Update repository with updates from SUSE Linux Enterprise 15" (http://download.opensuse.org/update/leap/15.3/sle/) is
    wel in een webbrowser te bereiken, dus de server is niet offline.

    Wie helpt mij dit probleem op te lossen ?


    Met vriendelijke groet,

    Flash2020

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,680

    Default Re: Foutmelding "Signature verification for Repository openSUSE_Leap_15.3_1 failed".

    Als je met YaST/zypper geen problemen hebt heb je volgenms mij geen problemen.

    Op 25 april was waarschinjlijk gedurende het bijwerken van de repository (of de mirror die je gebruikt). Dat geeft dan even een instabiele situatie. Is meestal na een half uurtje weer over.

    Verdere opmerkingen.
    Gebruik altijd
    Code:
    su -
    en nooit kale su.

    Dat gerommel van
    Sinds een tijdje krijg ik de volgende KDE Plasma melding in beeld.

    Software Updates
    Fout tijdens bijwerken
    komt waarschijnlijk van de update applet. Velen van ons hebben die verwijderd en hebben zelfs heel PackageKit verwijderd.

    Je gebruikt kennelijk al zypper voor het bijwerken, dus je hebt PackageKit niet nodig.

    En nog iets. Als je hier computer text toont vanwege de output, doe dat dan compleet, dus inclusief de regel met de prompt en het commando en liefst tot en met de nieuwe prompt. Wij zien dan wat je doet, wie je was, waar je was, wat je kreeg en dat het volledig is.

    Voorbeeld. Niet
    Code:
    5.3.18-150300.59.63-default
    maar
    Code:
    henk@boven:~> uname -r
    5.3.18-150300.59.63-default
    henk@boven:~>
    Henk van Velden

  3. #3

    Default Re: Foutmelding "Signature verification for Repository openSUSE_Leap_15.3_1 failed".

    Hallo,


    Bedankt voor de hulp.

    Het updaten met "su -" en "zypper ref && sudo zypper up" ging zonder problemen.
    Na het opnieuw opstarten van de PC kwam (uiteraard) wel de KDE Plasma foutmelding weer in beeld.

    Is het mogelijk om de PackageKit update applet te repareren ?
    De meldingen als er nieuwe updates zijn, vind ik namelijk wel handig.

    Verwijderen kan altijd nog.
    Ik neem aan dat dan de programma's die in beeld verschijnen als er op PackageKit wordt gezocht verwijderd moeten worden ?
    (PackageKit / PackageKit-backend-zypp / PackageKit-branding-openSUSE / PackageKit-gstreamer-plugin / PackageKit-gtk3-module /PackageKit-lang / discover-backend-packagekit / libpackagekit-glib2-18 / libpackagekitqt5-1)

    Groet,
    Flash2020

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,680

    Default Re: Foutmelding "Signature verification for Repository openSUSE_Leap_15.3_1 failed".

    Als je die applet wilt blijven gebruiken moet je PackageKit ook behouden.

    Ik heb geen idee hoe je PackageKit kunt repareren. Zoals je hebt begerepen heb ik het niet (laat het niet installeren bij systeeminstallatie, nooit meer last van).

    Ik neem aan dat als je het pakket Packagekit verwijdert, de meeste van die andere ook wel gesuggereerd zullen worden. Anders kun je eerst PackageKit verwijderen en dan die anderen, misschien komen er protesten. Maar als je PackageKit niet meer hebt doet de rest ook niets meer.

    Ik weet niet meer welk pakket bij KDE het applet bevat (om dat ook te verwijderen). Je kut het volgens mij ook uitzetten (rechts klik of het icoon?).

    Perssonlijk vindt ik het niet goed dat mijn gebruikers (daar hoor ik zelf ook bij) in hun dagelijks werk worden lastig gevallen over updates. Daar hebben ze niets mee te maken.
    In mijn rol als systeembeheerder start ik eens per week YaST > Software > Online Update om the kijken wat er is. Datzelfde kan natuurlijk ook met zypper patch (of zypperup als je andere repos ook tegelijk wilt controleren). Ik controleer snel even de lijst, maar meestal installeer ik daarna alles wat aangeboden wordt.

    Overigens (niet erg belangrijk), maar als je autrefresh van je repos aan hebt staan (dat is de default), hoef je niet als maar zypper ref te doen. Dat gaat dan "vanzelf". Het kan natuurlik ook geen kwaad.
    Henk van Velden

  5. #5

    Default Re: Foutmelding "Signature verification for Repository openSUSE_Leap_15.3_1 failed".

    Hallo,


    De meldingen kunnen inderdaad uitgezet worden.
    Uiteraard heb ik dat gelijk gedaan.

    Ik ga binnenkort nog wel eens uitzoeken hoe die fouten ontstaan en of er een reparatie mogelijk is.

    Maar gelukkig ben ik nu van die irritatnte meldingen af.
    Bedankt voor de hulp !


    Groet,
    Flash2020

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •