Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Default gateway doesn't work

  1. #1

    Angry Default gateway doesn't work

    Hi mates!
    I've installed Tumbleweed and made network settings thgrough YaST. Set up static ip, DNS and route. And now I can't connect to any source from internet.
    This my ip settings:
    Code:
    # ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether b4:7a:f1:36:54:28 brd ff:ff:ff:ff:ff:ff
        altname enp2s0f0
        inet 192.168.0.2/24 brd 192.168.0.255 scope global noprefixroute eno1
           valid_lft forever preferred_lft forever
        inet6 fe80::ee1f:8deb:c3cb:908d/64 scope link noprefixroute
           valid_lft forever preferred_lft forever
    3: eno2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether b4:7a:f1:36:54:29 brd ff:ff:ff:ff:ff:ff
        altname enp2s0f1
    4: eno3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether b4:7a:f1:36:54:2a brd ff:ff:ff:ff:ff:ff
        altname enp2s0f2
    5: enp1s0f4u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
        link/ether f2:68:6d:32:74:a2 brd ff:ff:ff:ff:ff:ff
        inet 16.1.15.2/30 brd 16.1.15.3 scope global dynamic noprefixroute enp1s0f4u4
           valid_lft 8637695sec preferred_lft 8637695sec
        inet6 fe80::5113:f7bf:ef59:fdf8/64 scope link noprefixroute
           valid_lft forever preferred_lft forever
    6: eno4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether b4:7a:f1:36:54:2b brd ff:ff:ff:ff:ff:ff
        altname enp2s0f3
    /etc/resolv.conf
    Code:
    search local
    nameserver 192.168.0.1
    /etc/sysconfig/network/routes
    Code:
    default 192.168.0.1 - -
    And /etc/sysconfig/network/ifcfg-eno1
    Code:
    IPADDR='192.168.0.2/24'
    BOOTPROTO='static'
    STARTMODE='auto'
    # ip route
    Code:
    # ip route
    16.1.15.0/30 dev enp1s0f4u4 proto kernel scope link src 16.1.15.2 metric 100
    192.168.0.0/24 dev eno1 proto kernel scope link src 192.168.0.2 metric 101
    And test internet connection:
    Code:
    # ping google.com
    ping: connect: Network is unreachable
    What am I doing wrong?

  2. #2
    Join Date
    Sep 2012
    Posts
    7,684

    Default Re: Default gateway doesn't work

    Quote Originally Posted by Del.Mar View Post
    What am I doing wrong?
    You did not define default route.

  3. #3

    Default Re: Default gateway doesn't work

    Quote Originally Posted by arvidjaar View Post
    You did not define default route.
    Where?
    Code:
    # cat /etc/sysconfig/network/routes
    default 192.168.0.1 - -
    Default route already setup

  4. #4
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,114
    Blog Entries
    15

    Default Re: Default gateway doesn't work

    Quote Originally Posted by Del.Mar View Post
    Where?
    Code:
    # cat /etc/sysconfig/network/routes
    default 192.168.0.1 - -
    Default route already setup
    Hi
    Define the route interface, eg eno1
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Default gateway doesn't work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Define the route interface, eg eno1
    You mean like this?
    Code:
    default 192.168.0.1 - eno1

  6. #6
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,114
    Blog Entries
    15

    Default Re: Default gateway doesn't work

    Quote Originally Posted by Del.Mar View Post
    You mean like this?
    Code:
    default 192.168.0.1 - eno1
    Hi
    Yes, then should see it in the output of `ip route` as well as a file ifroute-eno1.
    Last edited by malcolmlewis; 03-May-2022 at 13:49.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Sep 2012
    Posts
    7,684

    Default Re: Default gateway doesn't work

    Quote Originally Posted by Del.Mar View Post
    Default route already setup
    Right, I missed it, sorry. You have the second interface, how is it configured? I guess by DHCP? Does DHCP server for this interface provide default gateway? What happens if you uncheck "change default route via DHCP" in global options? Show ifcfg file for this interface too.

    Quote Originally Posted by malcolmlewis View Post
    Define the route interface, eg eno1
    That's not necessary, interface is auto-detected.

  8. #8

    Default Re: Default gateway doesn't work

    Quote Originally Posted by arvidjaar View Post
    Right, I missed it, sorry. You have the second interface, how is it configured? I guess by DHCP? Does DHCP server for this interface provide default gateway? What happens if you uncheck "change default route via DHCP" in global options? Show ifcfg file for this interface too.
    That's not necessary, interface is auto-detected.
    Only one interface connected to LAN cable - it's eno1.
    I have eno1 config file only
    Code:
    # ls -l /etc/sysconfig/network
    total 56
    -rw-r--r-- 1 root root  8137 May  3 19:28 config
    -rw-r--r-- 1 root root  8984 May  3 19:28 dhcp
    -rw-r--r-- 1 root root    60 May  3 19:59 ifcfg-eno1
    -rw------- 1 root root   147 May  3 19:28 ifcfg-lo
    -rw-r--r-- 1 root root 21738 Feb 20 06:34 ifcfg.template
    drwxr-xr-x 1 root root     0 Mar  9 22:00 if-down.d
    drwxr-xr-x 1 root root     0 Mar  9 22:00 if-up.d
    drwx------ 1 root root     0 Mar  9 22:00 providers
    -rw-r--r-- 1 root root    25 May  3 20:40 routes
    drwxr-xr-x 1 root root    76 May  3 19:26 scripts
    Quote Originally Posted by malcolmlewis View Post
    Hi
    Yes, then should see it in the output of `ip route` as well as a file ifroute-eno1.
    No effect. After reboot no default route
    Code:
    # ip route
    16.1.15.0/30 dev enp1s0f4u4 proto kernel scope link src 16.1.15.2 metric 100
    192.168.0.0/24 dev eno1 proto kernel scope link src 192.168.0.2 metric 101

  9. #9
    Join Date
    Sep 2012
    Posts
    7,684

    Default Re: Default gateway doesn't work

    Quote Originally Posted by Del.Mar View Post
    Only one interface connected to LAN cable - it's eno1.
    So what is this?
    Quote Originally Posted by Del.Mar View Post
    Code:
    # ip addr
    5: enp1s0f4u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
        link/ether f2:68:6d:32:74:a2 brd ff:ff:ff:ff:ff:ff
        inet 16.1.15.2/30 brd 16.1.15.3 scope global dynamic noprefixroute enp1s0f4u4
           valid_lft 8637695sec preferred_lft 8637695sec
        inet6 fe80::5113:f7bf:ef59:fdf8/64 scope link noprefixroute
           valid_lft forever preferred_lft forever
    Where the address comes from?

    Judging by "noprefixroute" it may be NetworkManager ...

  10. #10

    Default Re: Default gateway doesn't work

    Quote Originally Posted by arvidjaar View Post
    So what is this?

    Where the address comes from?

    Judging by "noprefixroute" it may be NetworkManager ...
    It's iLO virtual NIC. I have HP microserver Gen 10. So, I don't sure that this device can accure the problem with default gateway.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •