Results 1 to 5 of 5

Thread: Conflict for libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64

  1. #1

    Arrow Conflict for libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64

    Greetings:

    Some recent updates to TW (I believe with the big update to LLVM/Clang 14) made it slightly more difficult to update some packages (see message below). A cursory look within Yast seems to indicate that libclang13's new version is becoming 14.0.0-1.2 (which seems like it should be incorrect... I would expect libclang13 to be tied to 13.*). Have others on this forum encountered this and, if so, what it the appropriate way to deal with this? Thank you for your help with this.

    Code:
    Problem: the installed libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64 requires 'libclang13 = 13.0.1', but this requirement cannot be provided
      deleted providers: libclang13-13.0.1-3.3.x86_64
    not installable providers: llvm13-libclang13-13.0.1-4.1.i586[repo-oss]
                       llvm13-libclang13-13.0.1-4.1.x86_64[repo-oss]
     Solution 1: deinstallation of libclang13-13.0.1-3.3.x86_64
     Solution 2: deinstallation of libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64
     Solution 3: keep obsolete libclang13-13.0.1-3.3.x86_64
     Solution 4: break libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64 by ignoring some of its dependencies

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,015
    Blog Entries
    3

    Default Re: Conflict for libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64

    If it were me, then I would go with solution 3. And then see if it clears up after the next few updates.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  3. #3
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,242
    Blog Entries
    15

    Default Re: Conflict for libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64

    Quote Originally Posted by iqgrande View Post
    Greetings:

    Some recent updates to TW (I believe with the big update to LLVM/Clang 14) made it slightly more difficult to update some packages (see message below). A cursory look within Yast seems to indicate that libclang13's new version is becoming 14.0.0-1.2 (which seems like it should be incorrect... I would expect libclang13 to be tied to 13.*). Have others on this forum encountered this and, if so, what it the appropriate way to deal with this? Thank you for your help with this.

    Code:
    Problem: the installed libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64 requires 'libclang13 = 13.0.1', but this requirement cannot be provided
      deleted providers: libclang13-13.0.1-3.3.x86_64
    not installable providers: llvm13-libclang13-13.0.1-4.1.i586[repo-oss]
                       llvm13-libclang13-13.0.1-4.1.x86_64[repo-oss]
     Solution 1: deinstallation of libclang13-13.0.1-3.3.x86_64
     Solution 2: deinstallation of libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64
     Solution 3: keep obsolete libclang13-13.0.1-3.3.x86_64
     Solution 4: break libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64 by ignoring some of its dependencies
    Hi
    As a Tumbleweed user it's always a good option to browse the Factory Mailing List, this is a known issue....
    https://lists.opensuse.org/archives/....opensuse.org/
    https://lists.opensuse.org/archives/...WZL6F2R4LIDDN/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Conflict for libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64

    Quote Originally Posted by malcolmlewis View Post
    Hi
    As a Tumbleweed user it's always a good option to browse the Factory Mailing List, this is a known issue....
    https://lists.opensuse.org/archives/....opensuse.org/
    https://lists.opensuse.org/archives/...WZL6F2R4LIDDN/
    Greetings,

    This is wonderful advice. I did not know about the Factory Mailing List and have added it to the things I check. When issues arise, I typically look at forums.opensuse.org, bugzilla.opensuse.org, and now the Factory Mailing List. Are there other good openSUSE resources I should add to that list? Thank you for your help with this.

    Kind regards,
    Anthony

  5. #5
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,242
    Blog Entries
    15

    Default Re: Conflict for libqt5-qttools-doc-5.15.2+kde17-1.12.x86_64

    Quote Originally Posted by iqgrande View Post
    Greetings,

    This is wonderful advice. I did not know about the Factory Mailing List and have added it to the things I check. When issues arise, I typically look at forums.opensuse.org, bugzilla.opensuse.org, and now the Factory Mailing List. Are there other good openSUSE resources I should add to that list? Thank you for your help with this.

    Kind regards,
    Anthony
    Hi
    Those should cover most issues, however if feel like adding IRC (libera.chat or matrix) you can catch stuff in real time (#opensuse-factory), there is an openSUSE Forums channel as well (#opensuse-forums)...

    openSUSE:Communication channels - openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •