Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: vsftp Response: 530 Login incorrect.

  1. #1

    Default vsftp Response: 530 Login incorrect.

    I have installed and configured vsftpd through YAST. When I try to log in i get the following:

    Code:
    Response:    530 Login incorrect.
    Error:    Critical error: Could not connect to server
    This my vsftpd.conf:

    Code:
    anon_mkdir_write_enable=NO
    anon_root=/srv/ftp
    anon_upload_enable=NO
    anonymous_enable=NO
    chroot_local_user=YES
    ftpd_banner=No matter where you go, there you are. Don't panic.
    idle_session_timeout=900
    local_enable=YES
    log_ftp_protocol=YES
    max_clients=10
    max_per_ip=3
    pasv_enable=YES
    pasv_max_port=40500
    pasv_min_port=40000
    ssl_enable=YES
    ssl_tlsv1=YES
    write_enable=YES
    xferlog_enable=YES
    rsa_cert_file=/etc/ssl/private/vsftpd.pem
    I am behind a cable router with a forward Xfinity ip linked to my domain through DNS Exit.
    The self signed ssl certificate is recognized.
    I get the same error whether trying to connect vie FQDN or internal ip.
    I am not sure what to look at to fix the problem.
    Any and all help appreciated.
    Rick71

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,693

    Default Re: vsftp Response: 530 Login incorrect.

    To see if a program is listening on the FTP port (as root):
    Code:
    lsof -i  | grep ftp
    To check if the service is running (assuming the service name is vsftpd, of which I am not sure):
    Code:
    systemctl status vsftpd
    Henk van Velden

  3. #3

    Default Re: vsftp Response: 530 Login incorrect.

    Quote Originally Posted by hcvv View Post
    To see if a program is listening on the FTP port (as root):
    Code:
    lsof -i  | grep ftp
    To check if the service is running (assuming the service name is vsftpd, of which I am not sure):
    Code:
    systemctl status vsftpd
    Code:
    lsof -i  | grep ftp
    vsftpd    26967   root    3u  IPv4  98827      0t0  TCP *:ftp (LISTEN)
    Code:
    systemctl status vsftpd
    ● vsftpd.service - Vsftpd ftp daemon
         Loaded: loaded (/usr/lib/systemd/system/vsftpd.service; disabled; vendor p>
         Active: active (running) since Wed 2022-04-13 13:19:21 EDT; 2min 35s ago
       Main PID: 26967 (vsftpd)
          Tasks: 1 (limit: 4915)
         CGroup: /system.slice/vsftpd.service
                 └─26967 /usr/sbin/vsftpd /etc/vsftpd.conf
    
    Apr 13 13:19:21 TOWER systemd[1]: Started Vsftpd ftp daemon.
    Rick71

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,693

    Default Re: vsftp Response: 530 Login incorrect.

    That looks fine then.

    It seems that basically a connection is possible. The 530 error meaning that something is wrong with username/password.
    Check and doublecheck.
    Henk van Velden

  5. #5

    Default Re: vsftp Response: 530 Login incorrect.

    Quote Originally Posted by hcvv View Post
    That looks fine then.

    It seems that basically a connection is possible. The 530 error meaning that something is wrong with username/password.
    Check and doublecheck.
    It is my login and password. I use it to login to the system. Do I need to add ftp users like samba users?
    Rick71

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,693

    Default Re: vsftp Response: 530 Login incorrect.

    I have no idea why you mention Samba. And I have nil Samba knowledge (I am an Unix/Linux user and system manager).

    But there is a file /etc/ftpusers that contains usernames of user that may NOT use ftp. That file normally does not contain users you have added as "normal users". So I doubt the user you use is in there, but you can check. I am also not sure if vsftpd uses it (not all ftp servers do).

    And of course, you could try to find some logs. I do not have vsftpd installed, thus I have no man page, but it could tell you where logs are.
    Last edited by hcvv; 14-Apr-2022 at 09:26.
    Henk van Velden

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,693

    Default Re: vsftp Response: 530 Login incorrect.

    Tried a man vsftp on the internet:
    Code:
    vsftpd_log_file
        This option is the name of the file to which we write the vsftpd style log file. This log is only written if the option xferlog_enable is set, and xferlog_std_format is NOT set. Alternatively, it is written if you have set the option dual_log_enable. One further complication - if you have set syslog_enable, then this file is not written and output is sent to the system log instead.
    
        Default: /var/log/vsftpd.log
    Henk van Velden

  8. #8

    Default Re: vsftp Response: 530 Login incorrect.

    Quote Originally Posted by hcvv View Post
    I have no idea why you mention Samba. And I have nil Samba knowledge (I am an Unix/Linux user and system manager).
    I was asking because I know you have to add samba users to samba and I wanted to know if you had to specifically add users to ftp or vdftp.
    Quote Originally Posted by hcvv View Post
    But there is a file /etc/ftpusers that contains usernames of user that may NOT use ftp. That file normally does not contain users you have added as "normal users". So I doubt the user you use is in there, but you can check. I am also not sure if vsftpd uses it (not all ftp servers do).
    my user in not n that file.
    Quote Originally Posted by hcvv View Post
    And of course, you could try to find some logs. I do not have vsftpd installed, thus I have no man page, but it could tell you where logs are.
    From the vdftpd log, the login fails at the password. It is apparently not being recognized.
    Rick71

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,074

    Default AW: vsftp Response: 530 Login incorrect.

    Is your User in the /etc/vsftpd.user_list?

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,693

    Default Re: AW: vsftp Response: 530 Login incorrect.

    Quote Originally Posted by Sauerland View Post
    Is your User in the /etc/vsftpd.user_list?
    In the man page I found
    userlist_enable
    If enabled, vsftpd will load a list of usernames, from the filename given by userlist_file. If a user tries to log in using a name in this file, they will be denied before they are asked for a password. This may be useful in preventing cleartext passwords being transmitted. See also userlist_deny.

    Default: NO
    Seeing his config in post #1, that is not enabled.

    But on openSUSE the default may be different.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •