Results 1 to 2 of 2

Thread: NVIDIA screen resolution

  1. #1

    Exclamation NVIDIA screen resolution

    Hello I have just installed tumbleweed. I am quite new to Linux and have followed everything as on guide while installing the drivers. When I use amd(integrated) gpu my screen resolution looks fine (as it should be) but when I change my bios settings discrete (I am not even sure if they will be switching automatically if I keep my settings on Dynamic!) my screen resolution drops a lot, in settings it says 1920 to 1080 but I think it is 1280 to 720, and I could not find any way to fix this so I am asking for help.
    Thanks in advance.

    Nvidia rtx 3060

  2. #2

    Default Re: NVIDIA screen resolution

    I solved it by following this;
    Can you verify the driver is actually being loaded? Run lsmod | grep nvidia in the terminal, it should produce a similar output to this:
    nvidia_drm 57344 2
    nvidia_modeset 1187840 3 nvidia_drm
    nvidia_uvm 1110016 0
    nvidia 19771392 81 nvidia_uvm,nvidia_modeset
    drm_kms_helper 229376 2 nvidia_drm,i915
    drm 544768 13 drm_kms_helper,nvidia_drm,i915
    If you have secureboot enabled, be sure to accept the MOK on the next restart. The MOK utility should start automatically, just select "Enroll MOK", then "Continue" and "Yes", then reboot. To check if secureboot is the problem, run
    # dmesg | grep nvidia
    If you see modprobe: ERROR: could not insert 'nvidia': Required key not available, try reimporting the MOK certificate or reinstalling the driver, alternatively disable secureboot in the BIOS or, as a last resort, disable verification of kernel modules with # mokutil --disable-validation (not recommended!).

    If you're on a desktop PC, you shouldn't have to switch display outputs in the BIOS settings. It's a hardware switch so to speak, just connect the display cable to your motherboard to use integrated graphics or connect to the graphics card to use discrete graphics. On a laptop, you can specify which graphics output you want to use with the prime-select command provided by the package suse-prime. Use # prime-select nvidia to use discrete graphics.

    then this


    Okay, it seems the driver is installed and loaded properly. Try to set the display output to auto in the BIOS settings and then specify to use the Nvidia graphics with # prime-select nvidia. If you get a "command not found" error, make sure the package suse-prime is installed and you're running prime-selectas root. Reboot to apply the changes, be sure to login to an Xorg session instead of Wayland since prime-select only works on Xorg. You can specify which display server you want to use by clicking the little gear wheel icon on the login screen.
    Once again, this is the laptop way. On a desktop PC you don't need to do any of this, you'd just connect the cable to whichever display output you want to use.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •