Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Upgrade 15.2 to 15.3 will not run except in recovery mode

  1. #1

    Default Upgrade 15.2 to 15.3 will not run except in recovery mode

    After discovering that 15.2 had already hit end-of-life, I followed the procedure and upgraded to 15.3.

    I am encountering a couple of problems. The first I suspect is settings in Thunderbird, but don't have a clue what is going on with this problem:

    When I try to run 15.3 in normal mode (not recovery), it will start but then freeze with this message "A start job is running for /dev/disk/by uuid/ata-WDC-WD2003FZEX-00SRLA0_WD-WCC6N4UH4NTJ-part3 (3min 30s / no limit)".

    I have three partitions on my hard drive, a small one automatically made, a big one (1.1Tb) for OpenSUSE Leap, a somewhat smaller (and as of now, unused partition - blank and unformatted) partition where I planned on putting W10, and a small one for swap.

    When the message in line 3 pops up (watching the boot sequence), it always freezes there, even though the timer keeps incrementing. I CAN reboot with Ctl-Alt-Delete.

    When I start in recovery mode, that message doesn't pop up and as long as I don't start Thunderbird, I can use the computer. (I think I know what I have to do to fix that.)

    I should add that I had some difficulty doing the upgrade. When I used the instructions for pre-downloading the files, I got a pop-up message that switch didn't work. The system had some issues and for a while, I could only get a screen with an older version of 15.3.

    My thinking is that for some reason, 15.3 is looking for software on the blank section of the disk, and without a maximum timeout, just goes into a wait loop.

    Any help to fix this would be greatly appreciated!

    Bob

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,002
    Blog Entries
    1

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Quote Originally Posted by Archaeometrist View Post
    When I try to run 15.3 in normal mode (not recovery), it will start but then freeze with this message "A start job is running for /dev/disk/by uuid/ata-WDC-WD2003FZEX-00SRLA0_WD-WCC6N4UH4NTJ-part3 (3min 30s / no limit)".
    Please provide using code tags input/output from:
    Code:
    lsblk -f
    cat /etc/fstab
    cat /proc/cmdline
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  3. #3

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Quote Originally Posted by mrmazda View Post
    Please provide using code tags input/output from:
    Code:
    lsblk -f
    cat /etc/fstab
    cat /proc/cmdline
    sblk -f

    NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
    sda mpath_
    ├─sda1
    │ none
    ├─sda2
    │ btrfs 89766f9c-fb4e-459d-9b02-1203b26e629b
    ├─sda3
    │ swap 1 a5bd1cc2-3a15-43b1-84c4-14a307e671a5
    ├─sda4
    │ none
    └─WDC_WD2003FZEX-00SRLA0_WD-WCC6N4VH4NTJ

    ├─WDC_WD2003FZEX-00SRLA0_WD-WCC6N4VH4NTJ-part1

    ├─WDC_WD2003FZEX-00SRLA0_WD-WCC6N4VH4NTJ-part2
    │ btrfs 89766f9c-fb4e-459d-9b02-1203b26e629b 450.7G 56% /tmp
    ├─WDC_WD2003FZEX-00SRLA0_WD-WCC6N4VH4NTJ-part3
    │ swap 1 a5bd1cc2-3a15-43b1-84c4-14a307e671a5 [SWAP]
    └─WDC_WD2003FZEX-00SRLA0_WD-WCC6N4VH4NTJ-part4


    bob@localhost:~> cat /etc/fstab

    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b / btrfs defaults 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /var btrfs subvol=/@/var 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /usr/local btrfs subvol=/@/usr/local 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /tmp btrfs subvol=/@/tmp 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /srv btrfs subvol=/@/srv 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /root btrfs subvol=/@/root 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /opt btrfs subvol=/@/opt 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /home btrfs subvol=/@/home 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /boot/grub2/x86_64-efi btrfs subvol=/@/boot/grub2/x86_64-efi 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /boot/grub2/i386-pc btrfs subvol=/@/boot/grub2/i386-pc 0 0
    UUID=89766f9c-fb4e-459d-9b02-1203b26e629b /.snapshots btrfs subvol=/@/.snapshots 0 0
    UUID=a5bd1cc2-3a15-43b1-84c4-14a307e671a5 swap swap defaults 0 0


    bob@localhost:~> cat /proc/cmdline

    BOOT_IMAGE=/boot/vmlinuz-5.3.18-150300.59.60-default root=UUID=89766f9c-fb4e-459d-9b02-1203b26e629b

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,016
    Blog Entries
    3

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    You did not use CODE tags, as requested. That makes your output harder to read.

    It looks as if the holdup is with swap, perhaps with attempting a resume from hiberbating. Recovery mode does not attempt that.

    Please provide the output from:
    Code:
    grep resume /etc/default/grub
    You may need root access to use that command (or put an "sudo" in front of the command).

    You can use CODE tags:


    [CODE]
    paste output here
    [/CODE]
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  5. #5

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="splash=silent resume=/dev/disk/by-id/ata-WDC_WD2003FZEX-00SRLA0_WD-WCC6N4VH4NTJ-part3 mitigations=auto quiet"
    This is the first time I've heard of "Code Tags".

  6. #6
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,002
    Blog Entries
    1

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Try this test: At the Grub menu with default menu selection highlighted, strike the E key, find the string that begins resume=whatever, change it to noresume, then proceed to boot via the instruction at the bottom of the screen. Do you get a normal boot?
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  7. #7

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Well, for the first time 15.3 booted normally. So I guess I need to do the editing to remove that switch?

    Thanks for helping!

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,002
    Blog Entries
    1

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Quote Originally Posted by Archaeometrist View Post
    Well, for the first time 15.3 booted normally. So I guess I need to do the editing to remove that switch?
    Not remove, adjust. It needs to match the entry in /etc/fstab to enable resume, or normally boot. Edit /etc/default/grub, then regenerate grub.cfg. Alternatively, if you don't ever suspend to disk, you could replace the resume=whatever in /etc/default/grub with noresume before regenerating.

    It's unusual to see resume=/dev/disk/by-id/whatever. Usually it's resume=UUID=whatever. It also can be resume=LABEL=whatever, where LABEL refers to filesystem label that you may set to anything you please on any or all filesystems, subject to a length and special characters limitation.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,016
    Blog Entries
    3

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Quote Originally Posted by Archaeometrist View Post
    Well, for the first time 15.3 booted normally.
    Before changing anything, I would suggest you check whether you actually have swap. Perhaps the device specified in "/etc/fstab" and in "/etc/default/grub" is wrong.

    What's the output from:
    Code:
    free
    and what's the output from:
    Code:
    cat /proc/swaps
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  10. #10

    Default Re: Upgrade 15.2 to 15.3 will not run except in recovery mode

    Quote Originally Posted by nrickert View Post
    Before changing anything, I would suggest you check whether you actually have swap. Perhaps the device specified in "/etc/fstab" and in "/etc/default/grub" is wrong.

    What's the output from:
    Code:
    free
    and what's the output from:
    Code:
    cat /proc/swaps
    Code:
    bob@localhost:~> free
                  total        used        free      shared  buff/cache   available
    Mem:       16301760     3304956     5254532      715340     7742272    11945444
    Swap:       2097216           0     2097216
    bob@localhost:~> cat /proc/swaps
    Filename                Type        Size    Used    Priority
    /dev/dm-3                               partition    2097216    0    -2
    Since I made the change, I've had two minor problems - Thunderbird and Firefox locking up. However, that appears to be a loose connection in the ethernet. Otherwise, the upgrade now seems to be complete and OK.

    I really appreciate the help!!!

    Bob

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •