Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Slow Repo

  1. #21
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: Slow Repo

    Quote Originally Posted by mrmazda View Post
    just annoying that it's last and seems to take longer than all others combined.
    When the fact that it is last annoys you extra, then that can be addressed. Just rename the configuration file in /etc/zypp/repos.d/ to another one that starts e.g. with an a. and change the name in the first line accordingly.

    You will have a slightly different name from what I have. I have:

    Code:
    boven:/etc/zypp/repos.d # cat sle-update.repo 
    [sle-update]
    name=Updates from SUSE Linux Enterprise 15
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/update/leap/$releasever/sle/
    path=/
    keeppackages=0
    boven:/etc/zypp/repos.d #
    The blue names are what I am talking about.
    Henk van Velden

  2. #22
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,251
    Blog Entries
    15

    Default Re: Slow Repo

    Quote Originally Posted by hcvv View Post
    When the fact that it is last annoys you extra, then that can be addressed. Just rename the configuration file in /etc/zypp/repos.d/ to another one that starts e.g. with an a. and change the name in the first line accordingly.

    You will have a slightly different name from what I have. I have:

    Code:
    boven:/etc/zypp/repos.d # cat sle-update.repo 
    [sle-update]
    name=Updates from SUSE Linux Enterprise 15
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/update/leap/$releasever/sle/
    path=/
    keeppackages=0
    boven:/etc/zypp/repos.d #
    The blue names are what I am talking about.
    Hi
    Switch to the EU mirrorcache and see if that helps.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #23
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    502

    Default Re: Slow Repo

    Extremely long ref of "SUSE linux Enterprise 1 " repo has started again. Not working in yast software management and also zypper. Worked well for a few days after last hanging period. Found not working on 4/4 0700 gmt-5.

    tom kosvic

  4. #24
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,992
    Blog Entries
    1

    Default Re: Slow Repo

    I just tried. SLE took nearly twice as long as all others combined, but it still took less than a minute to do all 12 enabled 15.3 repos.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  5. #25
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: Slow Repo

    I just did YaST Online Updates on two systems. Again, those repos use more time tio refresh then others, but it still is less then a minute. Yesterday I did another one a few hourse before @tckosvic reported above. Same, as todays experience.

    Difficult to lay hand on this. Is it Geographical?
    Henk van Velden

  6. #26

    Default Re: Slow Repo

    Similar here also now~

    It has been taking 15 min, still retrieving the repository.....

  7. #27
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    502

    Default Re: Slow Repo

    Update SUSE enterprise repo taking > 15 minutes to update. It is still spinning the slash symbol around and around. I will let it continue to try to get a time but it appears hung.

    zypper run at 1011 gmt-5 (us central dst) on 4/6

    who is in charge of this server; openSUSE or big daddy enterprise SUSE? Are they aware of this issue?

    thanks, tom kosvic

  8. #28
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,251
    Blog Entries
    15

    Default Re: Slow Repo

    Quote Originally Posted by tckosvic View Post
    Update SUSE enterprise repo taking > 15 minutes to update. It is still spinning the slash symbol around and around. I will let it continue to try to get a time but it appears hung.

    zypper run at 1011 gmt-5 (us central dst) on 4/6

    who is in charge of this server; openSUSE or big daddy enterprise SUSE? Are they aware of this issue?

    thanks, tom kosvic
    Hi
    It's openSUSE infrastructure, are you using download or mirrorcache-us?

    I just forced a refresh here on openSUSE Leap 15.3 systems using;

    download.opensuse.org

    Code:
    6 active repos
    time zypper -vvv ref -f
    .....
    real    0m40.278s
    user    0m20.202s
    sys    0m1.123s
    mirrorcache-us.opensuse.org

    Code:
    5 active repos
    time zypper -vvv ref -f
    .....
    real    1m28.337s
    user    0m40.381s
    sys    0m2.881s
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #29
    Join Date
    Mar 2014
    Location
    Canary Island Lat. 27.994547-15.405127 Lon-160m sea level
    Posts
    298

    Default Re: Slow Repo

    Hello:

    It was also very slow, until I realized that I had to change http to https, from there it was very fast. From Yast repositories just edit http and add an s. Hope this can help you.

    Best regards

  10. #30
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,000

    Default Re: Slow Repo

    Added repo and did some tests:
    Code:
    erlangen:~ # zypper lr test            
    Alias          : test 
    Name           : test 
    URI            : https://download.opensuse.org/update/leap/15.3/sle/ 
    Enabled        : Yes 
    GPG Check      : ( p) Yes 
    Priority       : 99 (default priority) 
    Autorefresh    : On 
    Keep Packages  : Off 
    Type           : NONE 
    GPG Key URI    :  
    Path Prefix    :  
    Parent Service :  
    Keywords       : --- 
    Repo Info Path : /etc/zypp/repos.d/test.repo 
    MD Cache Path  : /var/cache/zypp/raw/test 
    erlangen:~ #
    Code:
    erlangen:~ # zypper clean --all --repo test 
    Specified repositories have been cleaned up. 
    erlangen:~ # time zypper refresh test            
    Retrieving repository 'test' metadata ..................................................................................................................................................................................................[done] 
    Building repository 'test' cache .......................................................................................................................................................................................................[done] 
    Specified repositories have been refreshed. 
    
    real    0m39.563s 
    user    0m11.328s 
    sys     0m4.520s 
    erlangen:~ # time zypper refresh test 
    Repository 'test' is up to date.                                                                                                                                                                                                               
    Specified repositories have been refreshed. 
    
    real    0m0.623s 
    user    0m0.227s 
    sys     0m0.054s 
    erlangen:~ # time zypper refresh --force test 
    Forcing raw metadata refresh 
    Retrieving repository 'test' metadata ..................................................................................................................................................................................................[done] 
    Forcing building of repository cache 
    Building repository 'test' cache .......................................................................................................................................................................................................[done] 
    Specified repositories have been refreshed. 
    
    real    0m8.069s 
    user    0m7.276s 
    sys     0m0.163s 
    erlangen:~ #
    Showing the location:
    Code:
    erlangen:~ # curl -I  https://download.opensuse.org/update/leap/15.3/sle/x86_64/389-ds-1.4.4.16~git16.c1926dfc6-3.4.1.x86_64.rpm             
    HTTP/2 302  
    location: https://mirrorcache.opensuse.org/update/leap/15.3/sle/x86_64/389-ds-1.4.4.16~git16.c1926dfc6-3.4.1.x86_64.rpm 
    content-type: text/html; charset=iso-8859-1 
    date: Mon, 11 Apr 2022 08:55:29 GMT 
    server: Apache 
    
    erlangen:~ #
    
    Checking the connection:
    Code:
    erlangen:~ # resolvectl query mirrorcache.opensuse.org 
    mirrorcache.opensuse.org: 2001:67c:2178:8::16-- link: eth0
                              195.135.221.140-- link: eth0
                              (proxy-nue.opensuse.org) 
    
    -- Information acquired via protocol DNS in 1.0ms.
    -- Data is authenticated: no; Data was acquired via local or encrypted transport: no
    -- Data from: cache
    erlangen:~ # ping -c 11 proxy-nue.opensuse.org                      
    PING proxy-nue.opensuse.org(proxy-nue.opensuse.org (2001:67c:2178:8::16)) 56 data bytes 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=1 ttl=58 time=15.7 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=2 ttl=58 time=15.6 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=3 ttl=58 time=15.6 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=4 ttl=58 time=16.7 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=5 ttl=58 time=16.3 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=6 ttl=58 time=16.4 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=7 ttl=58 time=16.4 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=8 ttl=58 time=16.4 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=9 ttl=58 time=16.3 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=10 ttl=58 time=16.4 ms 
    64 bytes from proxy-nue.opensuse.org (2001:67c:2178:8::16): icmp_seq=11 ttl=58 time=16.5 ms 
    
    --- proxy-nue.opensuse.org ping statistics --- 
    11 packets transmitted, 11 received, 0% packet loss, time 10016ms 
    rtt min/avg/max/mdev = 15.559/16.198/16.700/0.379 ms 
    erlangen:~ #
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •