Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Slow Repo

  1. #11
    Join Date
    Nov 2020
    Location
    USA
    Posts
    70

    Default Re: Slow Repo

    On Leap 15.3 (work) and the SUSE Repository is timing out when attempting any zypper command.

    Would it be safe to disable this repo temporarily? Is there an upstream discussion about this?


    From UTC 15:11, 2022.03.30
    Code:
    
    Repository 'Update repository with updates from SUSE Linux Enterprise 15' is invalid.
    [repo-sle-update|http://download.opensuse.org/update/leap/15.3/sle/] Valid metadata not found at specified URL                
    History:                                                                                                                      
     - File './repodata/7ff52b872cd8d1d399c36236c2d8f03a4de86fcd291feaf2c96ab8a10a9fa2de-primary.xml.gz' not found on medium 'http
    ://download.opensuse.org/update/leap/15.3/sle/'                                                                               
     - Can't provide ./repodata/7ff52b872cd8d1d399c36236c2d8f03a4de86fcd291feaf2c96ab8a10a9fa2de-primary.xml.gz  
    
    只要努力,就能成功
    With hard work, success is possible.

  2. #12
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,967

    Default Re: Slow Repo

    That is the repo we are talking about here. Apparently there was a problem, but as you can see, people report it is working now.

    When did you try?

    And about disabling it, that depends on what you are going to do. E.g. a proper update will not be a good idea with it disabled. But when you just want install packages from a non-standard repo it might work.

    BTW, your output is NOT complete. Please always copy/paste with the prompt/command line, the complete output and the next prompt line. Now we do not know what you did, and have only part of the output. Not a very good base to give advise.
    Henk van Velden

  3. #13
    Join Date
    Nov 2020
    Location
    USA
    Posts
    70

    Default Re: Slow Repo

    Sorry about the incomplete, it was a simple 'zypper ref'


    Ran just now, at 1641 UTC, I still receive a timeout:

    Code:
    
    sudo zypper ref 
    [sudo] password for root:  
    Repository 'nVidia Graphics Drivers' is up to date.                                                                            
    Repository 'Packman Repository' is up to date.                                                                                 
    Repository 'google-chrome' is up to date.                                                                                      
    Repository 'Mozilla' is up to date.                                                                                            
    Repository 'Update repository of openSUSE Backports' is up to date.                                                            
    Repository 'Non-OSS Repository' is up to date.                                                                                 
    Repository 'Main Repository' is up to date.                                                                                    
    Retrieving repository 'Update repository with updates from SUSE Linux Enterprise 15' metadata .........................[error] 
    Repository 'Update repository with updates from SUSE Linux Enterprise 15' is invalid.
    [repo-sle-update|http://download.opensuse.org/update/leap/15.3/sle/] Valid metadata not found at specified URL                
    History:                                                                                                                      
     - Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/15.3/sle/repodata/0e4ed8ffa89f3dc0c7b3e730b93a557
    8383ce8a0f9eb53bbcb029d310c92d7ce-primary.xml.gz'.                                                                            
     - Can't provide ./repodata/0e4ed8ffa89f3dc0c7b3e730b93a5578383ce8a0f9eb53bbcb029d310c92d7ce-primary.xml.gz                   
    
    Please check if the URIs defined for this repository are pointing to a valid repository. 
    Skipping repository 'Update repository with updates from SUSE Linux Enterprise 15' because of the above error.
    
    只要努力,就能成功
    With hard work, success is possible.

  4. #14
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,967

    Default Re: Slow Repo

    Here:
    Code:
    boven:~ # zypper ref
    Retrieving repository 'Updates from openSUSE Backports' metadata .........................................[done]
    Building repository 'Updates from openSUSE Backports' cache ..............................................[done]
    Repository 'Main (OSS)' is up to date.                                                                          
    Retrieving repository 'Update (OSS)' metadata ............................................................[done]
    Building repository 'Update (OSS)' cache .................................................................[done]
    Repository 'Main (Non-OSS)' is up to date.                                                                      
    Repository 'Update (Non-OSS)' is up to date.                                                                    
    Retrieving repository 'Packman' metadata .................................................................[done]
    Building repository 'Packman' cache ......................................................................[done]
    Retrieving repository 'Updates from SUSE Linux Enterprise 15' metadata --------------------------------------[/]
    It is now hanging already for several minutes.

    I am having the same URL as you:
    Code:
    boven:/etc/zypp/repos.d # grep base sle-update.repo 
    baseurl=http://download.opensuse.org/update/leap/$releasever/sle/
    boven:/etc/zypp/repos.d #
    I will try to alert the admins.
    Henk van Velden

  5. #15

    Default Re: Slow Repo

    I'm still having a problem. Updating the repo has been running for over 15-minutes.

  6. #16
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,967

    Default Re: Slow Repo

    I now succeeded. It seems to go on and off.

    I reported upstream, but for some reason they do not understand me
    Henk van Velden

  7. #17
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    504

    Default Re: Slow Repo

    Mine hangs at ref "Retrieving repository 'Update repository with updates from SUSE Linux Enterprise". Hangs in both software manager and zypper.

    Has been not ref for last 8 hours when tried intermittently

    No refresh from 0700 to 1500 here in us central (gmt-6).

    tom kosvic

  8. #18
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,048

    Default Re: Slow Repo

    Zypper dup.. From CEST 21.34 to 21.38.

    Yes:
    Code:
    15 packages to upgrade, 6 new. 
    Overall download size: 238.8 MiB. Already cached: 0 B. After the operation, additional 336.5 MiB will be used.


    The upgrade took from 21.39 to to 21.53 CEST. Soon it will be compered with MS(Microsoft) levels.

    Regards from Sweden.

    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  9. #19

    Default Re: Slow Repo

    I just tried again and it is fixed. Thanks everyone.

  10. #20
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    4,000
    Blog Entries
    1

    Default Re: Slow Repo

    7 hours ago SLE was slower than normal refreshing, but it didn't seem to affect zypper up. several hours later on a different PC SLE seemed to be back to its normal sloth, not unduly slow, just annoying that it's last and seems to take longer than all others combined.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •