Results 1 to 10 of 10

Thread: Windows doesn't boot with GRUB2.

  1. #1

    Question Windows doesn't boot with GRUB2.

    Hi,

    I have two SSD installed. One with openSuse Tumbleweed and the other one with Windows 10. I had this before and everything worked fine. Then I decided to delete Windows completely and use this SSD for files under Linux. Because I am a gamer and had some problems with a game I wanted to play I change my mind again and wanted to use this SSD for Windows 10 again. So I installed Windows and that could be the end of the story because: Linux works fine and Windows 10 works fine.

    But: the bootloader (GRUB2) doesn't work as before. I still see Windows 10 in the menu but when I select it I get the following error message:
    Code:
    error: ../../grub-core/commands/search.c:296:no such device: ???77BA8774957.
    error: ../../grub-core/net/net.c:1474:disk `hd1,msdos1' not found.
    error: ../../grub-core/net/net.c:1474:disk `hd1,msdos1' not found.
    
    Press any key to continue...
    (The ??? above are, because I took a picture with my smartphone and cannot read all of the numbers because it's coropped)

    When I change the boot order in UEFI between the both SSD I can chose which one should be booted and that's how I switch between Linux and Windows right now. But it's kind of annoying and I want to use the GRUB2 menu again.

    Do you have any idea what's the problem is and how I can solve it? I am a beginner and guess that the bootloader tries to use something from the old Windows installation!? But I don't know.

    Thank you for your time!

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,018
    Blog Entries
    3

    Default Re: Windows doesn't boot with GRUB2.

    It's a bit hard to guess with so little information.

    If you are able to boot Windows with the UEFI menu, that suggests that Windows is installed to use UEFI. And if it is using UEFI, then that normally means it is installed on a GPT partitioned drive. However, "hd1,msdos1" does not make sense for a GPT drive.

    You possibly have a mix of systems, with one of your systems using UEFI booting and the other using traditional MBR booting. That won't work for booting Windows with grub2.


    Please provide the output from:
    Code:
    fdisk -l
    (run that as root).
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  3. #3
    Join Date
    Sep 2012
    Posts
    7,880

    Default Re: Windows doesn't boot with GRUB2.

    Quote Originally Posted by Strapinski View Post
    When I change the boot order in UEFI between the both SSD I can chose which one should be booted
    Are you using EFI or legacy BIOS boot?
    I ... guess that the bootloader tries to use something from the old Windows installation!?
    Yes. grub menu is built statically and it refers to old filesystem UUID; when you reinstalled Windows it formatted partition and so UUID changed. Run in openSUSE as root
    Code:
    update-bootloader --refresh
    to make it scan for new Windows installation and update configuration.

  4. #4

    Default Re: Windows doesn't boot with GRUB2.

    Quote Originally Posted by nrickert View Post
    Please provide the output from:
    Code:
    fdisk -l
    (run that as root).
    Here is the output:
    Code:
    Disk /dev/sda: 119,24 GiB, 128035676160 bytes, 250069680 sectors
    Disk model: SAMSUNG SSD 830  
    Units: sectors of 1 * 512 = 512 bytes 
    Sector size (logical/physical): 512 bytes / 512 bytes 
    I/O size (minimum/optimal): 512 bytes / 512 bytes 
    Disklabel type: gpt 
    Disk identifier: 287EB7DB-FADE-449E-9AC9-3100DF1E3858 
    
    Device        Start      End  Sectors  SizeType
    /dev/sda1       2048     18431     16384     8M BIOS boot 
    /dev/sda2      18432 245874687 245856256 117,2G Linux filesystem 
    /dev/sda3  245874688 250069646   4194959     2G Linux swap 
    
    
    Disk /dev/sdb: 931,51 GiB, 1000204886016 bytes, 1953525168 sectors
    Disk model: Samsung SSD 860  
    Units: sectors of 1 * 512 = 512 bytes 
    Sector size (logical/physical): 512 bytes / 512 bytes 
    I/O size (minimum/optimal): 512 bytes / 512 bytes 
    Disklabel type: gpt 
    Disk identifier: BF8A1343-664C-4F05-9B9B-0EACD09A44D6 
    
    Device         Start       End   Sectors  SizeType
    /dev/sdb1        2048     206847     204800   100M EFI System 
    /dev/sdb2      206848     239615      32768    16M Microsoft reserved 
    /dev/sdb3      239616 1952445812 1952206197 930,9G Microsoft basic data 
    /dev/sdb4  1952446464 1953521663    1075200   525M Windows recovery environment 
    

    Quote Originally Posted by arvidjaar View Post
    Are you using EFI or legacy BIOS boot?
    To be honest: I am not sure. I try to find out and post it here as soon as possible. I just know the UI looks like UEFI.


    Quote Originally Posted by arvidjaar View Post
    Yes. grub menu is built statically and it refers to old filesystem UUID; when you reinstalled Windows it formatted partition and so UUID changed. Run in openSUSE as root
    Code:
    update-bootloader --refresh
    to make it scan for new Windows installation and update configuration.
    I ran the command and now Windows 10 disappears from the GRUB menu. So I guess GRUB noticed it's not there anymore like before, removed the entry but didn't find the new installation. Maybe here begins what @nrickert is talking about?

    In UEFI/BIOS the Windows SSD is called as "Windows Boot Loader: SSD Samsung 1tB etc."

  5. #5
    Join Date
    Sep 2012
    Posts
    7,880

    Default Re: Windows doesn't boot with GRUB2.

    Quote Originally Posted by Strapinski View Post
    Maybe here begins what @nrickert is talking about?
    Yes, it sounds like it.

    In UEFI/BIOS the Windows SSD is called as "Windows Boot Loader: SSD Samsung 1tB etc."
    This is UEFI boot.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,018
    Blog Entries
    3

    Default Re: Windows doesn't boot with GRUB2.

    It looks as if you have Tumbleweed installed for traditional MBR booting, and Windows for UEFI booting. Unfortunately, that combination doesn't work. You need to either reinstall Windows for MBR booting, or reinstall Tumbleweed for UEFI booting. My advice would be to reinstall Tumbleweed for UEFI booting.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,018
    Blog Entries
    3

    Default Re: Windows doesn't boot with GRUB2.

    I should add that it should be technically possible to switch Tumbleweed to using UEFI booting without a reinstall. However, it is a bit tricky, so a reinstall might be simpler.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  8. #8

    Default Re: Windows doesn't boot with GRUB2.

    Thanks for your help. I reinstalled openSUSE and now everything works fine.

    During the installation at the partition overview I saw that Linux will be installed for EFI booting but I still don't get where I had the possibility to change this for Linux and Windows. I just installed it (as always) but I never saw the option "Do you want EFI or MBR booting?".

    Thanks for your time again for solving my problem.

  9. #9
    Join Date
    Sep 2012
    Posts
    7,880

    Default Re: Windows doesn't boot with GRUB2.

    Quote Originally Posted by Strapinski View Post
    I still don't get where I had the possibility to change this for Linux and Windows.
    This is determined by the way you boot installation medium. Exact boot options depend on your system, there is no universal standard. Often you see something like "UEFI: DVD" or "UEFI: Removable Drive" in the list of boot options. You need to consult your system/BIOS manual how to chose boot method.

  10. #10

    Default Re: Windows doesn't boot with GRUB2.

    Quote Originally Posted by arvidjaar View Post
    This is determined by the way you boot installation medium. Exact boot options depend on your system, there is no universal standard. Often you see something like "UEFI: DVD" or "UEFI: Removable Drive" in the list of boot options. You need to consult your system/BIOS manual how to chose boot method.
    Ahh, I guess I know what you mean. As I installed Linux today and changed the boot order in UEFI so the system boots from USB device I had the options:
    USB: USB
    UEFI: USB
    or something like that. So if I had chose the first one it would have been installed as the wrong one again. Did I get you right?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •