Results 1 to 9 of 9

Thread: cryfs out of date

  1. #1

    Default cryfs out of date

    "Failed to open: The installed version of cryfs is too old to open this vault."

    Why is the cryfs version so old. https://software.opensuse.org/package/cryfs says 9.9 has been in use since at least 15.0, and even the beta 15.4 still shows version cryfs 9.9 while Tumbleweed uses 11.2.

    An upgrade to 10.anything would solve the incompatibility. How do we get a backport or security upgrade?

    Thanks,
    Lance

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,226

    Default Re: cryfs out of date

    Code:
    https://build.opensuse.org/package/show/security%3Aprivacy/cryfs
    Has 0.10.2 for 15.x, would have 0.11 but it fails due to cmake issue.
    .: miuku @ #opensuse @ irc.libera.chat

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: cryfs out of date

    Henk van Velden

  4. #4

    Default Re: cryfs out of date

    Thanks, I downloaded the cryfs 10.x binary, which solved the problem. Now, what's the process for getting that where end-users like me will find it? Preferable in the repo's, or at least https://software.opensuse.org/package/cryfs ?

  5. #5
    Join Date
    Sep 2012
    Posts
    7,859

    Default Re: cryfs out of date

    Quote Originally Posted by LanceHaverkamp View Post
    Preferable in the repo's, or at least https://software.opensuse.org/package/cryfs ?
    You cannot have it in the latter without having in the former. software.o.o is just a search engine for repositories.

    Building of new version fails on Leap 15.3 because it needs range-v3 which is missing. So you would need to either patch out this requirement for Leap 15.3 (assuming it is optional) or provide it for Leap 15.3 so that cryfs can use it.

  6. #6

    Default Re: cryfs out of date

    Quote Originally Posted by arvidjaar View Post
    You cannot have it in the latter without having in the former. software.o.o is just a search engine for repositories.

    Building of new version fails on Leap 15.3 because it needs range-v3 which is missing. So you would need to either patch out this requirement for Leap 15.3 (assuming it is optional) or provide it for Leap 15.3 so that cryfs can use it.
    Bear with me, I'm just an end-user [scratching head in confusion]; since 99.99% of users are not going to "build" this, they're just installing it...why are we shipping an outdated version that won't open a file from any other distro? Even Debian Stable, which is notorious for being outdated, is shipping 10.2-5

    Thanks for the education,
    Lance

  7. #7
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,226

    Default Re: cryfs out of date

    Quote Originally Posted by LanceHaverkamp View Post
    Thanks, I downloaded the cryfs 10.x binary, which solved the problem. Now, what's the process for getting that where end-users like me will find it? Preferable in the repo's, or at least https://software.opensuse.org/package/cryfs ?
    It shows up under the "Show Experimental Packages".

    Unfortunately the s.o.o for 15.3 is broken and has been since it came out. I won't say anything about it because it wouldn't be pretty and I'd get banned from here if I said what I think about the main search engine for the distro being broken for 9 months.

    Perhaps it'll be fixed for 15.4.
    .: miuku @ #opensuse @ irc.libera.chat

  8. #8
    Join Date
    Sep 2012
    Posts
    7,859

    Default Re: cryfs out of date

    Quote Originally Posted by LanceHaverkamp View Post
    Even Debian Stable, which is notorious for being outdated, is shipping 10.2-5
    Yes, Bullseye also ships range-v3. Somebody needs to submit it to Leap 15.3. It does not happen by itself.

  9. #9
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,251
    Blog Entries
    15

    Default Re: cryfs out of date

    Quote Originally Posted by Miuku View Post
    It shows up under the "Show Experimental Packages".

    Unfortunately the s.o.o for 15.3 is broken and has been since it came out. I won't say anything about it because it wouldn't be pretty and I'd get banned from here if I said what I think about the main search engine for the distro being broken for 9 months.

    Perhaps it'll be fixed for 15.4.
    Hi
    S.O.O. is being decommissioned...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •