Results 1 to 3 of 3

Thread: Po ostatniej aktualizacji nie mam wi-fi

  1. #1

    Default Po ostatniej aktualizacji nie mam wi-fi

    Witam

    Jestem tutaj nowy na forum. Dzisiaj była aktualizacja kernela na 5.16.5 i po tej aktualizacji przy starcie z tego jądra nie uruchomiła mi się sieć wi-fi. Sterownik do niej do broadcom-wl. Poprawnie ładuje się z jądrem 5.16.4 i z tego korzystam. Jednak proszę o informację podłączyć ten sterownik do najnowszego jądra.
    [KOD] # zypper se broadcom-wl
    Wczytywanie danych repozytorium...
    Switchowanie zainstalowanych pakietów...

    Code:
    # zypper se broadcom-wl
    Wczytywanie danych repozytorium...
    Odczytywanie zainstalowanych pakietów...
    
    S  | Name                              | Summary                                               | Type
    ---+-----------------------------------+-------------------------------------------------------+----------------
    i+ | broadcom-wl                       | Wireless driver for Broadcom 43xx series of chips     | pakiet
       | broadcom-wl                       | Wireless driver for Broadcom 43xx series of chips     | pakiet źródłowy
       | broadcom-wl-debugsource           | Debug sources for package broadcom-wl                 | pakiet
    i  | broadcom-wl-kmp-default           | Wireless driver for Broadcom 43xx series of chips     | pakiet
       | broadcom-wl-kmp-default-debuginfo | Debug information for package broadcom-wl-kmp-default | pakiet
       | broadcom-wl-kmp-pae               | Wireless driver for Broadcom 43xx series of chips     | pakiet
       | broadcom-wl-kmp-pae-debuginfo     | Debug information for package broadcom-wl-kmp-pae     | pakiet
    
    
    Last edited by pbojczuk; 12-Feb-2022 at 06:16.

  2. #2
    Join Date
    Aug 2021
    Location
    Wolne Miasto
    Posts
    64

    Default

    Z tego co się orientuje to moduł broadcom-wl należy zainstalować samemu: https://software.opensuse.org/package/broadcom-wl czyli z repozytorium społeczności, widocznie zmiany w nowszym kenelu nie są jeszcze uwzględnione w module. Uroki korzystania z Tumbleweed. Naprawdę współczuję... Chyba że dysponujesz pakietem źródłowym modułu oraz nagłówkami jądra, więc możesz pokusić się o przebudowę modułu.

    Jednak nie tak prędko, gdyż jeśli zajrzeć do "pierwszego lepszego" użytkownika OBS np: https://build.opensuse.org/package/s...rm/broadcom-wl można zauważyć że ostatnie łaty pochodzą z sprzed 4 lat a na domiar złego aktualna kompilacja dla Tumbleweed ma nierozwiązane zależności. Więc jeśli byś chciał rzeczywiście przebudowywać pakiet samemu, sukces byłby wątpliwy. Myślę że po prostu pozostaje Tobie przeczekać na poprzedniej wersji kernela, i modlić się do bogów ot to, żeby zypper nie usuną zbyt wcześnie owej starszej wersji.
    Pozdrawiam
    Last edited by pbojczuk; 12-Feb-2022 at 06:16.
    Moja strona domowa: https://pietraszczyk.vxm.pl

  3. #3
    Join Date
    Dec 2017
    Posts
    143
    Blog Entries
    12

    Default Re: Po ostatniej aktualizacji nie mam wi-fi

    Nie wiem, nie znam się, mam inny sprzęt ale...


    @Kx_liner, spróbuj załadować na razie system z jądrem, w którym sterownik działa poprawnie. Następnie spróbuj rozpoznać własciwy moduł:
    Code:
    lsmod
    Następnie spróbuj go usunąć i dodać ponownie:
    Code:
    rmmod nazwa
    Code:
    modprobe nazwa
    Spodziewaj się zależności. U mnie taka sesja wygląda tak:
    Code:
    root@x260:~# rmmod iwlwifi 
    rmmod: ERROR: Module iwlwifi is in use by: iwlmvm
    root@x260:~# rmmod iwlmvm
    root@x260:~# rmmod iwlwifi 
    root@x260:~# lsmod | grep wifi
    root@x260:~# modprobe iwlmvm
    root@x260:~# lsmod | grep wifi
    iwlwifi               315392  1 iwlmvm
    cfg80211             1036288  3 iwlmvm,iwlwifi,mac80211
    root@x260:~#
    Przyda CI się również identyfikacja karty sieciowej ot choćby:
    Code:
    lspci
    lub lepiej - to polecenie od razu powinno pokazać Twój moduł:
    Code:
    inxi -na
    Gdy będziesz wiedział, jak nazywają się potrzebne modłuły w Twoim przypadku, to spróbujemy ich poszukać i ustalić, czemu się nie ładują.
    Last edited by pbojczuk; 12-Feb-2022 at 10:49.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •