Results 1 to 3 of 3

Thread: Can't connect to QEMU/KVM though Virtual Machine Manager

  1. #1

    Question Can't connect to QEMU/KVM though Virtual Machine Manager

    So I wanted to run a couple of VMs using the built-in tools with OpenSUSE, so I installed KVM through YaST, and tried to run Virtual Machine Manager.

    Unfortunately, it gives me this error when it tries to connect to QEMU:

    Unable to connect to libvirt qemu:///system.


    error from service: GDBus.Errorrg.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.238" (uid=0 pid=23755 comm="/usr/sbin/libvirtd --timeout 120 ") interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" error name="(unset)" requested_reply="0" destination="org.freedesktop.PolicyKit1" (bus)


    Libvirt URI is: qemu:///system


    Traceback (most recent call last):
    File "/usr/share/virt-manager/virtManager/connection.py", line 924, in _do_open
    self._backend.open(cb, data)
    File "/usr/share/virt-manager/virtinst/connection.py", line 153, in open
    conn = libvirt.openAuth(self._open_uri,
    File "/usr/lib64/python3.8/site-packages/libvirt.py", line 148, in openAuth
    raise libvirtError('virConnectOpenAuth() failed')
    libvirt.libvirtError: error from service: GDBus.Errorrg.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.238" (uid=0 pid=23755 comm="/usr/sbin/libvirtd --timeout 120 ") interface="org.freedesktop.PolicyKit1.Authority" member="CheckAuthorization" error name="(unset)" requested_reply="0" destination="org.freedesktop.PolicyKit1" (bus)

    Any help on this would be greatly appreciated!

  2. #2

    Default Re: Can't connect to QEMU/KVM though Virtual Machine Manager

    I'm not entirely sure how to delete a thread, but this issue got resolved. I had system files that had updated but I hadn't restarted in a while.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,007

    Default Re: Can't connect to QEMU/KVM though Virtual Machine Manager

    Hello, welcome to the openSUSE forums.

    No need to delete. We can all see it is solved.

    But I have some information for next time you come here and want to post computer text (I assume you saw the smileys in your post):

    There is an important, but not easy to find feature on the forums.

    Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

    An example is here: Using CODE tags Around your paste.
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •