Results 1 to 8 of 8

Thread: Setting up NSFV4.2 with Yast2 connected but no write permission.

  1. #1
    Join Date
    Nov 2008
    Posts
    2,443
    Blog Entries
    1

    Default Setting up NSFV4.2 with Yast2 connected but no write permission.

    I have NFS Server set up on remote machine using Yast2 with the domain name "localdomain" all as in the documentation. When I then went to client machine hoping to see the served directory I had the No server found message.

    I found the following thread here:-

    https://forums.opensuse.org/showthre...ighlight=NFSv4

    but before trying to set up a share manually I tried forcing use of NFSv4.2 and then used then went back to Select button to create a client connection. On this occasion my exported share was available. Hoorah!

    My firewall has nfs allowed and port 2049 opened.

    My problem is that I have no write permission when looking at the shared directories from Dolphin. The mount is shown with rw permissions.

    Where am I going wrong please?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,354

    Default Re: Setting up NSFV4.2 with Yast2 connected but no write permission.

    Please show the /etc/fstab entry!
    Code:
    cat /etc/fstab | grep nfs
    and how it is mounted
    Code:
    mount | grep nfs
    And owner/permissions of the mount point
    Code:
    ls -ld /..........
    And from the NFS server, how it is exported:
    Code:
    cat /etc/exports
    And owner/permissions of the exported directory
    Code:
    ls -ld /......
    Henk van Velden

  3. #3
    Join Date
    Nov 2008
    Posts
    2,443
    Blog Entries
    1

    Default Re: Setting up NSFV4.2 with Yast2 connected but no write permission.

    Hi Henk,
    These are the results from the client machine.
    I have to go to place to get the server info so will reply from there.

    Code:
    alastair@HP-Z640-1:~> cat /etc/fstab | grep nfs    
    192.168.169.134:/multimedia                /home/alastair/mastermedia  nfsnfsvers=4.2                   0  0 
    alastair@HP-Z640-1:~> 
    
    
    Code:
    alastair@HP-Z640-1:~> mount | grep nfs 
    192.168.169.134:/multimedia on /home/alastair/mastermedia type nfs4 (rw,relatime,vers=4.2,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clienta
    ddr=192.168.169.137,local_lock=none,addr=192.168.169.134) 
    alastair@HP-Z640-1:~> 
    
    
    Code:
    alastair@HP-Z640-1:~> ls -ld /home/alastair/mastermedia 
    drwxrwxr-x 4 alastair users 52 Feb 22  2016 /home/alastair/mastermedia
    alastair@HP-Z640-1:~> 
    
    
    I believe this is what is wanted and looks OK to me.

  4. #4
    Join Date
    Nov 2008
    Posts
    2,443
    Blog Entries
    1

    Default Re: Setting up NSFV4.2 with Yast2 connected but no write permission.

    Quote Originally Posted by hcvv View Post
    Please show the /etc/fstab entry!
    Code:
    cat /etc/fstab | grep nfs
    and how it is mounted
    Code:
    mount | grep nfs
    And owner/permissions of the mount point
    Code:
    ls -ld /..........
    And from the NFS server, how it is exported:
    Code:
    cat /etc/exports
    And owner/permissions of the exported directory
    Code:
    ls -ld /......
    Hi Henk,
    On the client machine this tells me what I was looking for. Here are the exports:-
    Code:
    alastair@ibmserv2:~> cat /etc/exports 
    /home/alastair/Mastermedia      *(ro,root_squash,sync,no_subtree_check) 
    alastair@ibmserv2:~> 
    
    
    I couldn't work out why I had ro for the export so, in Yast, I went to the share. The problem was that the window box that was opened by Yast for options was shorter than the line of default options and had been truncated by the relevant characters. When I scrolled back all was revealed. I am not surprised by the default being ro but didn't anticipate that the first part of the line was hidden.

    Having edited the options on the server and rebooted the client all is now well and thanks again for the help. I wouldn't have found it myself but am not sure I understand why a reboot was needed on the client. I log out and in was not sufficient.

    Many many thanks again.
    Budge.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,354

    Default Re: Setting up NSFV4.2 with Yast2 connected but no write permission.

    Yes, that looks fine to me also. It is not mounted ro and alistair:users is owner and has permissions in that directory.

    Thus, alistair must be able to write in that directory. Try that with e.g.
    Code:
    touch /home/alastair/mastermedia/tttest
    or, when alistair is in his home directory:
    Code:
    touch mastermedia/tttest
    Should be possible.

    (PS, do not forget to remove after the test
    Code:
    rm mastermedia/tttest
    )
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,354

    Default Re: Setting up NSFV4.2 with Yast2 connected but no write permission.

    Sorry, my post above was posted before your last post.

    Do I understand that you had first ro in the exports ebtry? And that by changing that to rw all is fine now.
    Then congratulations.

    I do not quite understand why you talk about Windows now???

    BTW, these things are called "exports", not "shares"
    Henk van Velden

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,343

    Default AW: Setting up NSFV4.2 with Yast2 connected but no write permission.

    /home/alastair/Mastermedia *(ro,root_squash,sync,no_subtree_check)
    Exported as read only, not read write rw?

  8. #8
    Join Date
    Nov 2008
    Posts
    2,443
    Blog Entries
    1

    Default Re: Setting up NSFV4.2 with Yast2 connected but no write permission.

    Hi Henk and Sauerland, I have the export working now. The window I refer to is the Options window in the Yast tool for creating NFS export. I didn't see the full default options line.
    Now back to work!
    Regards,
    Budge.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •