Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Nvidia driver on OpenSuse Tumbleweed require sudo?

  1. #21

    Default Re: Nvidia driver on OpenSuse Tumbleweed require sudo?

    Quote Originally Posted by asudem View Post
    Alright I believe the answer lies in MOK management... I do not believe I was prompted for MOK Management after installing the G06 drivers but I could be wrong... I believe the MOK keypair was signed with G05 and now seeing G06 it doesn't want it to work? I think I will try an uninstall and reinstall of the drivers to see if I get the MOK management prompt...
    Nvidia drivers are never signed in openSUSE: https://forums.opensuse.org/showthre...83#post2942983

    DIY if you need it: https://download.nvidia.com/XFree86/...#modulesigning

    Maybe it works now: https://en.opensuse.org/SDB:NVIDIA_drivers#Secureboot

  2. #22

    Default Re: Nvidia driver on OpenSuse Tumbleweed require sudo?

    Quote Originally Posted by Svyatko View Post
    Well all of this is news to me, and pretty much voids any MOK management theories, because of G06 isn't signed, what you're telling me is G05 wasn't signed either. And since I'm not running the installer (I didn't for G05 either) I can't generate signing keys.

    As the "run nvidia-smi as root on boot" fix in my previous post is working for now™, I guess that's what I am stuck with until a proper solution for what is going on is found.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •