Results 1 to 10 of 10

Thread: Network Manager wireless must be turned off and then on after booting since latest wpa_supplicant

  1. #1

    Default Network Manager wireless must be turned off and then on after booting since latest wpa_supplicant

    Hi All,

    Wondering if anyone else has run into this. Running OpenSuse 15.3 successfully for quite some time using Network Manager on top of KDE to manage my wifeless connections. All was well until relatively recently when I noticed that I had an update to wpa_supplicant-2.9-4.29.1.x86_64. It seems since then, after booting I have to disable wireless in network manager and enable it again. Until I do that, my wireless connection doesn't show up. It then works fine after I enable it again. Until recently, as soon as I logged in, I would be prompted to enter my wallet password and once done, I'd be connected. Now, my wireless connection doesn't even show up in the list. I've tried waiting quite some time and still doesn't appear. If I disable wireless and reenable, it shows up immediately. Anyone else experiencing this? Thanks.




  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,792

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    @jerid0:

    Hello and welcome to this Forum.

    Can you please post the following information for the case that the WLAN/WiFi connection isn't present –
    • “rfkill list”
    • “iwconfig”
    • “ip link”

    Can you also please indicate which Wireless security you're using – WPA or WEP?

  3. #3

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    Thanks so much for the response. Security is WPA.
    Output from the requested commands are below. This is with the wireless working as i disabled and reenabled wifi already. Please let me know if you need the same before it starts working:

    Code:
    rfkill list  
    0: ideapad_wlan: Wireless LAN 
            Soft blocked: no 
            Hard blocked: no 
    1: ideapad_bluetooth: Bluetooth 
            Soft blocked: no 
            Hard blocked: no 
    2: phy0: Wireless LAN 
            Soft blocked: no 
            Hard blocked: no 
    3: hci0: Bluetooth 
            Soft blocked: no 
            Hard blocked: no
    
    # iwconfig 
    lo        no wireless extensions. 
    
    eth0      no wireless extensions. 
    
    wlan0     IEEE 802.11  ESSID:"LINKNET"   
              Mode:Managed  Frequency:2.447 GHz  Access Point: D2:40:D0:4D:3B:43    
              Bit Rate=121.5 Mb/s   Tx-Power=16 dBm    
              Retry short limit:7   RTS thr:off   Fragment thr:off 
              Encryption key:off 
              Power Management:off 
              Link Quality=70/70  Signal level=-38 dBm   
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0 
              Tx excessive retries:0  Invalid misc:51   Missed beacon:0
    
    # ip link 
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000 
        link/ether 28:d2:44:11:69:43 brd ff:ff:ff:ff:ff:ff
        altname enp3s0 
    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000 
        link/ether 60:6c:66:61:64:bc brd ff:ff:ff:ff:ff:ff
        altname wlp4s0
    
     

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,792

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    Quote Originally Posted by jerid0 View Post
    Please let me know if you need the same before it starts working:
    Yes please.

    I've now patched and updated this Leap 15.3 Laptop and, I'm not seeing the issue you're experiencing but –

  5. #5

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    OK. Here's the same commands without the network working. Seems strange I would have to setup automatic prompting for the wallet when I didn't (intentionally) change anything it just stopped working and I don't see the entry in the network manager like I always did before unless i disable and enable. I also think once now I've seen it briefly pop up again in the network manager window and then disappear. But again, disable/enable allowed me to connect. I'm wondering if network manager settings have become corrupted? Again would seem strange to work then once I follow my usual procedure.

    Here's the results of the 3 commands while network isn't working. Thanks again for trying to help:
    Code:
     # rfkill list
    0: ideapad_wlan: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    1: ideapad_bluetooth: Bluetooth
            Soft blocked: no
            Hard blocked: no
    2: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    3: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no
    linux-pvzf:/home/jerid # iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    linux-pvzf:/home/jerid # ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
        link/ether 28:d2:44:11:69:43 brd ff:ff:ff:ff:ff:ff
        altname enp3s0
    3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
        link/ether 0e:ed:44:78:78:75 brd ff:ff:ff:ff:ff:ff
        altname wlp4s0

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,792

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    Quote Originally Posted by jerid0 View Post
    I didn't (intentionally) change anything it just stopped working and I don't see the entry in the network manager like I always did before unless i disable and enable.
    in other words, after you login, the Network Manager doesn't scan for any WLAN/WiFi Access Points despite, the Wireless Connections option being activated and, presumably the Aeroplane Mode being disabled …
    Presumably, you're using a Laptop, with function keys to control the Wireless interface and Aeroplane Mode.
    Regardless, we need to use the Network Manager Command Line interface to query the Network Manager states –
    • For the case of a fresh login with the WLAN/WiFi state of disabled, please post the output of:
    • “nmcli general”
    • “nmcli networking”
    • “nmcli radio”
    • “nmcli device”

    Please also check but, please, do not post, the output of “nmcli device wifi” –


    • Assuming that, the WiFi device is active, you should see a list of all the WiFi Access Points nearby.

  7. #7

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    Thanks again for trying to help with this. Interesting thing. Before I ran the commands, I checked to make sure my wireless connection wasn't offered in Network Manager and it was not. When I ran the commands when the network wasn't connected and then went back to Network Manager, now my connection was offered. At first, I thought it was just taking longer to appear and that if I waited longer it would. So I did that test, and it never came up. Ran your requested commands, went back to Network Manager and sure enough, now the option was there. Similar to how disabling and reenabling makes it appear. When I ran nmcli device wifi, it did show a list of available networks. It didn't show the SSID's, so I can't be sure mine was there. But based on the strength indication, I suspect it was. Here's the output of the commands you requested except for the nmcli device wifi since you asked not to post that one:
    Code:
    # nmcli general
    STATE         CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
    disconnected  none          enabled  enabled  enabled  enabled 
    # nmcli networking
    enabled
    # nmcli radio
    WIFI-HW  WIFI     WWAN-HW  WWAN    
    enabled  enabled  enabled  enabled 
    # nmcli device
    DEVICE  TYPE      STATE         CONNECTION 
    wlan0   wifi      disconnected  --         
    eth0    ethernet  unavailable   --         
    lo      loopback  unmanaged     --         
    nmcli device wifi

  8. #8
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    768

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    Looking at the output of the commands and comparing that with the output I get (WiFi enabled but not connected) I see exactly the same as you expect that the last command gives a list of nearby WiFi access points.

    Is it maybe that there are no nearby WiFi access points?

    Assuming that is not the case, can you try a more low-level command:

    $ sudo iwlist wlan0 scan

    That should give the list nearby WiFi access points.
    If it errors out, please post the command and the complete (error) output.
    If that is working it is a NetworkManger problem, if not it is some low-level problem.

  9. #9

    Default Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    So based on your suggestion that it must be a network manager problem, I fully agree. I did not get any errors when trying your last suggested command. So, then I did what I probably should have tried first and disabled wifi, deleted all of my wifi configurations in Network Manager and added the key one back in again. After multiple reboot tests, it now works every time! I really appreciate your help and now have an arsenal of commands to use for diagnosing wireless issues. So, thanks again for the help.

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,792

    Smile Re: Network Manager wireless must be turned off and then on after booting since latest wpa_supplican

    Quote Originally Posted by jerid0 View Post
    So, thanks again for the help.
    You're welcome.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •