Results 1 to 4 of 4

Thread: Fresh 15.4 Alpha/beta upgrade && "Fails to add Packman Repo"???

  1. #1

    Default Fresh 15.4 Alpha/beta upgrade && "Fails to add Packman Repo"???

    So, I got passed the "no upgrade" function in the live JEOS??? iso's by downloading the main system iso and ran the "upgrade" process and generally it went well, the installer does a good job of finding the old system and so forth . . . .

    After running the install I tried to "add Packman" via Yast Software Repos and when I clicked on "Go" it brought a "We have failed to add Packman to your beautiful system" error window??? I tried to several times and even rebooted the system a few times, tried to see if zypper would upgrade, etc. "Nothing to do." it said.

    So, is it that the Alpha edition is too fresh for the olde Packman Repos?? I noticed that when I ran "zypper ref" there were a couple of lines that said, "Backports looks outdated," and another one that said, "Main Updates looks outdated."???? I saw in the installer where it said, "Removing old repos" . . . so why are the "new" repos already "outdated"????? I tried to look at the what "ftp" address for Packman, but I think it was showing the adjusted address??? Not sure on that . . . but same question, if this is "Alpha," which is supposed to be "fresh horsies" ready for flogging, why would an old address still be in use to cause a "failure to add Packman" error????

    And, then, as posted in the "Grub> what next?" thread . . . somewhere in the recent upgrades ??? of what was Leap 15.3 grub must have been scrubbed and when booting to 15.4 Alpha via usb drive we powered over the "lack of grub" in the 15.3 installation, and in the upgrade I saw "installing grub2" in the jobs listing, but on reboot . . . blank screen, no grub. I had to boot the new system with SG2 disk and then log in as root and run
    Code:
    #grub2-install
    to get the newly upgraded system to boot. Somewhere in Leap 15.3 there must have been a "grub glitch"????

    But, main question, is it possible to get Packman repos added to 15.4 Alpha??

  2. #2
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    32,903
    Blog Entries
    15

    Default Re: Fresh 15.4 Alpha/beta upgrade && "Fails to add Packman Repo"???

    Quote Originally Posted by non_space View Post
    So, I got passed the "no upgrade" function in the live JEOS??? iso's by downloading the main system iso and ran the "upgrade" process and generally it went well, the installer does a good job of finding the old system and so forth . . . .

    After running the install I tried to "add Packman" via Yast Software Repos and when I clicked on "Go" it brought a "We have failed to add Packman to your beautiful system" error window??? I tried to several times and even rebooted the system a few times, tried to see if zypper would upgrade, etc. "Nothing to do." it said.

    So, is it that the Alpha edition is too fresh for the olde Packman Repos?? I noticed that when I ran "zypper ref" there were a couple of lines that said, "Backports looks outdated," and another one that said, "Main Updates looks outdated."???? I saw in the installer where it said, "Removing old repos" . . . so why are the "new" repos already "outdated"????? I tried to look at the what "ftp" address for Packman, but I think it was showing the adjusted address??? Not sure on that . . . but same question, if this is "Alpha," which is supposed to be "fresh horsies" ready for flogging, why would an old address still be in use to cause a "failure to add Packman" error????

    And, then, as posted in the "Grub> what next?" thread . . . somewhere in the recent upgrades ??? of what was Leap 15.3 grub must have been scrubbed and when booting to 15.4 Alpha via usb drive we powered over the "lack of grub" in the 15.3 installation, and in the upgrade I saw "installing grub2" in the jobs listing, but on reboot . . . blank screen, no grub. I had to boot the new system with SG2 disk and then log in as root and run
    Code:
    #grub2-install
    to get the newly upgraded system to boot. Somewhere in Leap 15.3 there must have been a "grub glitch"????

    But, main question, is it possible to get Packman repos added to 15.4 Alpha??
    Hi
    In a nutshell, unlikely at alpha stage. The build targets are there, but not published yet as somethings fail to build. I suspect sometime in the future when it gets to RC stage you might see something pop.

    Alpha is alpha, the developers expect bug reports.... plus they will be concentrating on specific aspects of the install based on my experience with SLE Alpha/Beta testing.
    Last edited by malcolmlewis; 21-Jan-2022 at 10:03.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,962

    Default AW: Fresh 15.4 Alpha/beta upgrade && "Fails to add Packman Repo"???

    Leap 15.4 is alpha so maybe there is no Packman Repo available or enabled by Packman.......

  4. #4

    Default Re: AW: Fresh 15.4 Alpha/beta upgrade && "Fails to add Packman Repo"???

    Quote Originally Posted by malcolmlewis View Post
    Hi
    In a nutshell, unlikely at alpha stage. The build targets are there, but not published yet as somethings fail to build. I suspect sometime in the future when it gets to RC stage you might see something pop.

    Alpha is alpha, the developers expect bug reports.... plus they will be concentrating on specific aspects of the install based on my experience with SLE Alpha/Beta testing.
    @malcolmlewis:

    Thanks for the thoughts and the quotable quote, "Alpha IS Alpha" . . . very nice. Back in my construction days we used to have a similar saying . . . "It IS what it IS . . . ." It kind of covers just about any situation . . . . : - ))))

    Quote Originally Posted by Sauerland View Post
    Leap 15.4 is alpha so maybe there is no Packman Repo available or enabled by Packman.......
    @Sauerland:

    And thanks to you for the thoughts . . . in fact it didn't seem to interfere with mini video playing on the Twitter . . . so no real raging rush to get Packman going . . . .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •