Results 1 to 3 of 3

Thread: PPPoE VDSL connection start on boot

  1. #1

    Default PPPoE VDSL connection start on boot

    Hi, I have a machine with a VDSL connection that I want to automatically connect to the internet when it boots up.

    It is connected to a VDSL modem (in bridging mode) through eth0. Eth1 is the interface for masquerading.

    I have installed rppoe, run pppoe-setup, and the machine connects fine when I run pppoe-start ('ip link' shows ppp0 UP and 'ip addr' shows both my public IP and the remote peer's IP and the machine has internet access).

    However it will do nothing if I run 'ifup ppp0'. It will say "PPP0 - Interface not found" with 0 additional information in the system log.

    Running YaST shows that along with eth0 and eth1, there also a PPP0 connection (obviously from running pppoe-setup), it is configured as "Activate Device: At boot time", but that doesn't work. The only thing that works is running pppoe-start manually as root.

    If there's no way to configure this through YaST that's fine, I'll setup something as a boot script or a system service but I would rather use an existing method that will persist through system updates.

    Thank you!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,895
    Blog Entries
    1

    Default Re: PPPoE VDSL connection start on boot

    Quote Originally Posted by ReverantGR View Post
    Hi, I have a machine with a VDSL connection that I want to automatically connect to the internet when it boots up.

    It is connected to a VDSL modem (in bridging mode) through eth0. Eth1 is the interface for masquerading.

    I have installed rppoe, run pppoe-setup, and the machine connects fine when I run pppoe-start ('ip link' shows ppp0 UP and 'ip addr' shows both my public IP and the remote peer's IP and the machine has internet access).

    However it will do nothing if I run 'ifup ppp0'. It will say "PPP0 - Interface not found" with 0 additional information in the system log.

    Running YaST shows that along with eth0 and eth1, there also a PPP0 connection (obviously from running pppoe-setup), it is configured as "Activate Device: At boot time", but that doesn't work. The only thing that works is running pppoe-start manually as root.

    If there's no way to configure this through YaST that's fine, I'll setup something as a boot script or a system service but I would rather use an existing method that will persist through system updates.

    Thank you!
    FWIW, NetworkManager can be used to manage DSL connectivity, and start a connection at boot if desired.

    However, the rp-pppoe package provides a pppoe.service unit that can manage connectivity at boot for you.

    Do the following to enable and start it immediately...
    Code:
    systemctl enable pppoe.service --now
    then check status with
    Code:
    systemctl status pppoe
    It should then take care of pppoe connectivity at boot.
    openSUSE Leap 15.3; KDE Plasma 5

  3. #3

    Default Re: PPPoE VDSL connection start on boot

    Thank you, this has solved my issue! Now to figure out how to disable/configure the firewall rules that get enabled when ppp0 comes up..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •