Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Yast and NFS-client how to set up?

  1. #1
    Join Date
    Nov 2008
    Posts
    2,314
    Blog Entries
    1

    Default Yast and NFS-client how to set up?

    I have always used Yast to set up an NFS client in the past but have just changed to Leap 15.3 on a newer system and cannot find the configuration tool in yast.
    What has happened to it, why and how do I get this working please?

  2. #2
    Join Date
    Nov 2008
    Posts
    2,314
    Blog Entries
    1

    Default Re: Yast and NFS-client how to set up?

    Solved it myself after a bit more reading but am annoyed that what works out of the box on TW did not work on Leap 15.3 without my trial and error approach.

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,788

    Default Re: Yast and NFS-client how to set up?

    Quote Originally Posted by Budgie2 View Post
    and cannot find the configuration tool in yast.
    You have to install the package “yast2-nfs-client” – it seems that, there're no dependencies present to automatically pull it in at installation time …

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,788

    Default Re: Yast and NFS-client how to set up?

    Quote Originally Posted by Budgie2 View Post
    I have always used Yast to set up an NFS client in the past
    BTW, on the NFS clients, I prefer to use on-demand mounting of NFS exports – <https://doc.opensuse.org/documentati...sec-autofs-nfs>.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,482

    Default Re: Yast and NFS-client how to set up?

    Quote Originally Posted by dcurtisfra View Post
    BTW, on the NFS clients, I prefer to use on-demand mounting of NFS exports – <https://doc.opensuse.org/documentati...sec-autofs-nfs>.
    I also would advise to use automounting, but I use systemd for that. Even easier to configure then good old Automounter.
    See https://wiki.archlinux.org/index.php...t_with_systemd

    In fact all I had to do is to add these options to the enty in/etc/fstab:
    Code:
    x-systemd.automount,x-systemd.mount-timeout=10,x-systemd.idle-timeout=5min
    My personal entry then reads:
    Code:
    boven.henm.xs4all.nl:/home/wij             /home/wij  nfs   noauto,nofail,x-systemd.automount,x-systemd.mount-timeout=10,_netdev,x-systemd.idle-timeout=5min          0  0
    The noauto and the nofail are for not mounting it on boot (that is not needed, because we mount it on need) and nofail to avoid extra problems when the moujnting fails. The _netdev is superfluous.
    You can of cource vary in the value of the x-stystemd.idle-timeout, after that many minutes of not being in use the fs will unmounted.
    Henk van Velden

  6. #6
    Join Date
    Nov 2008
    Posts
    2,314
    Blog Entries
    1

    Default Re: Yast and NFS-client how to set up?

    I have the NFS accessible now and can read files on the remote NAS server but I can no longer right click to create a new directory on the remote system.

    I assume it is a permissions issue but too difficult for me. How can I change this connection so I can write to the remote file system?

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,876
    Blog Entries
    1

    Default Re: Yast and NFS-client how to set up?

    Quote Originally Posted by Budgie2 View Post
    I have the NFS accessible now and can read files on the remote NAS server but I can no longer right click to create a new directory on the remote system.

    I assume it is a permissions issue but too difficult for me. How can I change this connection so I can write to the remote file system?
    How is the mount set up? Can you show us the pertinent details?
    openSUSE Leap 15.3; KDE Plasma 5

  8. #8
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    678

    Default Re: Yast and NFS-client how to set up?

    Quote Originally Posted by Budgie2 View Post
    I have the NFS accessible now and can read files on the remote NAS server but I can no longer right click to create a new directory on the remote system.

    I assume it is a permissions issue but too difficult for me. How can I change this connection so I can write to the remote file system?
    I'd say you just have to make sure to add the option "rw" to the nfs-mount. I have always ever only used YaST for NFS mounts. Did you follow dcurtisfra's avice? This is my (quite simple) fstab entry style I have for all my mounts created by YaST, now on 15.3:
    Code:
    server:/folder                             /home/user/targetfolder       nfs    rw,async                      0  0
    I don't know why, but these mounts now stay mounted even when closing the lid of my laptop down to suspend and opening it again, which didn't work until about half a year ago yet on 15.2.
    (Just note, "async" is no default setting. I am actually not sure if it is advisable but it works for me since many years. If you want to use it for the mount you need to use it as export option at the server, too. Otherwise just skip it or use "sync".)
    You may also want to make sure not to run into any compatibility issue with NFS version. Here in YaST the chart shows "NFS version" - "any". The YaST module has a setting for this. I have to admit I don't know where that is reflected in fstab. It may probably be established by not specifically adding an NFS version.

  9. #9
    Join Date
    Nov 2008
    Posts
    2,314
    Blog Entries
    1

    Default Re: Yast and NFS-client how to set up?

    Quote Originally Posted by deano_ferrari View Post
    How is the mount set up? Can you show us the pertinent details?
    Hi Deano,
    Many thanks for the reply.
    I set up my NFS using Yast. The server is an older Qnap NAS and doesn't have nfsv4 but works on versions 2 & 3 as far as I understand. On the yast tool I just selected the Any (highest available).

    Here is the line in my /etc/fstab:-

    Code:
    192.168.xxx.xxx:/Multimedia                /home/alastair/mastermedia  nfs    rw,async                      0  0
    
    
    I added the rw,async instead of defaults but no success yet.

    I have a suspicion that I don't have group or ownerships correct but no idea what used to work and does no longer.
    All help gratefully received.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,482

    Default Re: Yast and NFS-client how to set up?

    I would say:
    Why rw if that is already the default?
    Why async, did you read what it is intended to do and have you a reason you want that?

    And, a so often, please show what does not work and e.g. what iwnership and permissions are. Like:
    Code:
    ls -ld /home/alastair/mastermedia
    Code:
    ls -l /home/alastair/mastermedia
    BTW, there is no reason to obfuscate the IP address in your fstab entry. The 192.168.1/24 range is a private address range (and can not be connected to from outside the LAN) and many thousands of people use it because most Internet providers have it as standard in their routers.
    Last edited by hcvv; 22-Jan-2022 at 09:09.
    Henk van Velden

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •