Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: DHCP failed to start

  1. #1

    Red face DHCP failed to start

    Hi everybody,

    since today I constantly get notifications from (AFAIK) Network Manager : Wired Connection (eth0) - DHCP failed to start. Connection is going constantly up and down. I don't know what I changed to the system, in my opinion : nothing. I haven't updated since some days, and yesterday there were no problem. Getting access to a web site is getting hard, 3 times out of 4 I can't reach it. I'm on dualboot, connection is working perfectly on Windows. I haven't fetched anything really easy to apply from the web, nor from this forum. Nothing anyway that could point out where does such a sudden issue come from.

    Message in a bottle ...

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,509

    Default Re: DHCP failed to start

    Such problems that pop up unexpected are often the most difficult ones. I believe you when you say you did not update because since the beginning of this month 15.2 is without support, thus there will not be any updates anymore.

    But such on and off problems without any software change often point to hardware. Maybe check connection, cable, etc. to be sure.
    Henk van Velden

  3. #3

    Default Re: DHCP failed to start

    Hi Henk, thanks for your reply. I planned to upgrade to 15.3 but I did'nt do it yet. I hadn't noticed there were no more support, since there are still some updates for some apps.

    Do you think it could be a hardware problem that would not appear on the same machine with a different OS ? That's why, after changing my CPL, unplugging and plugging ethernet cable etc. (the weather is very wet in the moment in Reunion Island, it could effectively cause connection issues) I had finally let this possibility down ... and the network card is of course integrated in the mother board.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,509

    Default Re: DHCP failed to start

    I only suggested that it could be hardware, taking into account that nothing changed software wise (systems that do not get updates anymore are mostly very stable softwarewise, but there are of course draw backs in not getting security patches). Only that you would not forget it could be hardware.
    Henk van Velden

  5. #5

    Default Re: DHCP failed to start [SOLVED]

    Hello

    @Hank Yes, it was logical to have a look upon hardware parts and especially connections, so thanks ! I was just wondering if you had another idea, because I was stuck.

    When I browsed the web yesterday, I read once or twice that disabling IPv6 could have helped some people, but I wasn't that much confident in this kind of fix. But I gave it a try today, and actually it worked.

    I had a look to journalctl and it was filled with those lines (among others related to NetworkManager and avahi-daemon) :
    Code:
    janv. 20 16:54:10 openSuse_xyz NetworkManager[1155]: <info>  [1642683250.8923] manager: NetworkManager state is now CONNECTED_GLOBAL
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <info>  [1642683253.3913] dhcp6 (eth0): activation: beginning transaction (timeout in 45 seconds)
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <warn>  [1642683253.3914] device (eth0): failure to start DHCPv6: failed to set DHCP hostname: Argument invalide
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <info>  [1642683253.3914] device (eth0): state change: activated -> failed (reason 'dhcp-start-failed', sys-iface-state: 'ma>
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <info>  [1642683253.3917] manager: NetworkManager state is now DISCONNECTED
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <warn>  [1642683253.3925] device (eth0): Activation: failed for connection 'Connexion filaire 1'
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <info>  [1642683253.3932] device (eth0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
    janv. 20 16:54:13 openSuse_xyz avahi-daemon[1009]: Withdrawing address record for fe80::faf6:9d3c:15a:1e7d on eth0.
    janv. 20 16:54:13 openSuse_xyz avahi-daemon[1009]: Leaving mDNS multicast group on interface eth0.IPv6 with address fe80::faf6:9d3c:15a:1e7d.
    janv. 20 16:54:13 openSuse_xyz avahi-daemon[1009]: Interface eth0.IPv6 no longer relevant for mDNS.
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <info>  [1642683253.4082] dhcp4 (eth0): canceled DHCP transaction
    janv. 20 16:54:13 openSuse_xyz NetworkManager[1155]: <info>  [1642683253.4083] dhcp4 (eth0): state changed bound -> done
    janv. 20 16:54:13 openSuse_xyz avahi-daemon[1009]: Withdrawing address record for 192.168.1.111 on eth0.
    janv. 20 16:54:13 openSuse_xyz avahi-daemon[1009]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.1.111.
    janv. 20 16:54:13 openSuse_xyz avahi-daemon[1009]: Interface eth0.IPv4 no longer relevant for mDNS.
    So it looks like NetworkManager can't start DHCP in IPv6 mode, then it disconnects the IPv4 address too. Then it will try to reconnect, it will work a bit but disconnect again etc.

    My connection is now stable, but I still don't know what caused the problem (I was wrong when I told that I hadn't made any change to the system recently. In fact, I installed some packages related to KMail, an audio mixer and pavucontrol. But I don't see how it could interfere with NetworkManager ?). I hope that disabling IPv6 won't have any side effect. I assume that it is not very useful in a home network (?).

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,509

    Default Re: DHCP failed to start

    Hm, I am not using NetworkManager, nor DHCP (that is why I only hinted at checking hardware without much further help).

    I am using IPv6 now since many years without any problem, thus I always wonder why switching it off in trouble cases often seems to help.

    In a home network having no IPv6 is not a problem (all systems will probably have IPv4 addresses in a private address range), but it could be that you can not connect to sites that have only IPv6 addresses. And those should exist, else the message "IPv6 is needed because we run out of IPv4 addresses" is a hoax.

    Of course things also depend on your DHCP server. Maybe your provider changed something there.

    BTW, the openSUSE forums has both:
    Code:
    henk@boven:~> host forums.opensuse.org
    forums.opensuse.org is an alias for login2.opensuse.org.
    login2.opensuse.org has address 195.135.221.161
    login2.opensuse.org has IPv6 address 2001:67c:2178:8::161
    henk@boven:~>
    Henk van Velden

  7. #7

    Default Re: DHCP failed to start

    Sorry for the misspelling, @Henk and not @Hank!

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,509

    Default Re: DHCP failed to start

    Quote Originally Posted by Voronamanga View Post
    Sorry for the misspelling, @Henk and not @Hank!
    Never mind, I understood who you meant.
    Henk van Velden

  9. #9

    Default Re: DHCP failed to start

    That is more complex than I thought (it could be a mantra). I was assuming that network managers were only managing internal addresses and were not involved in external ones (that is, web addresses in the case of a home network). I'll be looking for a course on that matter!

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,509

    Default Re: DHCP failed to start

    NetworkManager manages your NICs, your routing and your DNS configuration. All on that one single system.

    I am not sure what you mean with it having to do anything with other (either inside your LAN, or outside on the Internet) addresses. After everyting is configured and started by Network Manager, it does not do much more then watching. The kernel has the IP stacks, the routing tables, etc.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •