Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: 90 Sekunden stop job beim Shutdown. Warum? Was?

  1. #31
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    4,347
    Blog Entries
    5

    Default Re: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Quote Originally Posted by wodenhof View Post
    Okay, danke. Wie gut, dass es das Forum gibt, ich alleine hätte da keine Chance. Nochmals danke und kann man den Thread kennzeichnen, dass er die Lösung enthält?
    Das ist hier nicht üblich.
    openSUSE Tumbleweed, KDE Plasma, Blogs/KeepItSimple, i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X, 5700U (2022)

  2. #32
    Join Date
    Jan 2021
    Location
    Vachdorf
    Posts
    45

    Default AW: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Quote Originally Posted by Kanonentux View Post
    Bei mir "erscheint" "das" auch ab und zu bei Leap.
    Ich denke, da ist noch "wer" der denkt, er müsse noch etwas tun vor dem Runterfahren.
    Wenn alle Programme geschlossen sind, passiert das vermutlich nicht.
    Da ich "mehrerere" Mailadressen habe, kann es doch sein, das der "Wicht" in meinen System sagt:
    "Ich muß erst Deine gefühlten 17000 Mailverbindungen trennen und sei zufrieden, daß das nur 90 sec dauert."
    Ich nehme alles zurück, und behaupte das Gegenteil.
    Alles offen gelassen, es sind nur 11 Mailadressen!!!, mehrere Tabs im Vivaldi, und fährt runter wie er soll.

  3. #33

    Cool Re: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Hallo zusammen,

    da ich das Problem auch hatte, aber Kleopatra brauche (meine ich zumindest!), kann man alternativ scdaemon auch deaktivieren. Dazu in
    Code:
    ~/.gnupg/gpg-agent.conf
    einfach
    Code:
    disable-scdaemon
    eintragen. Dann muss man Kleopatra nicht deinstallieren. Habe das mit Kommentar gemacht, da in dem Fall z.B. ein Yubi-Key nicht mehr funktionieren würde, denn dafür ist der Daemon...

    Warum er Amok läuft und sich nicht beendet, ist mir aber auch nicht klar. Sieht dann bei mir so aus:
    Code:
    default-cache-ttl 300
    max-cache-ttl 999999
    
    # This is necessary, as scdaemon will not stop
    # !!This will disable use of yubikeys and other
    # secure card readers!!
    disable-scdaemon
    Vielleicht hilft das noch jemandem

  4. #34

    Default Re: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Danke für Deinen Input. Ich habe eben mal nachgesehen:
    Code:
    me@ryzen:~> sudo zypper if kleopatra 
    Metadaten von Repository 'Packman Repository' abrufen .........................................................................................................................[fertig] 
    Cache für Repository 'Packman Repository' erzeugen ............................................................................................................................[fertig] 
    Repository-Daten werden geladen... 
    Installierte Pakete werden gelesen... 
    
    
    Informationen zu Paket kleopatra: 
    --------------------------------- 
    Repository         : Haupt-Repository (OSS) 
    Name               : kleopatra 
    Version            : 21.12.2-1.1 
    Arch               : x86_64 
    Anbieter           : openSUSE 
    Installierte Größe : 4,3 MiB 
    Installiert        : Ja (automatisch) 
    Status             : aktuell 
    Quellpaket         : kleopatra-21.12.2-1.1.src 
    Zusammenfassung    : Certificate manager and GUI for OpenPGP and CMS cryptography 
    Beschreibung       :  
        Kleopatra is a certificate manager and GUI for OpenPGP and CMS cryptography. 
    
    me@ryzen:~> 
    
    Da ist sie ja wieder. Wurde also automatisch von tumbleweed neu installiert. Jetzt macht sie aber keine Probleme mehr, Wartezeit ist nicht wieder aufgetreten. Vielleicht ist sie einfach zu sensibel für das harte Dasein in der IT .

  5. #35

    Default Re: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Quote Originally Posted by wodenhof View Post
    Da ist sie ja wieder. Wurde also automatisch von tumbleweed neu installiert. Jetzt macht sie aber keine Probleme mehr, Wartezeit ist nicht wieder aufgetreten. Vielleicht ist sie einfach zu sensibel für das harte Dasein in der IT .
    Leider kann ich das so nicht bestätigen. Kleopatra startet nicht generell automatisch, so scheint es mir. Nur, wenn man sie mal gestartet hatte und dann vor reboot nicht beendet, dann startet sie auch automatisch wieder hoch.
    In dem Fall wird auch PGP gestartet und ohne die obige Anpassung startet dann auch scdaemon wieder.
    Code:
    quippy@quippy:~> sudo ps ax | grep scdaemon 
     3027 ?        SLl    0:00 scdaemon --multi-server 
     9200 pts/0    S+     0:00 grep --color=auto scdaemon
    quippy@quippy:~>
    Damit habe ich wieder Wartezeit beim runterfahren. Also disable wieder rein:

    Code:
    quippy@quippy:~> cat ~/.gnupg/gpg-agent.conf    
    default-cache-ttl 300 
    max-cache-ttl 999999 
    
    # This is necessary, as scdaemon will not stop 
    # !!This will disable use of yubikeys and other 
    # secure card readers!! 
    disable-scdaemon 
    quippy@quippy:~>
    Dann kann Kleopatra ruhig starten, keine Wartezeit beim Booten. Es ist nicht Kleopatra schuld, sondern der sich nicht beenden wollende scdaemon - warum auch immer der so renitent ist.

  6. #36

    Default Re: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Ich habe das selbe Problem bei mir und es sieht so aus, als ob scdaemon von gpg-agent neu gestartet wird, sobald es mit kill beendet wird.
    Wenn ich den Prozess gpg-agent von Hand stoppe ( kill -9 ) fährt mein System schnell herunter.

  7. #37
    Join Date
    Jan 2021
    Location
    Vachdorf
    Posts
    45

    Default AW: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Ein "was" habe ich gefunden.
    Es werden zwei "funktionierende" Kernel gespeichert.
    Wenn es einen dritten "funktionierenden" Kernel gibt,
    wird der älteste gelöscht, damit nur zwei Kernel den "wertvollen" Speicherplatz belegen.
    Das dauert zwei bis drei Minuten (bei mir), und es steht etwas von purge old kernel in der Konsole.
    Danach läuft das Ganze so wie es soll.
    Ein Zeitlimit gibt es dabei nicht.
    Leap 15.3

  8. #38

    Smile Re: 90 Sekunden stop job beim Shutdown. Warum? Was?

    Bei mir ist das Problem seit ein paar Tagen verschwunden, nachdem ich einen Update eingespielt habe.

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •