Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: How to restart the CUPS daemon ?

  1. #1

    Default How to restart the CUPS daemon ?

    Hi,
    I am trying to install a local network printer using YAST.
    When I start the printer application I get a message "Restart locally running CUPS daemon". I answer "yes". I then get an error message "Error failed to restart the CUPS daemon" with details "Attempt to `restart` service 'cups' failed.ERROR: " with no more detail. I then get the error message "A locally running CUPS daemon is required, but it seems to be not accessible. Check with 'lpstat -h localhost -r' whether a local cupsd is accessible. A non-accessible cupsd leads to an endless sequence of further failures."
    Output for lpstat :

    Code:
    noot@localhost:~> lpstat -h localhost -r
    scheduler is not running
    



    The KDE printer installer won't work either , startup message "Print service is unavailable-bad file descriptor".
    How to get the CUPS daemon up and running again ?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,460

    Default Re: How to restart the CUPS daemon ?

    Quote Originally Posted by nootnl View Post
    Hi,
    I am trying to install a local network printer using YAST.
    This is an important point. You try, but you do not tell what exactly you did. Thus it is rather impossible for others to comment on that.

    BTW to start CUPS (as root):
    Code:
    systemctl start cups
    (and for restart, the restart command)
    But better first check it's status:
    Code:
    systemctl status cups
    Henk van Velden

  3. #3

    Default Re: How to restart the CUPS daemon ?

    Sorry, i have this issue for a good number of months now, I cannot recall how I ended up in this situation.

    Output :

    Code:
    localhost:/home/noot # systemctl status cups
    × cups.service - CUPS Scheduler
         Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
         Active: failed (Result: protocol) since Mon 2022-01-10 11:39:19 CET; 1h 9min ago
    TriggeredBy: × cups.socket
                 × cups.path
           Docs: man:cupsd(8)
        Process: 1527 ExecStart=/usr/sbin/cupsd -l (code=killed, signal=TERM)
       Main PID: 1527 (code=killed, signal=TERM)
            CPU: 5ms
    
    Jan 10 11:39:19 localhost systemd[1]: cups.service: Start request repeated too quickly.
    Jan 10 11:39:19 localhost systemd[1]: cups.service: Failed with result 'protocol'.
    Jan 10 11:39:19 localhost systemd[1]: Failed to start CUPS Scheduler.
    localhost:/home/noot # systemctl start cups
    Job for cups.service failed because the service did not take the steps required by its unit configuration.
    See "systemctl status cups.service" and "journalctl -xeu cups.service" for details.
    localhost:/home/noot # systemctl status cups.service
    ○ cups.service - CUPS Scheduler
         Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
         Active: inactive (dead) (Result: protocol) since Mon 2022-01-10 12:51:35 CET; 1min 23s ago
    TriggeredBy: × cups.socket
                 × cups.path
           Docs: man:cupsd(8)
        Process: 7575 ExecStart=/usr/sbin/cupsd -l (code=killed, signal=TERM)
       Main PID: 7575 (code=killed, signal=TERM)
            CPU: 5ms
    
    Jan 10 12:51:35 localhost.localdomain systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
    Jan 10 12:51:35 localhost.localdomain systemd[1]: Stopped CUPS Scheduler.
    Jan 10 12:51:35 localhost.localdomain systemd[1]: Dependency failed for CUPS Scheduler.
    Jan 10 12:51:35 localhost.localdomain systemd[1]: cups.service: Job cups.service/start failed with result 'dependency'.
    localhost:/home/noot # systemctl status cups.service
    ○ cups.service - CUPS Scheduler
         Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
         Active: inactive (dead) (Result: protocol) since Mon 2022-01-10 12:51:35 CET; 2min 18s ago
    TriggeredBy: × cups.socket
                 × cups.path
           Docs: man:cupsd(8)
        Process: 7575 ExecStart=/usr/sbin/cupsd -l (code=killed, signal=TERM)
       Main PID: 7575 (code=killed, signal=TERM)
            CPU: 5ms
    
    Jan 10 12:51:35 localhost.localdomain systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
    Jan 10 12:51:35 localhost.localdomain systemd[1]: Stopped CUPS Scheduler.
    Jan 10 12:51:35 localhost.localdomain systemd[1]: Dependency failed for CUPS Scheduler.
    Jan 10 12:51:35 localhost.localdomain systemd[1]: cups.service: Job cups.service/start failed with result 'dependency'.
    localhost:/home/noot #
    

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,670

    Default Re: How to restart the CUPS daemon ?

    Quote Originally Posted by nootnl View Post
    Sorry, i have this issue for a good number of months now, I cannot recall how I ended up in this situation.
    You may search for cups stuff and run "zypper install --force" for each of the packages found:
    Code:
    erlangen:~ # zypper se -is cups 
    Loading repository data... 
    Reading installed packages... 
    
    S  | Name                | Type    | Version      | Arch   | Repository 
    ---+---------------------+---------+--------------+--------+----------------------- 
    i+ | cups                | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | cups-client         | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | cups-config         | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | cups-filters        | package | 1.28.8-3.2   | x86_64 | Haupt-Repository (OSS) 
    i  | libcups2            | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i+ | libcups2-32bit      | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | libcupsimage2       | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | python3-cupshelpers | package | 1.5.15-2.2   | noarch | Haupt-Repository (OSS) 
    i  | python38-pycups     | package | 2.0.1-1.8    | x86_64 | Haupt-Repository (OSS) 
    erlangen:~ #
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

  5. #5

    Default Re: How to restart the CUPS daemon ?

    Quote Originally Posted by karlmistelberger View Post
    You may search for cups stuff and run "zypper install --force" for each of the packages found:
    Code:
    erlangen:~ # zypper se -is cups 
    Loading repository data... 
    Reading installed packages... 
    
    S  | Name                | Type    | Version      | Arch   | Repository 
    ---+---------------------+---------+--------------+--------+----------------------- 
    i+ | cups                | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | cups-client         | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | cups-config         | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | cups-filters        | package | 1.28.8-3.2   | x86_64 | Haupt-Repository (OSS) 
    i  | libcups2            | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i+ | libcups2-32bit      | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | libcupsimage2       | package | 2.3.3op2-8.1 | x86_64 | Haupt-Repository (OSS) 
    i  | python3-cupshelpers | package | 1.5.15-2.2   | noarch | Haupt-Repository (OSS) 
    i  | python38-pycups     | package | 2.0.1-1.8    | x86_64 | Haupt-Repository (OSS) 
    erlangen:~ #

    Thanks. My output shows all duplicates and an older version of python38-pycups ?

    Code:
    noot@localhost:~> sudo zypper se -is cups
    Loading repository data...
    Reading installed packages...
    
    S  | Name                | Type    | Version      | Arch   | Repository
    ---+---------------------+---------+--------------+--------+----------------------
    i  | cups                | package | 2.3.3op2-8.1 | x86_64 | Main Repository (OSS)
    i  | cups                | package | 2.3.3op2-8.1 | x86_64 | openSUSE-20200721-0
    i+ | cups-airprint       | package | 1.1-1.5      | noarch | (System Packages)
    i  | cups-client         | package | 2.3.3op2-8.1 | x86_64 | Main Repository (OSS)
    i  | cups-client         | package | 2.3.3op2-8.1 | x86_64 | openSUSE-20200721-0
    i+ | cups-config         | package | 2.3.3op2-8.1 | x86_64 | Main Repository (OSS)
    i+ | cups-config         | package | 2.3.3op2-8.1 | x86_64 | openSUSE-20200721-0
    i+ | cups-filters        | package | 1.28.8-3.2   | x86_64 | Main Repository (OSS)
    i+ | cups-filters        | package | 1.28.8-3.2   | x86_64 | openSUSE-20200721-0
    i  | libcups2            | package | 2.3.3op2-8.1 | x86_64 | Main Repository (OSS)
    i  | libcups2            | package | 2.3.3op2-8.1 | x86_64 | openSUSE-20200721-0
    i+ | libcups2-32bit      | package | 2.3.3op2-8.1 | x86_64 | Main Repository (OSS)
    i+ | libcups2-32bit      | package | 2.3.3op2-8.1 | x86_64 | openSUSE-20200721-0
    i  | libcupsimage2       | package | 2.3.3op2-8.1 | x86_64 | Main Repository (OSS)
    i  | libcupsimage2       | package | 2.3.3op2-8.1 | x86_64 | openSUSE-20200721-0
    i+ | python3-cupshelpers | package | 1.5.15-2.2   | noarch | Main Repository (OSS)
    i+ | python3-cupshelpers | package | 1.5.15-2.2   | noarch | openSUSE-20200721-0
    i+ | python38-pycups     | package | 2.0.1-1.7    | x86_64 | (System Packages)
    noot@localhost:~> 
    More suggestions ?

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,460

    Default Re: How to restart the CUPS daemon ?

    As you can see yourself, you seem to have double versions of several packages installed, from different repos.

    Can you please post
    Code:
    zypper lr -d
    Henk van Velden

  7. #7

    Default Re: How to restart the CUPS daemon ?

    Quote Originally Posted by hcvv View Post
    As you can see yourself, you seem to have double versions of several packages installed, from different repos.

    Can you please post
    Code:
    zypper lr -d
    As additional info, I have another thread running as I experience update problems too.
    One of the suggestions there is too reduce the number of repositories to the bare minimum.

    Output:

    Code:
    noot@localhost:~> sudo zypper lr -d
    [sudo] password for root:  
    #  | Alias                                  | Name                      | Enabled | GPG Check | Refresh | Priority | Type     | URI                                                                          | Service
    ---+----------------------------------------+---------------------------+---------+-----------+---------+----------+----------+------------------------------------------------------------------------------+--------
     1 | Downloads                              | Downloads                 | Yes     | ( p) Yes  | Yes     |   99     | plaindir | dir:/home/noot/Downloads                                                     |  
     2 | brave-browser                          | brave-browser             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://brave-browser-rpm-release.s3.brave.com/x86_64/                       |  
     3 | download.nvidia.com-tumbleweed         | nVidia Graphics Drivers   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://download.nvidia.com/opensuse/tumbleweed                              |  
     4 | download.opensuse.org-non-oss          | Main Repository (NON-OSS) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/tumbleweed/repo/non-oss/                        |  
     5 | download.opensuse.org-oss              | Main Repository (OSS)     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/tumbleweed/repo/oss/                            |  
     6 | download.opensuse.org-tumbleweed       | Main Update Repository    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/tumbleweed/                              |  
     7 | openSUSE-20200721-0                    | openSUSE-20200721-0       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/tumbleweed/repo/oss/                            |  
     8 | openSUSE_Tumbleweed                    | Packman                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/                          |  
     9 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                          |  
    10 | oss                                    | tmp                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                |  
    11 | snappy                                 | snappy                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.0 |  
    noot@localhost:~>
    Would that be applicable in this issue too?

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,460

    Default Re: How to restart the CUPS daemon ?

    Well, I don't know if it is the reason for this printer problem. but you can see that you #5 and #7 are the same (they have the same URL, thus even when they have different names ans aliases, they still point to the same repository and that is also the reason that packages are mentioned twice). Advice: remove #7.

    Then you say you run Tumbleweed, but #10 is for 15.2, and yes that can give problems. Advice: remove it.

    #11 is even for 15.0. I have no idea where you have it for, but when you need packages from it, better change to a Tumbleweed version of that repo.

    After you have repaired this list, you should do a
    Code:
    zypper dup
    to be sure that now all packages are from the correct repos. Only after that it will be relevant to address any problems.
    Henk van Velden

  9. #9

    Default Re: How to restart the CUPS daemon ?

    OK, was able to perform the zypper dup after cleaning up the repositories, updated some 3000+ items and rebooted.
    System started up normally. The Yast printer installer however did not work, same problem as described above.
    I will go through the steps suggested earlier and come back with the results.

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,670

    Default Re: How to restart the CUPS daemon ?

    Quote Originally Posted by nootnl View Post
    OK, was able to perform the zypper dup after cleaning up the repositories, updated some 3000+ items and rebooted.
    System started up normally. The Yast printer installer however did not work, same problem as described above.
    I will go through the steps suggested earlier and come back with the results.
    As a courtesy to users willing to help you may temporarily disable all repos but the following and upgrade:
    Code:
    erlangen:~ # zypper lr -uEP 
    #  | Alias                            | Name                            | Enabled | GPG Check | Refresh | Priority | URI 
    ---+----------------------------------+---------------------------------+---------+-----------+---------+----------+-------------------------------------------------------------------------------- 
     5 | Packman                          | Packman                         | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/ 
     8 | download.opensuse.org-non-oss    | Haupt-Repository (NON-OSS)      | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/ 
     9 | download.opensuse.org-oss        | Haupt-Repository (OSS)          | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/ 
    10 | download.opensuse.org-tumbleweed | Hauptaktualisierungs-Repository | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/ 
    erlangen:~ # zypper dist-upgrade --allow-vendor-change  
    Loading repository data... 
    Reading installed packages... 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command. 
    Computing distribution upgrade... 
    Nothing to do. 
    erlangen:~ #
    i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), 5600X (2022) openSUSE Tumbleweed, KDE Plasma

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •