Results 1 to 10 of 10

Thread: WiFi regularly disconnects and asks for password to reconnect

  1. #1

    Default WiFi regularly disconnects and asks for password to reconnect

    My wi-fi connection keeps dropping out (disconnecting). I get a popup window asking for the wifi password, which I enter and then it reconnects for a short while.
    Is the wifi access password not stored anywhere so it can auto-connect?

    Magni

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,951

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    Hello and welcome to the openSUSE forums.

    As Linux (and thus openSUSE) has huge amount of choices and variations of using the system and the applications and as we can not look over you shoulder, please tell us what you are using.

    For network e.g. are you using WIcked or NetworkManager? in the second case, what desktop environment? Maybe other details about your network environment.
    Henk van Velden

  3. #3

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    Hi Henk and thanks for responding:
    Desktop is KDE Plasma version 5.18.6
    Kernel Version 5.3.18-lp152.106-default 64-bit
    I'm using NetworkManager

    General configuration for the adaptor is:
    Connect automatically with priority 1 - checked
    All users may connect to this network - checked

    Wi-Fi configuration is:
    Mode - Infrastructure

    Wi-Fi Security is:
    WPA/WPA/2 Personal
    Password *****
    Store Password for all users - selected

    IPV4 and IPV6 Methods are both Automatic

    Is there other information I can collect / pass? I'm not sure what information is required to help diagnose the problem

    Magni

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,951

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    The above is a good start. I do not use NetworkManeger, but others will tune in.
    Henk van Velden

  5. #5
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    709

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    This seems strange. I have the same set up and here it works well. The only difference is the priority setting. I have a "0" entered there - AFAIR it was default setting. I don't think that makes a big difference. I assume you are using the plasma applet? If the setting is stored for all users you must enter the root password. Did it ask you for it? Otherwise the settings can not be persistant.

    Edit:
    You can find the settings of your connection in: /etc/NetworkManager/system-connections/
    There is a file named after the SSID of your WLAN. The PSK must be there in plain text. Can you find it?

  6. #6

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    Hi Kasi,
    Yes the psk is there in plain text.
    I changed the priority from 0 to 1 to see if would help in any way, but it didn't.

    magni

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    Quote Originally Posted by Magni1 View Post
    Hi Kasi,
    Yes the psk is there in plain text.
    I changed the priority from 0 to 1 to see if would help in any way, but it didn't.

    magni
    Examination of the NetworkManager logging may be useful.
    Code:
    sudo journalctl -u NetworkManager
    *It can be lengthy, and you're looking for disconnection and reconnection logging.

    To watch it on the fly
    Code:
    sudo journalctl -fu NetworkManager
    then observe/capture the moments where you are getting disconnected and prompted to reconnect again.

    Share the wireless NIC/driver details...
    Code:
    /usr/sbin/hwinfo --wlan
    Similar archlinux thread...
    https://bbs.archlinux.org/viewtopic.php?id=228107
    openSUSE Leap 15.4; KDE Plasma 5

  8. #8

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    Hi Deano, thanks for the reply - here is my hwinfo:
    Code:
    07: PCI 100.0: 0282 WLAN controller
      [Created at pci.386]
      Unique ID: y9sn.MxvvoCwdjwB
      Parent ID: z8Q3.O8qDgKpXcV4
      SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: network
      Device Name: "Ralink WLAN Ralink RT3290LE Roma 802.11bgn 1x1 Wi-Fi + BT4.0 co"
      Model: "Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter"
      Vendor: pci 0x1814 "Ralink corp."
      Device: pci 0x3290 "RT3290 Wireless 802.11n 1T/1R PCIe"
      SubVendor: pci 0x103c "Hewlett-Packard Company"
      SubDevice: pci 0x18ec "Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter"
      Driver: "rt2800pci"
      Driver Modules: "rt2800pci"
      Device File: wlan0
      Features: WLAN
      Memory Range: 0x52510000-0x5251ffff (rw,non-prefetchable)
      IRQ: 16 (no events)
      HW Address: 68:94:23:a5:fb:e1
      Permanent HW Address: 68:94:23:a5:fb:e1
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
      WLAN encryption modes: WEP40 WEP104 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Module Alias: "pci:v00001814d00003290sv0000103Csd000018ECbc02sc80i00"
      Driver Info #0:
        Driver Status: rt2800pci is active
        Driver Activation Cmd: "modprobe rt2800pci"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #3 (PCI bridge)
    I don't know if the Ralink adaptor is Broadcom related (and the responses in the article you posted seemed to indicate it was broadcom harsware that was the culprit).

    The journalctl command is mainly handshake messages - other than this.

    Code:
    Dec 30 12:55:35 Linux-box NetworkManager[23358]: <warn>  [1640868935.6492] sup-iface[0x55bef09ca110,wlan0]: connection disconnected (reason -4)

    Magni

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    I really don't know what to advise here. Lots of results if you search "rt2800pci disconnects" online. Does this happen after machine has been suspended, or from boot as well?
    openSUSE Leap 15.4; KDE Plasma 5

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: WiFi regularly disconnects and asks for password to reconnect

    Quote Originally Posted by Magni1 View Post
    The journalctl command is mainly handshake messages - other than this.

    Code:
    Dec 30 12:55:35 Linux-box NetworkManager[23358]: <warn>  [1640868935.6492] sup-iface[0x55bef09ca110,wlan0]: connection disconnected (reason -4)

    Magni
    The NM reason codes are listed here...

    NM_DEVICE_STATE_REASON_CONFIG_FAILED The device could not be readied for configuration
    openSUSE Leap 15.4; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •