Results 1 to 7 of 7

Thread: Установка и запуск PUREBASIC

  1. #1

    Default Установка и запуск PUREBASIC

    Здравствуйте, Уважаемые.

    Данным прошу Вас помочь в решении следующей проблемы касательно темы.
    Для полноценной работы темы нужно установить следующие компоненты:

    g++
    libc6-dev
    libgnome2-dev
    libgtk-3-dev
    libsdl1.2-dev
    libwebkitgtk-3.0-dev
    libwebkitgtk-dev
    libxine2-dev
    libxxf86vm-dev
    unixodbc-dev

    На борту Tumbleweed + GNOME.

  2. #2

    Default Re: Установка и запуск PUREBASIC

    Прилагаю список установленных пакетов (выложил файл в облако). Может быть необходимые пакеты уже установлены и нужны инструкции для применения?

    https://cloud.mail.ru/public/UVUH/EJbP2knMr

  3. #3
    Join Date
    Sep 2012
    Posts
    8,064

    Default Re: Установка и запуск PUREBASIC

    Quote Originally Posted by ugulamjanov View Post
    g++
    gcc-c++
    libc6-dev
    glibc-devel
    libgnome2-dev
    GNOME2 нет в Tumbleweed
    libgtk-3-dev
    Скорее всего gtk3-devel
    libsdl1.2-dev
    libwebkitgtk-3.0-dev
    libwebkitgtk-dev
    libxine2-dev
    libxxf86vm-dev
    unixodbc-dev
    Пакеты разработки в openSUSE заканчиваются на -devel. Название может включать префикс lib, может не включать (как пример с gtk3). Ищете в списке пакетов по базовому имени (например, sdl), выбираете наиболее похожий с учетом требуемой версии (например, libSDL-devel), проверяете, что он подходит (например, сравниваете файлы). Если скрипт конфигурации вашей программы использует pkg-config, проще всего искать по нему:
    Code:
    bor@tw:~> zypper search --provides 'pkgconfig(gtk+-3.0)'
    Loading repository data...
    Reading installed packages...
    
    
    S | Name             | Summary                                         | Type
    --+------------------+-------------------------------------------------+--------
      | gtk3-devel       | Development files for the GTK+ toolkit librar-> | package
      | gtk3-devel-32bit | Development files for the GTK+ toolkit librar-> | package
    
    
        Note: For an extended search including not yet activated remote resources
        please use 'zypper search-packages'.
    bor@tw:~>

  4. #4

    Default Re: Установка и запуск PUREBASIC

    Означает ли данный отчет, что необходимые библиотеки уже установлены?

    S | Name | Summary | Type
    ---+---------------------------------+------------------------------------------------------------------------------+------
    i+ | WebKit2GTK-4.0-lang | Translations for package webkit2gtk3-soup2 | пакет
    i+ | WebKit2GTK-4.1-lang | Translations for package webkit2gtk3 | пакет
    i+ | glibc | Standard Shared Libraries (from the GNU C Library) | пакет
    i+ | glibc-devel | Include Files and Libraries Mandatory for Development | пакет
    i+ | glibc-extra | Extra binaries from GNU C Library | пакет
    i+ | glibc-lang | Translations for package glibc | пакет
    i+ | glibc-locale | Locale Data for Localized Programs | пакет
    i+ | glibc-locale-base | en_US Locale Data for Localized Programs | пакет
    i | java-17-openjdk-devel | OpenJDK 17 Development Environment | пакет
    i+ | libXinerama1 | Xinerama extension to the X11 Protocol | пакет
    i+ | libproxy1-pacrunner-webkit | Libproxy module to support WPAD/PAC parsing via the WebKit JavaScript Engine | пакет
    i+ | libstdc++-devel | The system GNU C++ development files | пакет
    i+ | libstdc++6-devel-gcc11 | Include Files and Libraries mandatory for Development | пакет
    i+ | libwebkit2gtk-4_0-37 | Library for rendering web content, GTK+ Port | пакет
    i+ | libwebkit2gtk-4_1-0 | Library for rendering web content, GTK+ Port | пакет
    i+ | libxcb-xinerama0 | X11 Xinerama Extension C library | пакет
    i+ | libxcrypt-devel | Development files for libxcrypt | пакет
    i+ | linux-glibc-devel | Linux headers for userspace development | пакет
    i+ | python38-devel | Include Files and Libraries Mandatory for Building Python Modules | пакет
    i+ | typelib-1_0-WebKit2-4_0 | Introspection bindings for webkit2gtk3-soup2 | пакет
    i+ | webkit2gtk-4_0-injected-bundles | Injected bundles for webkit2gtk3-soup2 | пакет
    i+ | webkit2gtk-4_1-injected-bundles | Injected bundles for webkit2gtk3 | пакет

  5. #5

    Default Re: Установка и запуск PUREBASIC

    Почти все указанные пакеты есть в ресурсе software.opensuse.org, но не устанавливаются.
    Буду разбираться и напишу по результатам.

  6. #6
    Join Date
    Sep 2012
    Posts
    8,064

    Default Re: Установка и запуск PUREBASIC

    Quote Originally Posted by ugulamjanov View Post
    Означает ли данный отчет, что необходимые библиотеки уже установлены?
    У вас установлены библиотеки, а вам требуются компоненты для разработки (компиляции прогамм, использующих эти библиотеки).

  7. #7

    Default Re: Установка и запуск PUREBASIC

    Quote Originally Posted by arvidjaar View Post
    У вас установлены библиотеки, а вам требуются компоненты для разработки (компиляции прогамм, использующих эти библиотеки).
    это ошибка компилятора в работе с системой:

    Package gtk+-3.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-3.0.pc'
    to the PKG_CONFIG_PATH environment variable
    Package 'gtk+-3.0', required by 'virtual:world', not found

    это список существующих пакетов:

    i | gtk3-data | Data files for the GTK+ toolkit library v3 | пакет
    | gtk3-debugsource | Debug sources for package gtk3 | пакет
    | gtk3-devel | Development files for the GTK+ toolkit library v3 | пакет
    | gtk3-devel-32bit | Development files for the GTK+ toolkit library v3 | пакет
    | gtk3-devel-32bit-debuginfo | Debug information for package gtk3-devel | пакет
    | gtk3-devel-debuginfo | Debug information for package gtk3-devel | пакет
    | gtk3-devel-doc | API documentation for the GTK+ toolkit library v3 | пакет
    | gtk3-doc | Библиотека инструментов GTK+ (версия 3) | пакет с исходным к

    как настроить ОС для работы компилятора именно с ее пакетами?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •